
T M

User Guide
Version 3.0 for Macintosh® and Windows®

PH OTOTO O L S
T M



© 1997 Extensis Corporation. This manual and the software described in it are copyrighted
with all rights reserved. Under the copyright laws, neither this manual nor the software may
be copied, in whole or part,without the written consent of Extensis Corporation, except in the
normal use of the software or to make a backup copy of the software. This exception does
not allow copies to be made for others. 

Extensis, the Extensis logo, PhotoTools, PhotoAnimator, PhotoBars, PhotoGroove, Photo-
CastShadow, PhotoBevel, PhotoEmboss, PhotoGlow, and PhotoButton are trademarks of
Extensis Corporation. Adobe and Adobe Photoshop are registered trademarks of Adobe
Systems Incorporated, which have been registered in the U.S. patent and trademark office and
in many other countries. Apple and Macintosh are registered trademarks of Apple Computer,
Inc. Microsoft and Microsoft Windows are registered trademarks of Microsoft Corporation.
All other trademarks are the property of their respective owners. 

Extensis warrants the disks on which the software is recorded to be free from defects in mate-
rials and faulty workmanship under normal use for a period of ninety (90) days from the orig-
inal date of purchase. If a defect occurs during the 90-day period, you may return the disks to
Extensis Corporation for a free replacement provided that you have previously registered your
product with Extensis Corporation. This warranty is limited to replacement and shall not
encompass any other damages, including but not limited to loss of profit, and special, inciden-
tal, or other similar claims. This software is provided on an “as is” basis. Except for the
express warranty set forth above, Extensis Corporation makes no other warranties, either
express or implied, regarding the enclosed software’s quality, performance, merchantability, or
fitness for a particular purpose.

2

Extensis Europe
Zonnebaan 34
3606 CB Maarssen
The Netherlands

Telephone: #31 (0)30 247 50 50
Fax: #31 (0)30 241 20 39
E-mail: extensis@euronet.nl

Extensis Corporation
1800 SW First Avenue, Suite 500
Portland, OR 97201

Telephone: (503) 274-2020
Fax: (503) 274-0530
Technical Support: (503) 274-7030
E-mail: support@extensis.com
http://www.extensis.com

Http://www.extensis.com


3

Introducing PhotoTools  . . . . . . . . . . . . . . . . . . . . .5
System and Software Requirements . . . . . . . . . . . . . . . . . . . . .5
Installation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
Technical Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .6
What is PhotoTools?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .7

PhotoTexture  . . . . . . . . . . . . . . . . . . . . . . . . . . . .10
Getting Started with PhotoTexture . . . . . . . . . . . . . . . . . . . . .10
Creating Textures  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .14
The Toolbox  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .17
Effects and Filters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .19

The PhotoEffects Plug-ins  . . . . . . . . . . . . . . . . . .33
Elements Common to All Effects . . . . . . . . . . . . . . . . . . . . . .34
Getting Started with PhotoEffects  . . . . . . . . . . . . . . . . . . . . .35
Common Elements Explained  . . . . . . . . . . . . . . . . . . . . . . . .38
Additional Information  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .46

PhotoButton  . . . . . . . . . . . . . . . . . . . . . . . . .49
Getting Started with PhotoButton  . . . . . . . . . . . . . . . . . .54
Creating Custom Shapes . . . . . . . . . . . . . . . . . . . . . . . . .60
Creating Custom Bevels  . . . . . . . . . . . . . . . . . . . . . . . . .62
Coloring Buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .67
Adding Textures and Bump Maps . . . . . . . . . . . . . . . . . .70

PhotoGroove . . . . . . . . . . . . . . . . . . . . . . . . .71

PhotoCastShadow  . . . . . . . . . . . . . . . . . . . .77

PhotoBevel . . . . . . . . . . . . . . . . . . . . . . . . . .84

PhotoEmboss  . . . . . . . . . . . . . . . . . . . . . . . .85

PhotoGlow  . . . . . . . . . . . . . . . . . . . . . . . . . .86

PhotoBars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .87
Getting Started with PhotoBars  . . . . . . . . . . . . . . . . . . . . . . .88

PhotoAnimator . . . . . . . . . . . . . . . . . . . . . . . . . .103
Getting Started with PhotoAnimator  . . . . . . . . . . . . . . . . . .104
Animation Functions and Settings . . . . . . . . . . . . . . . . . . . .109
Effect Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .110
Importing and Exporting  . . . . . . . . . . . . . . . . . . . . . . . . . . .117

Tutorials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .120
PhotoAnimator: Tutorials 1-5  . . . . . . . . . . . . . . . . . . . . . . .120
PhotoTexture/PhotoButton: Tutorials 6-7 . . . . . . . . . . . . . . .167

Appendix A: Keyboard Shortcuts  . . . . . . . . . . . .174

Appendix B: Troubleshooting  . . . . . . . . . . . . . . .176

Index  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .178

Contents



4



Welcome to Extensis™ P h o t o To o l s™! PhotoTools is a collection
of creativity and productivity tools that enable you to work
f a s t e r, easier, and more efficiently in A d o b e® P h o t o s h o p®. T h i s
powerful collection includes: PhotoTexture, PhotoAnimator,
PhotoGroove, PhotoButton, PhotoCastShadow, PhotoEmboss,
PhotoBevel, PhotoGlow, and PhotoBars.

PhotoTools 3.0 responds primarily to user requests by enhancing
the existing tools and adding three important new components:
PhotoTexture, a full-featured texture creator; PhotoAnimator, an
exciting animation editor; and PhotoGroove, an interactive
custom bevel maker with user defined bevel edges. These new
tools will have you producing stunning seamlessly tiled back-
grounds and complex animations in no time. Enhancements to the
existing plug-ins include the addition of user-defined shapes and
unlimited bevel capability in PhotoButton, and multiple shadows
from multiple light sources in PhotoCastShadow.

For quick and easy access, each component in the PhotoTo o l s
collection is available from the Extensis menu located in the
Photoshop menubar, and from the PhotoTools menu in the
Photoshop Filters menu. 

System and Software Requirements

To install and use Extensis PhotoTools, you will need the following:

M a c i nt o s h :
•   Power Macintosh® and PowerPC compatibles
•   3MB free hard drive space
•   Mac OS® System 7.5 or later 
• Adobe Photoshop 4.0 or later*

Wi n d ow s :
•   Pentium or faster PC 
•   3MB free hard drive space
•   Microsoft® Windows 95®, Windows 98®,

or Windows NT® 4.0
• Adobe Photoshop 4.0 or later*

* PhotoAnimator is a stand-alone application and does not require
P h o t o s h o p .

5

Introducing PhotoTools



Installation

You can find instructions for quick and easy installation on 
the CD-ROM that is included with your product or, if you
downloaded an Extensis product installer from our web site,
running the installer will place an informational Read Me on
your hard drive.

Technical Support

For questions regarding Extensis PhotoTools, please first refer to
this manual, which describes the features and basic operations.
We invite you to visit our PhotoTools page on the Extensis web-
site (www.extensis.com) for frequently asked questions and trou-
bleshooting tips.

If you have a question which is not addressed in this manual or
on the Extensis website, Technical Support is available by phone
at (503) 274-7030 Monday through Friday 8:00 a.m. to 5:00
p.m. Pacific time. When calling for technical support, please be at
your computer and have the following information available: your
Extensis PhotoTools registration number, your computer configu-
ration and your question or a description of the difficulty you’re
experiencing—what specifically occurs and when. Take note of
any displayed error numbers or messages and any other informa-
tion you think may be relevant.
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Tip

We can also be reached by:

Fax: (503) 274-0530

E-mail: support@extensis.com

I n t e r n e t :
h t t p : / / w w w. e x t e n s i s . c o m / s u p p o r t

http://www.extensis.com/support
http://www.extensis.com
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What is PhotoTools?

P h o t o Tools is a collection of creativity and productivity tools
that enable you to work faster, easier, and more efficiently in
A d o b e® P h o t o s h o p®.

The PhotoTools collection includes:

• PhotoTexture—A richly featured texture editor that lets
you design and create an unlimited variety of seamless textures
from scratch,
from a Photo-
shop selection,
or from an
imported JPEG
(.jpg) image.
Using prede-
fined texture
effects and 
filters and a
selection of
Photoshop-like
drawing tools
you can create seamless tiled backgrounds in a fraction of the
time it would normally take.

• PhotoAnimator—Astand-alone animation editor that helps
you create stunning and exciting animations with almost no
e ffort. Starting with raw animation elements saved either in

native Photoshop format (.psd), or as
GIF images (.gif), you can use Photo-
Animator’s intuitive tools to create the
animation and add special effects.
PhotoAnimator allows you to use layers
and to apply effects to resizeable cells and
preview the results as you go, so you can
see how your animation will look at every
step. And since PhotoAnimator is a stand-
alone application, you don’t need to have
Photoshop open to use it.



• PhotoEffects—Includes five plug-ins for you to use alone or in
combination to quickly create dazzling effects on any image,
and adds a sixth plug-in for creating consistent, stylized buttons
such as those used on web pages and in multimedia projects. 

With all the PhotoEffects plug-ins, see how your effects look in
real-time and in relationship to the background and surrounding
objects as you tweak, twist, blend, and shape using an effect
plug-in’s unique tools to achieve just the right overall look.
Change your mind at any time with multiple undos and redos—
even reset your effect and start over from scratch. Save the set-
tings for reuse and easy, one-click application. 

The six PhotoEffects plug-ins include:

• PhotoButton—Quickly construct beautifully rendered,
uniform matrices of buttons (such as those seen on web
pages and in multimedia projects) using your own custom
shape, or choose from 15 pre-defined but completely
customizable shapes. Shape,
color, bevel, and texturize
your “anchor” button, then 
see your effects applied to all
the other buttons. Use any combination of rotation angle,
corner radius, inner height, bevel height, width, and cur-
vature; change surface reflectivity, diffuse angle, and high-
light color, ratio, and direction; and add textures—includ-
ing bump maps—to create startlingly realistic 3-D buttons!

• PhotoGroove—Create complex custom beveled shapes
effortlessly using PhotoGroove’s interactive, infinitely
adjustable bevel shape editor.

• PhotoBevel, PhotoEmboss, and PhotoGlow—Create
professional-quality bevels, embosses, and glows. Adjust
image attributes using slider controls or numeric entry
fields. Save settings
for future use. And as
with all Photo-Effects
plug-ins, see how your
changes look as you
apply them—watch your
effect’s color change as you
move the mouse over the differ-
ent colors in the color pop-up window! 
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• PhotoCastShadow—Create simple drop shadows with one
click, or use any or all of 10 positioning and shaping tools
to interactively skew
shadows to your
desired per-
spective.
Easily
adjust
shadow
blur for
realistic 3-D
images. Isolate the
shadow on  its own lay-
er. Blend your shadow
with other pixel values in
the target layer. Add addi-
tional shadows for unique special effects. Creating realistic
shadows has never been this easy!

PhotoTools also includes the popular floating toolbar plug-in:

• PhotoBars—Helps you manage menu options and tasks by
making all menu and sub-menu commands available as click-
able buttons which you access from convenient toolbars.
Toolbars can be moved freely about in the display or embedded
along any edge of the display, and you can rearrange, add or
remove buttons and toolbars instantly. PhotoBars provides sev-
eral pre-configured toolbars of commonly used commands; use
these or create your own—even add buttons and toolbars for
new filters and plug-ins as you go!

All PhotoTools plug-ins share a consistent interface, and were
designed and tested to work smoothly with Photoshop versions
4.0 and later. We believe you’ll find PhotoTools a natural exten-
sion of Photoshop, and an invaluable tool in your creative arsenal. 

If you have questions, comments, suggestions, or we can help
you in any way, please contact us at our Web site,
h t t p : / / w w w.extensis.com, or at the location listed on page 2.
Contact information for technical support is given on page 6.

9
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PhotoTexture is a full-featured texture editor that lets you easi-
ly create textures that tile seamlessly over any number of tiles.
Create seamless custom textures from scratch using standard
Photoshop-like drawing and coloring tools, or work from any
Photoshop image or selection, or any imported JPEG image
(.jpg). Special filters and effects included with PhotoTexture
give you unlimited options for creating exciting seamless tex-
tures in minutes. Textures can be applied to an image and saved
as usual from Photoshop—in any format that Photoshop sup-
ports—or saved directly from PhotoTexture as a JPEG file.

PhotoTexture

A Tile Tab: Provides access to all 
texture editing options.

B Preview:Provides access to a larger
preview of the tiled texture. See
page 27.

C Toolbox: Standard Photoshop-like
tools for drawing and coloring texture
elements. See page 17.

D Drawing Area:Displays the texture as
you create and modify it. Tiles are
always displayed in a 3x3 matrix in
this window.

E Base Tile:Represents the pattern
area that is saved when the texture is
applied or saved.

F Size Marks Toggle: Toggle tile size
marks on or off. Or press the M key.

G Texture file options: Allows you to
create and save texture files. Dis-
plays tile size and resolution. See
page 13.

H Texture Effects:Provides special
effects and filters for creating custom
textures. See page 20.

I Help Box: Displays a description of
each tool or option as the mouse
passes over it.

J Cancel: Closes the dialog box with-
out making changes to the image.
Also Cancel by pressing
Command+“.” (period) [Alt+F4].

K Apply: Adds your selected effects to
the image and closes the dialog box.
You can also Apply the effect by
pressing Return or Enter.

EDA B C F

G

H

JI K

The PhotoTexture Dialog box

Tip

For a quick tutorial showing how
to create a texture in Photo-
Texture and add it to a button in
PhotoButton, see page 167.
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Getting Started with PhotoTexture

You can create textures in PhotoTexture in one of three ways: 

• Create a texture from scratch using the painting and coloring
tools and the special Effects and Filters in PhotoTexture.

• Specify a Photoshop image or selection area to be used as the
base for the texture.

• Import an existing JPEG (.jpg) image directly into PhotoTe x t u r e
to be used as the base for a texture. 

You create textures by designing a “base tile” that can be replicat-
ed numerous times to create an overall texture effect. Typically
you would want your pattern to be as seamless as possible so that
no matter how large an area it is applied to, you will not see
where the initial pattern begins and ends. With PhotoTexture you
can create exciting seamless textures with ease.

As you create your base tile, PhotoTexture helps you visualize
your texture by displaying a 3x3 tile matrix and replicating your
base tile design over the nine tiles. The center tile in the Drawing
Area represents your base tile; it is delineated by Size Marks in
each of the four corners so you can continue to see the base tile
pattern as the texture develops. 

Base tile replicated over 3x3 tile matrix 

Base tile saved

Base tile size

Tip

PhotoTexture only works with
images in the RGB color space.

Tip

To toggle the Size Marks on or off,
press the M key.
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Use PhotoTexture’s customizable Effects and Filters to create
interesting patterns with just a few clicks—or customize Effects
or Filters and save your settings for future use. You can reapply
an Effect or Filter as many times as you like to achieve just the
right effect, and even combine your design with previously saved
textures. Add additional touches to your textures with common
painting tools like Paintbrush, Paint bucket, Pencil, Rubber
Stamp, and more.

When you’ve created a tile design that you like, you can save it
in one of two ways:

• Apply the texture to an image or selection area in Photoshop
(or to a blank Photoshop document, if you are creating a
texture from scratch).

• Save the texture directly from PhotoTexture as a JPEG (.jpg)
format file.

If file size is not a problem, you can replicate your base tile right
in PhotoTexture to create a larger tile (up to 512 x 512 pixels)
before saving.  
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Texture File Options allow you to cre-
ate, edit, and save your texture. 

A Texture Name: Displays texture
name, if a texture name exists.

B Width and Height: Displays the size
of the base tile.

C New: Opens the New texture dialog
allowing you to create a new texture.
Discards the current texture, if any.

D Open/Save: Allows you to locate and
open a JPEG file to be used as a
base tile for the texture, or to save a
texture as a JPEG format file. See
page 16.

E Tile Size and Resolution: Displays
the file size and resolution of the
base tile. Size is calculated based on
the Width, Height, and Resolution of
the base tile. Resolution is informa-
tional and cannot be changed in
PhotoTexture.

F Edit: Opens the Edit dialog allowing
you to modify the Name, Width, or
Height of the current texture.

New texture/Edit texture dialogs:

G Texture Name field: Enter a name for
the texture. A texture name is not
necessary if the texture will be
applied to a Photoshop selection.

H Width and Height fields: Displays the
size of the current base tile. Enter the
size of the base tile that you wish to
create. See page 11.

I Measurement pop-up menu:
Determines which unit of measure
Width and Height values will be dis-
played in. Options are Pixels, Inches,
Centimeters.

J Contents: Determines what will form
the basis of the texture. Options are:
Blank, Selection from Photoshop, or
Continue with last Texture.

K OK: Accepts the settings and creates
(or changes) the base tile based on
the selections in the dialog.

L Show this dialog next time: When
checked, opens the New dialog when
PhotoTexture is opened. When
unchecked, automatically opens
PhotoTexture in “Selection from
Photoshop” mode.

A

F

B

H

J

E

Texture File Options

C

I

K

L

H

G

D

I

K
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Creating Textures from Scratch

When you create a texture from scratch, you first create a blank
document in Photoshop at the size that you want, choose RGB
mode, then open PhotoTexture. PhotoTexture automatically cre-
ates a base tile the same size as the active document.  

To create your tile pattern, simply start drawing with the
PhotoTexture painting tools, or create a base pattern using any
combination of Effects and Filters. As you draw or add effects,
the pattern is replicated over all the tiles. You can turn the tile
size marks off and on to get a better idea of how the pattern will
look, and you can reposition the pattern on the tile by moving it
around with the Move tool. To see the pattern replicated over a
larger area, select the Preview tab. 

To create a texture from scratch:

1. Open Photoshop.

2. Open a new document (Command-N [Ctrl+N]) and
specify the size para m e t e rs that you want for yo u r
base tile. Ve rify that RGB is the active mode.

When you  “Apply” your texture from PhotoTexture it is
automatically applied to the active document.

N o t e : When no selection area is specifi e d, the entire image
a rea is assumed. See page x for info rm ation on using a
selection area as the base for the tex t u re.

3. Open PhotoTexture by choosing “PhotoTexture” from
the Extensis menu.

The New texture dialog will be displayed.

4. Click the “Blank” radio button.

This indicates that you want to create a texture from
scratch, using a blank tile. P h o t o Texture will create a base
tile the same the height and width as the Photoshop docu-
ment you created in step 1.

5. You can now create your texture using PhotoTexture
Effects, Filters, and tools (see pages 19-26). When you
have created a texture that you like, click “Apply” to
apply it to your Photoshop document (see page 19).
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Creating Textures from a Photoshop Selection

When you select a Photoshop image or an area of the image using
Photoshop selection tools (such as the marquee tools), the selec-
tion area is replaced by the newly created texture when you click
the Apply button in PhotoTexture. Creating a texture from an
existing image may not allow you to create the kind of seamless
textures that are possible when creating textures from scratch. For
more information on Photoshop selections, refer to your
Photoshop User Guide.

To create a texture from a Photoshop image or selection:

1. In Photoshop, open the image that you want to use for
the base tile. Select the area that you want to use.

If you do not specify a selection, PhotoTexture assumes that
you want to use the entire image.

2. Open PhotoTexture by choosing Extensis >
PhotoTexture.

The New texture dialog will be displayed.

3. Click the “Selection from Photoshop” radio button.

P h o t o Texture will use your selection as the base tile, and
replicate the image over the nine tiles in the 3x3 matrix in
the Drawing A r e a .

4. Modify the design using the PhotoTexture painting
tools, or combine Effects, Filters, and tools to create the
texture you want.

5. When you are finished creating your texture, click
“Apply” to apply the texture to your image.

Your new texture will replace the image or selection area. 

6. Save the Photoshop file in the normal way.
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Continuing with the Last Applied Texture

You can open PhotoTexture to the texture and settings that were
last applied. This is handy if you want to continue with a pattern
that you had started earlier, or if you want to create a larger
Photoshop file to apply the image to.

To continue with the last applied texture:

1. In Photoshop, either create a new file for the texture the
same size as the base tile you want to create.

If you do not specify a selection, PhotoTexture assumes that
you want to use the entire image.

2. Open PhotoTexture by choosing Extensis >
PhotoTexture.

The New texture dialog will be displayed.

3. Click the “Continue with last Texture” radio button.

P h o t o Texture will open with the tile size, pattern, and set-
tings that were last applied (or saved).

4. Modify the design using the PhotoTexture painting
tools, or combine Effects, Filters, and tools to create the
texture you want.

Creating Textures from an Existing File

You can create a new texture from an existing texture by opening
it directly in PhotoTexture. This feature allows you to create tex-
tures from scratch, save them from PhotoTexture as JPEG (.jpg)
files, then open them later for more editing. You can create tex-
tures based on any JPEG image, but doing so may not allow you
to create the kind of seamless textures that are possible when cre-
ating textures from scratch.

To create a texture from an existing JPEG (.jpg) file:

1. From the New dialog (or from the Texture File Options
area of the Tile tab), click the “Open” button .

2. Locate the JPEG file you wish to use as the base tile,
then click “Open.”

Abase tile will be created using the imported image.

3. When you are finished modifying your texture, click
“Save” in the Texture File Options area of the Tile tab
to save it back out as a JPEG image.



The Toolbox

PhotoTexture’s Photoshop-like painting and coloring tools let you
create patterns freehand. To select a tool, click its icon on the
Toolbox, or press the indicated key.  For additional information
on these tools, refer to your Photoshop User Guide.

V Move Lets you reposition the texture on the tile.

E Eraser Changes pixels in the image to the background color.

G Gradient Creates a gradual blend between the foreground and background colors.
Shades from the starting point to the ending point in a straight line. Note:
Provides Horizontal and Vertical gradients only, to ensure seamless textures.

K Bucket (Fill) Paint bucket fills adjacent pixels that are similar in color value to the pixels
where you click.

B Brush Paintbrush creates soft strokes  of color.

N Pencil Creates freehand lines.

S Stamp Rubber stamp takes a sample of the image, which you can apply in other
areas of the image.

I Eyedropper Extracts a color from the image for the Foreground or Background color.

Foreground Color Click to open the system color picker to choose a foreground color.

Background Color Click to open the system color picker to choose a background color.

X Exchange Color switcher exchanges the current foreground and background colors.

D Default Sets the foreground and background colors to their default values (fore-
ground black, background white).

Key Tool Description

Move  (V)

Eraser  (E)

Gradient  (G)

Bucket Fill (K)

Foreground Color  

Default  (D)  

Brush  (B)

Background Color

Pencil  (N)

Stamp  (S)

Eyedropper  (I)

Exchange  (X)

PhotoTexture Toolbox
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Stamp, Fill, and Brush Settings
Using commands on the Settings menu you can specify settings
for the following tools: Rubber Stamp, Fill (Paint Bucket), and
Brush. 

Stamp

The Stamp tool works like the rubber stamp tool in Photoshop:
using it you can take a sample of the texture which you can apply
to other areas of the texture. Cross hairs mark the original
sampling point. This tool is handy for smudging the edges of an
existing image to give it a more seamless look.

To use the Rubber Stamp Tool: Position the stamp pointer on
the part of the texture that you want to sample then Option-click
[Alt-click]. This sample point is the location from which the
image is duplicated as you paint. 

You can change the size of the sample area, and the Horizontal
and Vertical Offset of the sample as you paint with the Rubber
Stamp, by selecting “Stamp. . .” from the Settings menu. 

Fill (Paint Bucket)

The Fill tool (Paint Bucket) fills an area of adjacent pixels with
the current Foreground color.

You can change the tolerance of the fill by selecting “Fill. . .” from
the Settings menu. Tolerance defines how similar in color a pixel
must be to be filled. A low tolerance fills pixels within a range of
color values very similar to the pixel you click. A high tolerance
fills pixels within a broader range.

You can smooth the edges of the filled selection by choosing
“Anti-aliased Contour” from the Fill Tool Settings.

Brush

You can change the size of the Brush by selecting “Brush. . .” from
the Settings menu. Size is indicated in pixels.

Tip

You can access the Rubber
Stamp, Paint Bucket, and Brush
tool Settings by double-clicking
the tool on the Toolbox palette.
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Effects and Filters

You can create interesting and eye-catching seamless effects with
little or no effort using PhotoTexture preconfigured and customiz-
able Effects and Filters. Effects and Filters can be repeated
numerous times, and they can be combined with each other; with
the designs that you draw using the PhotoTexture tools; and with
other textures, creating truly unlimited possibilities. You can
select from different preconfigured Effect settings, or create and
save your own settings.

To apply Effects and Filters:

1. Choose an Effect or Filter from the list (page 20) and
click its button to select it.

— or —

1. Choose an Effect or Filter from the Effects or Filters
menu in the PhotoTexture menu bar.

This opens the dialog for the Effect or Filter, allowing you
to change the settings.

2. Click “Apply” to apply the setting to the texture in the
Edit Texture window.

This allows you to see the results of the applied Effect or
Filter without closing the dialog box. If necessary, reposi-
tion the Effect or Filter dialog box so that you can see the
texture and the dialog box at the same time.

3.If you do not like the effect, experiment with the
Effect or Filter settings by changing the values, and
click Apply to see the changes. Continue to experiment
with the Effect or Filter settings until you have
achieved just the right effect, then click “OK.”

This applies the effect to the texture and closes the dialog. 

If you do not like the effect at all, click “Cancel” to close
the dialog without making any changes to the texture. 

4. You can apply additional Effects and/or Filters by
following steps 1 through 3 until your texture is just the
way you want it. Repeat the last effect that was applied
by clicking the “Repeat Effect” or “Repeat Filter”
button (or by selecting these commands from the
Effects or Filters menu).

Tip

If you do not like the effect after
you close the dialog, select Undo
from the edit menu (or press
Command-Z [Ctrl+Z]). Select
“Clear” from the Edit menu to
clear the screen and start over.

Tip

To apply the effect repeatedly
without closing the Effect or Filter
dialog, press Command [Ctrl].
The “Apply” button will become
“Apply Again.” You can click Apply
Again until you achieve just the
effect you want.
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A Effects: Includes seven completely
customizable Effects: Lines, Shapes,
Drops, Dividers, Waves, Twirls, and
Skew.

Click an Effect button to open a dia-
log allowing you to modify the Effect
parameters. Click the Apply button in
the Effect dialog to see how different
values will affect the image. You can
even save Effect Settings for future
use. See  page 29.

B Filters: Includes seven completely
customizable Filters: Blur, Sharpen,
Noise, Saturation, Brightness and
Contrast, Add Color, and Mosaic.

Click a Filter on the list to open a dia-
log allowing you to modify the Filter
parameters. Click the Apply button in
the Filter dialog to see how different
values will affect the image. See
page 19.

C Effect Button

D Repeat Effect:Click to apply the last
applied Effect again. You can apply
an effect multiple times.

E Combine:Allows you to combine
existing textures together. See
page 30.

F Tile:Allows you to change the
number of pattern repetitions on
the base tile.

G Filter Button

H Repeat Filter:Click to apply the last
applied filter again. You can apply a
filter multiple times.

I Additional Filters: Invert, Add Bump,
Flip Horizontal and Flip Vertical.
These filters do not have additional
settings and are applied immediately
when the button is clicked.

I

PhotoTexture Effects and Filters
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Selecting an Effect from the Effects List
opens the dialog box for the Effect,
allowing you to set effect parameters
and apply the effect. You can also cre-
ate, modify, select, and save Effect
Settings for the selected effect.

A Preset Effect pop-up: Select a saved
effect from the list. Effect settings that
you save for a particular Effect are
available from the Preset list for that
Effect.

B Save: Allows you to save and name
the current Effect settings for later
use. Effect settings that you save for
a particular Effect are available from
the Presets pop-up menu (A).

C Delete: Deletes the selected Preset
from the Preset list.

D Effect Settings: Allows you to change
how the Effect will look. The settings
options are different for each Effect.

E Apply:Click to apply the displayed
Effect settings to the image in the
Edit Texture window without closing
the dialog. Press Command [Ctrl] to
get “Apply Again,” allowing you to
repeat the effect numerous times
without closing the dialog. 

F Cancel:Close the Effect dialog with-
out applying changes.

G OK: Close the dialog and applies the
Effect settings to the image in the
Edit Texture window.

Working with Effects

Selecting a Filter from the list opens the
Filter dialog box, allowing you to set
parameters and apply the filter.

A Filter Settings: Allows you to change
the effect of the selected Filter.

B Apply:Click to apply the displayed
Effect settings to the image in the
Edit Texture window without closing
the dialog. Press Command [Ctrl] to
get “Apply Again,” allowing you to
repeat the effect numerous times
without closing the dialog.

C Cancel:Closes the Filter dialog with-
out applying changes.

D OK: Closes the dialog and applies
the Filter settings to the image in the
Edit Texture window.

Working with Filters

CB D

A

A

FE G

B C

D



22

Lines: Creates a base pattern of multi -
ple single color or multi-colored lines
according to the Lines settings.

A Precision: High or Low. Determines
how skewed (Low) or organized
(High) the lines will be.

B Appearance: Wax (anti-aliased) or Ink
(not anti-aliased).

C Color: Random, Average Color.
Choosing a “Random” setting creates
lines of different colors. Selecting
“Average Color” creates lines of a sin-
gle color. Click the Color box to open
the system color palette to choose a
color for the lines.

D Angle: Use the directional model
control knob or enter a value for the
angle of the lines.

Shapes: Creates a base pattern of
shapes according the the Shapes
settings.

E Shape: Kind:Choose from Square,
Circle, or Ring. Color: Click the Color
box to open the system color palette to
choose a color for the shapes. Bevel:
Drag the slider to set bevel size.

F Direction: Angle:Determines the angle
or skew of the shape. Drag the direc-
tional control or enter a value.
Horizontal and Vertical Size:Drag the
sliders to set the size. 100% repre-
sents maximum size.

G Repetition: Sets the matrix of how
many shapes will be placed in the
base tile. 1x1 places one shape; 2x2
places four shapes, etc. Radio buttons
determine whether shape will overlap
or blend with the existing texture.

H Surface: Determines the surface prop-
erties of the shapes. Material: Sets
the texture to be smooth (glossy) or
bumpy (rough). Transparency:Deter-
mines how transparent the shapes will
be. Contrast:Determines how much
contrast is applied to the shapes. 

I Displacement: Determines the offset
of shapes from each other vertically
and horizontally. No displacement
(none) arranges the shapes in orderly
rows. Full displacement (random) cre-
ates disorderly, random patterns from
the shapes. Half-shift every second
row: Displaces shapes by row.

Effects—Lines, Shapes
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Drops: Creates a water-droplet pattern
using the background color or current
texture.

A Drops: Determines the amount (few
to many) and size (small to big)of
the droplets, and whether they are
uniformly sized (same) or randomly
sized (different).

B Reflection: Determines how the light
source affects the shapes, giving
them a washed out (dim) or empha-
sized (glossy) appearance.
Emphasize light: When checked,
gives the droplets a stronger 3-D
appearance.

C Covered area: Determines how the
droplets affect the background pat -
tern. “Normal” allows the background
to show through the droplet just as it
is. “Blurred” blurs the pattern where it
shows through the droplet. Most
noticeable on a multi-pattern back-
ground.

Dividers: Creates a base pattern by
dividing the screen into multiple sized
boxes using one or more colors.

D Lines:Determines how many lines
are created (few to many) and orien-
tation mix of the lines (mostly hori-
zontal, mostly vertical, or equal).

E Colors: Random Colors applies lines
in multiple colors. From Color Picker
creates lines using the current
Foreground and Background colors.
Transparent allows the background
to show through the the spaces
between the lines.

F Size: Determines line thickness and
the spacing between lines, and the
variation of the lines. Line Width:
Determines minimum line width, in
pixels. Width Variation: Determines
how much the line width will vary
from 0% (all lines will be of equal
size) to 100% (maximum variation).
Minimal Gap Between Lines:
Determines the minimum amount of
space between lines, in pixels.

G Drawing: Use Anti-Aliased Lines:
When checked, blurs lines using
antialiasing.

Effects—Drops, Dividers
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Waves: Creates a pattern by applying
hard or soft waves to the elements in
the current texture, either horizontally,
vertically, or both. Has no effect if the
texture is blank or a solid color.

A Horizontal:Sets wave parameters to
be applied horizontally. Waveform:
Choose None, Sine, Sawtooth, or
Square or Random. Height:
Determines the size of the wave, as
a percentage of the total pattern.
Count:Determines how many waves
will be applied in the base tile area.

B Vertical: Same as horizontal, but the
wave settings affect the pattern verti -
cally.

Twirls: Creates a pattern by swirling
the elements in the current texture. Has
no effect if the texture is blank or a solid
color.

C Quantity: Determines how much of
the pattern is swirled, as a percent-
age of the total. 1% applies minimum
swirliness; 100% applies maximum
swirliness.

D Size: Determines the size of the
swirls as a percentage of total size of
the pattern.

E Intensity:Determines the intensity of
the swirl. An intensity of 0% applies
minimum swirliness, 100% applies
maximum swirliness.

Skew: Creates a pattern by skewing
the elements in the current texture. Has
no effect if the texture is blank or a solid
color.

F Skew direction: Sets the direction of
the skew: from Left, from Right, from
Bottom, from Top.

Effects—Waves, Twirls, Skew
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Blur: Softens the image. Smooths tran-
sitions by averaging the pixels next to
the hard edges of defined lines and
shaded areas. 

A Blur amount: Use the slider or enter a
value between 0 (no blur) and 100
(maximum blur).

B Motion Blur: Click to create a blur
that simulates motion.

C Direction: Click a button to indicate
the originating direction of a motion
blur.

Sharpen: Focuses texture by increas-
ing the contrast between pixels.

D Sharpen amount: Use the slider or
enter a value between 1 (minimum
sharpen) and 5 (maximum sharpen).

Noise: Adds “noise,” or randomly dis-
tributed colors to the texture. 

E Noise amount:Use the slider or enter
a value between 0% (no noise) and
100% (maximum noise).

F Color: Select noise pixels in: Black &
White; Colored; and Really Colorful.

Saturation: Increase or decrease the
color saturation.

G Saturation amount: Use the slider or
enter a value from -50% to +50%.

Filters—Blur, Sharpen, Noise, Saturation
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Brightness and Contrast: Adjusts the
tonal range of the image. Affects all
pixel values in the texture: highlights,
shadows and mid-tones.

A Brightness:Use the slider or enter a
value between -100% (minimum
brightness) and 100% (maximum
brightness).

B Contrast:Use the slider or enter a
value between -100% (minimum con-
trast) and 100% (maximum contrast).

Add Color: Adds a color to the image,
with adjustable opacity.

D Color:Click to open the system color
palette allowing you to select a back-
ground color.

E Opacity: Use the slider to adjust the
opacity between 0% (minimum
opacity) and 100% (maximum
opacity).

Mosaic: Applies a pixelated effect to
the texture.

F Horizontal: Select a number from the
pop-up menu between “None” (no
horizontal mosaic effect) and 8 (maxi -
mum mosaic effect horizontally). The
mosaic “squares” are measured in
pixels.

G Vertical: Same as Horizontal, but
affects the texture vertically.

Filters—Brightness/Contrast, Add Color, Mosaic
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Additional Filters

PhotoTexture provides four filters that do not have
dialog boxes and are applied directly when you click
the button. 

Invert: Inverts texture color: The color of each pixel is
converted to its inverse value.

Add Bump: Gives the texture  pattern a raised appear-
ance by beveling areas of similar color.

Flip Horizontal/Flip Vertical: Flips the texture hori-
zontally or vertically: The texture is rotated 180° from
its current position.
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Texture Preview

You can see how your pattern will look when applied to a larger
area by examining it in the Preview window. You add or remove
the Size Marks from the Preview to get a better idea of how the
pattern will look.

To view an enlarged Preview of the texture:

• Click the Preview tab

To return to the Edit Texture window, click the “Tile” tab.

Tip

To toggle between the Preview
tab and the Tile tab, press the “ P”
key.
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Tip

Macintosh Users: To momentarily
switch to the Hand tool from any
other tool, press the Spacebar.

To momentarily access the Zoom
tool when the Hand tool is active,
press Command (Zoom In) or
Option (Zoom Out).

Note:These commands work
together: With any tool selected,
press Spacebar to activate the
Hand tool, then also press
Command or Option to access a
Zoom tool.

Tip

To return to 100% magnification
and center the base tile in the
window, press Command-0
[Ctrl+0] or select “Actual Pixels”
from the View menu.

Zooming and Panning

The Zoom and Pan (Hand) tools perform the same functions as
the Photoshop Zoom and Hand tools. 

To Zoom In:

• Select the Zoom tool (magnifying glass), then click the
area of the image you want to magnify.

Each click magnifies the image to the next percentage, and
the magnified display is centered around the point you
click. 

— or —

• Press Command-Shift-“+” or Command-Keypad “+”
[Ctrl+Keypad “+”].

— or —

• Choose View > Zoom In from the menubar.

To Zoom Out:

• Select the Zoom tool (magnifying glass). While pressing
Option [Alt], click the area of the image you want to
reduce.

Each click reduces the image to the next percentage. 

— or —

• Press Command-Shift-“–” or Command-Keypad “–”
[Ctrl+Keypad “–”].

— or —

• Choose View > Zoom Out from the menubar.

To Pan (Scroll) in the Drawing Area:

Select the Hand tool and drag the image until you
locate the area you wish to view.

— or —
• With any other tool selected (Macintosh only), press

Spacebar while you drag the image in the window.
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Applying and Saving Textures

You can save a texture in one of two ways: by applying it to an
image in Photoshop, or by saving it from PhotoTexture as a JPEG
format file. 

When you apply a texture to an image in Photoshop, the new tile
replaces the image or selection, and the pattern size that is
applied is limited to the size of the selection area. Applying your
texture to a Photoshop document and then saving allows you to
save the texture in any format supported by Photoshop. 

When you save a texture from PhotoTexture as a JPEG file, tile
size can be changed from within PhotoTexture. That is, you don’t
have to know before opening PhotoTexture how large the tile will
be since you can change it at any time. You can only save from
PhotoTexture as a JPEG format file.

To apply a texture to a Photoshop document or selection:

1. When you are ready to save your texture, click the
“Apply” button in the Drawing Area on the Tile tab.

This replaces the Photoshop image (if any) or selection area
with the texture you created. You can continue working with
the pattern in Photoshop, or save the file using any format
supported by Photoshop.

To save a texture from PhotoTexture:

1. When you are ready to save your texture, click the
“Save” button in the Texture File Options area of the
Tile tab.
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Combining a Texture with an Existing Image

You can use the Combine feature to merge existing textures and
images with your base tile pattern to create some really
spectacular effects. Any JPEG (.jpg) file can be used, but the file
and the texture base tile must be the same size. 

Combine options are:

Blend this texture with <filename>: Blends the pattern in the
file you specify with the pattern on the base tile. Select an opacity
for the blend between 0 and 100%. Opacity values closer to 0
allow more of the base tile texture to show through; values closer
to 100% allow less of the base tile texture to show through.

Structure this texture with <filename>: Applies the black and
white, or luminosity values, of the pattern in the selected file with
the base tile pattern. Luminosity can be adjusted from 0 to 100%.

Color this texture with <filename>: Uses color differences
between the file you specify and the pattern on the base tile. The
effect can be adjusted between 0 and 100%.

To combine a texture with another image:

1. Click the “Combine. . .” button in the  Effects area of the
Tile tab.

— or —

1. Choose “Combine. . .” from the Effects menu.

2. Choose the combining process that you want to use
from the pop-up list. 

3. Click the “Choose Texture” button and locate the image
that you want to combine with the texture.

The name of the texture file you selected is displayed in
the box below the pop-up.

4. Adjust the percentage of merging using the slider or by
entering a value in the box. Apply the effect to see how
it will look on your texture. Experiment until you
achieve just the right effect.
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Changing the Number of Pattern Repetitions

You can change the number of pattern repetitions on the base tile
by entering different matrix parameters (1x1, 3x5, 4x6 etc., up to
12x12). Be aware that doing so affects file size, which affects
what happens to the texture when you apply or save it. 

To change the number of pattern repetitions:

1. Click the “Tile. . .” button in the Effects area of the Tile
tab.

— or —

1. Choose  “Tile. . .” from the Effects menu.

The Tile dialog is displayed.

2. In the Horizontal and Vertical boxes, enter the number
of times you want the pattern repeated on the base tile.

3. Click “OK.”

The base tile will be enlarged or reduced as necessary to
accommodate the number of repetitions you indicated.

Note: If you increase the number of pattern repetitions,
base tile size is increased.



32

Resizing the Base Tile

You can change the size of the base tile without affecting the
number of pattern repetitions. This affects both file size and the
size of the pattern elements.

To change the size of the base tile:

1. Click the “Edit. . .” button in the File Options area of the
Tile tab.

— or —

1. Choose “Edit. . .” from the File menu in the
PhotoTexture menu bar.

The Edit file dialog is displayed.

2. In the Width and Height fields, enter the size that you
want to change the base tile to.

This resets the size of the base tile to the specified size.
The pattern is reduced or enlarged as much as necessary to
fit the new base tile size.
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PhotoEffects is a set of six image-enhancement tools for
Photoshop that allow you to create spectacular Photoshop effects
in a fraction of the time it used to take, and with much more inter-
active control. The six Effects plug-ins are:

•  PhotoButton •  PhotoGroove •  PhotoEmboss
•  PhotoCastShadow •  PhotoBevel •  PhotoGlow

Using these tools you can create professional effects on any type
of graphic element, including text, with significantly less effort.
See the results of your actions interactively as you tweak, twist,
color, and distort to achieve just the right effect. When you’ve
achieved the result you want, apply it to your image. You can
even save your favorite effect settings and recall them for use on
other images.

PhotoButton: Interactively create up to 64 beautifully rendered
identical buttons using an array of tools to create custom buttons
in all shapes, sizes, colors, and beveling.

PhotoCastShadow: Interactively create multiple shadows—
including drop shadows and perspective shadows with realistic
adjustable 3-D blurs—and see your work in a real-time preview.

PhotoGroove: Gain complete control over simple to complex
bevel shapes with PhotoGroove’s custom interactive bevel shape
editor, which allows you to effortlessly create unlimited edge
possibilities by manipulating quantity, shape, width, softness, and
highlighting.

PhotoBevel: Quickly create bevel shapes in PhotoBevel using
standard PhotoTools shaping tools including inside and outside
bevels, highlight and shadow colors. 

PhotoEmboss and PhotoGlow: Create custom embossing and
glow effects on any image, in a fraction of the time it would take
to achieve them manually.

All PhotoEffects plug-ins include a handy pop-up image naviga-
tor, editing in real time with interactive preview, multiple undos,
and the ability to view composite layers—so you can see exactly
how your effects will fit with the background and other image
elements. Whether used individually or together, the PhotoEffects
plug-ins will give you professional buttons, shadows, bevels,
embossing, and glows with a minimum of effort.

PhotoEffects
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Elements Common to All Effects

Many commands and attributes are common to all of the Effects
plug-ins (PhotoButton, PhotoCastShadow, PhotoGroove,
PhotoBevel, PhotoEmboss, and PhotoGlow). Those common
operations are described in this section. For specific details about
each of the individual plug-ins, refer to the section in this manual
specific to that effect.

All PhotoEffects plug-ins provide the following:

• Image preview—work with any image or selected part of an
image. Experiment until you achieve just the right effect, then
“apply” that effect to your image.

• Interactive, real-time editing environment—work with effects
interactively, watching your effect take shape on a real-time
Preview screen.

• Multiple undos and redos—go back and forth as many steps as
you need to before applying your effect to the image.

• View composite layers—see all the active layers, not just the
layer you’re working on, inside the plug-in Preview window.
Allows you to see your effects in relation to the rest of the
image without giving up the flexibility of layers.

• Photoshop Actions Palette awa re—allows for easy A c t i o n s
Palette scripting inside Photoshop. Dramatically increases produc-
tivity when you need to create the same effects in multiple files.

• Navigator pop-up—innovative “pop-out” navigator is hidden
until needed. Allows you to instantly position your image in the
Preview window without competing with the image for space. 

• Standard Photoshop-style interface—no need to relearn tools
and commands. All PhotoEffects plug-ins use many Photoshop-
type commands, and operations behave as you’d expect them to
if applied directly in Photoshop (exceptions are noted where
they occur.) Zooming and scrolling controls use standard key-
board shortcuts (see Appendix A, page 174).

• Save and reapply effects—create just the effect you want, then
save the settings for reuse at any time.

• Eyedropper tool—extract colors from the image without leav-
ing the Preview window.

• Background processing—uses idle time between image adjust-
ments to process the effect, reducing or eliminating the need for
more processing when the effect is applied.

• Fit on Preview—fits the image to the available Preview win-
dow. Equates to Photoshop Fit on Screen command.

• Help Box—displays, in a special window, a description of each
tool and button function as you drag the mouse over it.

Tip

For a listing of keyboard shortcuts,
see Appendix A, page 174.
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Getting Started with PhotoEffects

To create an effect using a PhotoEffects plug-in:

1. Select an area of your image where you wish to add an
effect.

Note: PhotoCastShadow and PhotoGlow require that an
image area be selected, either implicitly (using a layer’s
transparency mask) or explicitly (“marching ants” indicat-
ing the selected area). PhotoTexture, PhotoButton,
PhotoGroove, PhotoBevel, and PhotoEmboss do not.

If you’re not familiar with creating effects using a plug-in,
start with something simple. Open your image in Photoshop,
and using the Marquee tool, drag a rectangle around the area
you wish to work with, or create a layer with the image
you’ll be working with on a transparent background. If no
area is selected, the PhotoEffect plug-ins assume you want
to work with the full image (see Note above).

2. Select the desired PhotoEffect plug-in.

Select a plug-in from the PhotoTools Commands toolbar,
from the Extensis menu, or from the PhotoTools menu in the
Photoshop Filters menu.

Select PhotoButton, PhotoGroove, PhotoBevel, PhotoCast-
Shadow, PhotoEmboss, or PhotoGlow. The Preview win-
dow dialog box for the selected Effect will be displayed.

3. Use the options in the effects Preview dialog box to
create the desired effect (the specific options for each
effect are described later in this chapter). 
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Inside each of the PhotoEffects plug-ins you can experi-
ment with all kinds of effect parameters, and immediately
see your result on the image in the Preview window.

Note: While you are working in an Effect’s dialog box
(Preview window) the changes you make do not affect the
image in Photoshop. When you like the effect you see in the
Preview window and are ready to make those changes to
your image, click “Apply.” Until you click “Apply” you
can change the parameters as much as you like until you
get just the effect you want. If you don’t like the effect you
created, click Cancel and the Effect’s window will close
without making any changes to your image.

If your changes don’t appear in the Preview window, see
“Unexpected Results” later in this chapter.

5. When you’re satisfied with the effect you’ve created in
the Preview window, apply the effect to your image.

Click “Apply” to add the effect to your image.

If you get any warning dialogs when you attempt to apply
your changes, refer to Troubleshooting ( p age 176) a n d
“Additional Information” later in this chapter.

Note: If you accidentally Apply the effect to your image
before you are completely finished (the Effect dialog box
closes), you can “undo” the effect (Command-Z [Ctrl+Z]).
You can then reopen the Effect—it will  remember and dis-
play your Last Used settings.

To Save PhotoEffects Settings for Later Use:

1. Once you’ve established the settings exactly as you
want them, click the “Save” button in the Effect’s dia-
log box.

A Save dialog box appears, allowing you to name and save
the current Effect’s settings as a filter.

2. Type a name for the Settings to be saved.

3. Click “OK.”

The name of the Settings will appear in the pop-up menu
in the bottom-left corner of the dialog box. It will also be
available from the Effect plug-in’s submenu on the
Extensis menu. 

Tip

Macintosh Users: PhotoBars
provides another convenient way
to access effect settings saved in
the PhotoEffects plug-ins: Click
the Saved Effects button in the
Effects Settings toolbar to see a
list of all saved effect sets. 

Tip

You can apply a saved effect by
selecting it in the Effect’s dialog
box or by selecting it from the
Extensis menu. When you choose
a Setting from the menu, the
effect is immediately applied to
the selection, without opening the
Effect’s dialog box.
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To Use PhotoEffects Settings Previously Saved:

1. Select an area of your image on wh i ch to ap p ly the effe c t .

2. Open the desired PhotoEffects plug-in.

3. Select the name of the saved effect from the Settings
pop-up menu in the bottom-left corner of the dialog box .

N o t e : Settings are specific to the plug-in they we re save d
in. For ex a m p l e, you cannot open PhotoCastShadow set-
tings in PhotoBeve l .

4. If desire d, m a ke any additional adjustments to the effe c t .

5. Click “Apply” to add the effect to your image.

— or —

1. Select an area of your image on wh i ch to ap p ly the effe c t .

2. Select the saved Settings you wish to use from the Effect
plug-in’s submenu on the Extensis menu.

The saved effect will be applied to the selection immedi-
ately, without opening the Effect’s dialog box. 

To Delete PhotoEffects Settings Previously Saved:

1. Select the desired PhotoEffects plug-in.

2. L o c ate the setting you want to delete in the Settings
pop-up menu in the bottom-left corner of the dialog box .

3. Click “Delete.” You will be asked to confi rm the deletion.

4. Click “OK.”

Preset Settings
A number of common effect Settings are provided for each of the
Effect plug-ins. These Settings can be used “as is” or selected and
then modified. The Preset Settings cannot be removed.

To Select a Preset Setting:

1. Follow the steps in “To Use PhotoEffects Settings Pre-
v i o u s ly Save d ” ( ab ove). The Preset Settings appear in the
upper-half of the menu, above any user-created settings.



Common PhotoEffects Elements Explained

The PhotoEffects Dialog Box

When you select a PhotoEffects plug-in, the dialog box for that
plug-in is opened. Inside this window you have access to all the
tools, options, and windows needed to create, modify, experiment
with, and view your effect. For details about the tools and options
available for the different Effects, refer to the section of this man-
ual specific to that Effect. 
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A PhotoEffects Menus: In Windows, the
Effects menus are located at the top
of the dialog box window. In
Macintosh, the menus replace the
Photoshop menus in the main
menubar

B Title Bar: Shows the PhotoEffects
plug-in currently in use.

C Preview window: Displays your image
with the selected effects applied
before you apply them to your image.
Updates your changes in real time if
“Real-time Preview” is turned on.
Displays the composite view of all
selected layers when “View
Composite Layers” is turned on.

D Image Navigator: Click and drag in
this pop-up window to instantly reposi-
tion the image in the Preview window.

E Effect-specific Options: These effects
options will differ depending on what
PhotoEffects plug-in is being used.

F Settings: These tools allow you to
Select, Save, and Delete effect set -
tings. Only settings appropriate to the
current PhotoEffects plug-in will be
available in the list. 

G Help Box: Describes each function as
the mouse passes over it.

H Undo/Redo/Reset: Undo/Redo pro-
vides multiple undos and redos;
Reset returns all settings to their
default values (useful for starting over
“from scratch”).

I Zoom Controls and Indicator:
Changes and displays zoom amount.

J Progress Indicators: Top bar shows Preview Redraw progress. Bottom bar shows
Background Processing progress when the “Background Processing” option is
turned on.

K Effect-specific Tools: These tools may differ depending on what PhotoEffects plug-in
is being used. Scroll (Hand) and Zoom (Magnifying glass) are available in all
Effects.

L Cancel/Apply: Apply closes the dialog box and applies your effects to the image in
Photoshop. Cancel closes the dialog and leaving the image unchanged. 

B C D

E

F

LG I J KH

Typical PhotoEffects Dialog box

A
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Undo/Redo/Reset

All of the controls in PhotoEffects provide multiple undo and
redo capability using the Undo/Redo buttons in the Effect’s dialog
box, selecting Undo/Redo from the menu, or using keyboard
shortcuts. Reset returns all settings to the default condition, allow-
ing you to start over in a known state.

To Undo a Command:

1. Click Undo as many times as needed to undo steps. 

Choose Edit > Undo (or press Command-Z [Ctrl+Z]).

The Undo button is dimmed if there are no operations to
undo.

To Redo a Command:

1. Click Redo as many times as needed to restore previous
undo(s).

Choose Edit > Redo (or press Command-Y [Ctrl+Y]

The Redo button is dimmed if there are no operations to
redo.

To Reset all Effects:

1. Click Reset.

All effect settings, undos, and redos for the current session
will be restored to factory defaults. The Preview image will
be displayed with no other effects applied.

Tip

You CAN “undo” a Reset.
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View Composite Layers

With the View Composite Layer feature you can see all visible
layers—not just the layer you’re working on—inside the Effect
Preview window. This allows you to see your effects in relation to
the rest of the image without having to flatten the layers.

To View Multiple Layers in a PhotoEffects Preview:

1. In Photoshop, verify that all the layers you want to see
in the image Preview window have been made visible
(eye icon showing in the layers palette).

2. Select the image area that you wish to create an effect
for.

3. Select the PhotoEffects plug-in for the effect you wish to
create.

This opens the plug-in Preview window dialog box. You
should see all the layers along with your image.

4. If you do not see the layers along with your image,
choose View > View Composite Layer.

This enables the View Composite Layer function. (This
option is turned off by default when PhotoTools is
installed.) Or press Command-L [Ctrl+L].

Note: If the image does not appear to preview correctly after per-
forming the steps above, see Additional Information on page 46
and Troubleshooting on page 176.

Fit on Preview

Fit on Preview adjusts the zoom percentage to the largest size that
can fit in the Preview area and still contain the entire image.
Actual Pixels returns the Preview to the actual pixel size prior to
invoking Fit on Preview.

To Fit the image to the Preview window:

1. Select View > Fit on Preview (or press Command-0
(zero) [Ctrl+0 (zero)]).

Tip

You can toggle View Composite
Layer on and off from inside the
Effect’s Preview window with
Command-L [Ctrl+L].



Real-time Preview

The Real-time Preview feature allows different effects to be
applied and viewed as you change them . This means you get
immediate feedback in your preview as you adjust the parameters
of an effect.

One of the most striking examples is in the Color Palette. In a typ-
ical program, you would click-open the Color Palette, choose a
c o l o r, release the pop-up, then wait for the preview to display the
e ffect in that color. To try a different color, you would have to go
through the whole color-selection process again. With the Eff e c t s
plug-ins, you simply click-open the palette and drag the mouse
over the color chips. Each time you drag the mouse over a diff e r-
ent color chip, the preview updates immediately in real time. 

For example, with Real-time Preview on, if you are creating a
cast shadow and want to experiment with shadow coloring, press
and hold the Color Palette pop-up as you drag the mouse
around—the Preview image immediately shows the shadow in the
color you chose, and the shadow color will change as you drag
your mouse over the different colors. Try turning Real-time
Preview off and see the difference!

Note: You can also preview colors interactively by selecting the
Eyedropper and dragging it around the Preview window.

To Turn Real-time Preview On or Off:

1. Choose Options > Real-time Preview.

A checkmark indicates that Real-time Previewing is On.

Whether or not you have Real-time Previewing turned on, the
Preview image must be processed and redrawn when you change
an effect option. This redraw is tracked on the top half of the dual
progress bar located just underneath the Preview window. The
Preview is not completely finished until the progress bar reaches
the end. 
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Preview
processing progress
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Background Processing

In a typical Preview scenario, when you are finished with preview
mode and want to apply your changes to the image, more process-
ing is required before the image window reappears. To speed
things up, PhotoEffects uses the idle time between your image
adjustments in the Preview window to begin final processing. As
soon as you stop adjusting controls, final processing begins, and a
progress bar is displayed just below the Preview window. If the
progress bar is complete (indicating that processing is complete)
when you Apply the effect, the image screen will appear much
more quickly.

To Turn Background Processing On or Off:

1. Choose Options > Background Processing.

A checkmark indicates that Background Processing is On.

Background processing
progress



Zooming and Panning

All PhotoEffects plug-ins provide a number of easy ways for nav-
igating and viewing effects in the Preview window.

To Zoom In:

• Click the “+” button under the Preview window.

Each click magnifies the image to the next percentage.
Zooming occurs from the center of the image. When you
reach maximum magnification, the center of the Zoom tool
appears empty.

— or —

Select the Zoom tool (magnifying glass), then click the
area of the image you want to magnify.

Each click magnifies the image to the next percentage, and
the magnified display is centered around the point you click. 

— or —

• Press Command-Shift-“+” or Command-Keypad “+”
[Ctrl+Keypad “+”].

— or —

• Choose View > Zoom In from the menubar.

To Zoom Out:

• Click the “–” button under the Preview window.

Each click reduces the image to the next percentage.
Zooming occurs from the center of the image. When you
reach maximum reduction, the center of the Zoom tool
appears empty.

— or —

Select the Zoom tool (magnifying glass). While p re s s i n g
Option (Macintosh) or A LT ( Wi n d ow s ) , click the area
of the image you want to reduce.

Each click reduces the image to the next percentage. 

— or —

• Press Command-Shift-“–” or Command-Keypad “–”
[Ctrl+Keypad “–”].

— or —

• Choose View > Zoom Out from the menubar.
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Zoom In

Zoom Out

Tip

Macintosh Users: To momentarily
switch to the Hand tool, hold down
the Spacebar.

To momentarily access the Zoom
tool when the Hand tool is active,
press Command (Zoom In) or
Option (Zoom Out).

Note:These commands work
together: With any tool selected,
press Spacebar to activate the
Hand tool, then also press
Command or Option to access a
Zoom tool.

Tip

Double-click the Zoom tool to
zoom to 100%. 
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Tip

Double-click on the Hand tool to
force the Preview image to fit the
available window (Fit on Preview). 

To Pan (Scroll) in the Preview Window:

Select the Hand tool and drag the image until you
locate the area you wish to view.

— or —

• With any other tool selected (Macintosh only), press
Spacebar while you drag the image in the window.

Navigator Pop-up

This handy little navigator window “pops-out” from the upper-
right corner of the Effect’s Preview window (except
PhotoButton), allowing you to instantly reposition your image
within the window. The navigator stays out of the way until you
need it, but is instantly available when you do.

To Use the Effect’s Preview Window Navigator:

1. Click and hold the mouse over the Navigator button in
the upper-right corner of the Preview window.

2. Keep holding the mouse button down as you drag the
view box around the Navigator window.

3. When the image area you want to see appears in the
Preview window, release the mouse to close the pop-up.



Color Tools

Color Pop-up: Provides interactive access to the current Color
Palette, the current Photoshop Foreground and Background col-
ors, and the Color Picker. Color values are shown on the right
side of the palette, reflecting both the current Color Mode (RGB,
CMYK, etc) and the color values of the highlighted color.

Note: In RGB mode, the Color pop-up displays all and only
“web-safe” colors. This does not mean that the final result color
will be web-safe, since colors may sometimes be blended and/or
faded to the background.

Note: None and Transparent are PhotoButton only parameters
and will be grayed out in the other PhotoEffects plug-ins. For
information on these selections refer to the PhotoButton section
of this manual.

To Preview Colors Interactively Using the Color Pop-up:

1. Click and hold on the color indicator box.

2. Drag the cursor over the color swatches in the window
and observe the changes in the effect’s color.

Eyedropper: Provides interactive access to colors in the Preview
window.

To Preview Colors Interactively Using the Eyedropper:

1. Select the Eyedropper tool.

2. Drag the Eyedropper around in the Preview window
and observe the changes in the effects’color.

To Select a Color Using the Eyedropper:

1. Select the Eyedropper tool.

2. In the Preview window, click the Eyedropper on the
color you wish to select.

The selected color will appear in the color box.

45



46

Additional Information

This section details some of the more intricate features of the
PhotoEffects plug-ins. If you’re already familiar with Photoshop,
this information can help you avoid unexpected results when
working with these ground-breaking plug-ins.

View Composite Layer

The “View Composite Layer” feature allows you to see all of
your visible Photoshop layers while creating your effect, some-
thing no other plug-in has allowed you to do. This is an extremely
powerful feature, but current limitations with the Photoshop
Application Programming Interface prevent it from working
exactly as you might expect. 

How it works: If you choose any layer other than the top-
most layer as the target for your effect, the PhotoEffects
plug-ins (PhotoCastShadow, PhotoGroove, PhotoButton,
PhotoBevel, PhotoEmboss, or PhotoGlow) display the select-
ed layer as the top layer in the Preview window; the effect is
applied to this selected layer.

Example: In the composite image shown, the layer named
“text” is the top layer. We have selected the layer named
“medium” (which is below the “text” layer) as the active
layer. We’ll use the image on that layer to create our effect. 

When the PhotoEffect plug-in Preview window is opened
(we’ve selected PhotoCastShadow), you would expect to see
the image in the Preview window exactly as it appears in
Photoshop—with all layers in the correct relationship.That is,
with the “text” layer above and the “medium” layer below.
However, this is not what happens: the selected layer, “medi-
um,” Previews on top.

In order for the PhotoEffects plug-ins to display any com-
posite preview correctly in all cases, your selection layer
must be the top layer. But even if your selection is not the
top layer, be assured that PhotoTools is not actually rear-
ranging the layers in your image, only the Preview. If you
select the top layer before opening an effect, the preview
behaves normally. 

Photoshop composite image:
Top layer displays on top

Layers palette:“text”is the top layer,
“medium”is the selected layer

PhotoEffects Preview composite image:
Selected layer displays on top
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Create Shadow Only / Create Glow Only

Create Shadow Only (and Create Glow Only) is a feature in the
shadow-effect plug-ins, PhotoCastShadow and PhotoGlow. This
feature allows you to create the effect you want and then separate
it from the image, so that the shadow occupies its own layer. You
may even want to delete the original image, keeping only the
shadow image.

You can do this easily with PhotoCastShadow and PhotoGlow by
first duplicating the layer you want to create a shadow-only effect
for before you open the Effect plug-in.

How it works: When you turn on the “Create Shadow
Only” checkbox, the preview brings the shadow for-
ward. The Preview is designed this way to give you a
visual clue that you are not just adding a drop shadow to
the original information on the targeted layer. Rather, the
preview is showing you that you are actually turning the
targeted layer into a shadow.

Example: If you wanted to make a cast shadow for the
big wrench, you would duplicate its layer, activate the
layer, then  open PhotoCastShadow. Next you would set
all the parameters for your shadow, such as opacity,
color, edge blur, etc. When you have the shadow looking
the way you want it to, you would turn on the “Create
Shadow Only” checkbox and then click Apply.

By default, PhotoTools always keeps the original infor-
mation on the targeted layer and then adds the shadow
outside (or around, in the case of a glow effect) the orig-
inal image. By duplicating the layer first, you no longer
need to keep the original image pixels intact. Just select
Create Shadow Only, and the image on the targeted
layer will be transformed into a shadow, on its own
layer, separate from the original layer that you duplicat-
ed beforehand!

After choosing Apply, the effect lands on its own layer
where you can change the opacity, position, and blend
mode without altering the original image you had before
creating the effect.

Image and Shadow

Shadow Only
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Actions Palette Awareness/Actions Palette Scripting

PhotoCastShadow, PhotoBevel, PhotoEmboss, PhotoGlow  and
PhotoGroove are Actions Palette aware and Actions Palette script-
able. PhotoButton and PhotoTexture are Actions Palette aware but
not scriptable. 

For detailed information on Actions Palette awareness and A c t i o n s
Palette scripting, refer to your Adobe Photoshop User Guide.

Multiple Undos and RAM

All of the PhotoEffects plug-ins allow you to Undo effects
applied in the Preview window multiple times, then Redo as
many of those steps as you like. This feature allows you to exper-
iment with effect actions, reverting back to earlier actions, then
moving forward to latter actions to compare different effects, or
to change your mind without “losing” any work in the process. 

As you might expect, Undo and Redo work only inside the effect
plug-in, and effect actions are only captured for one session at a
time.

The amount of RAM memory available to Photoshop will impact
how many times you can Undo and Redo effect actions. Natur-
ally, the more RAM the better, but even with Photoshop’s
recommended RAM settings you’ll have access to dozens of
levels of Undo.

Note: For best performance, Photoshop recommends that you do
not use virtual memory software when running Photoshop, but
rather allow Photoshop to manage memory. Refer to the Adobe
Photoshop User Guide for more information.

Color Modes

Not all color modes are available in all PhotoTools plug-ins. 

•  RGB
•  CMYK
•  Multi-channel
•  Grayscale
•  Duotone

•  Bitmap
•  Indexed

•  Lab mode 

The rest of the PhotoEffects plug-ins
work in all of these modes

PhotoTexture supports RGB only

PhotoGroove, PhotoButton, and
PhotoTexture do not work in this mode

No Photoshop plug-ins work
in these modes
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With PhotoButton, you can quickly construct beautifully-ren-
dered, uniform buttons from 15 predefined, completely customiz-
able shapes, or design and save your own custom button shapes
and edit those shapes at any time. Create button groups or single
buttons, then customize by adding simple or complex custom
bevels, textures and/or bump maps, and highlights. Add colors
to your buttons as a group, or apply different colors to different
buttons. Constructing buttons with PhotoButton saves tremendous
time over “hand-rolling” individual buttons—making it the per-
fect tool for Web and multimedia interface projects.

PhotoButton

K Adjust (Resize) tool: Adjust Anchor Button size and position (affects all buttons).

L Pen (Reshape) tool: Adjust Anchor Button shape (affects all buttons). Add and delete
anchor points, drag points and lines.

M Cancel: Closes the dialog box without making changes to the image. You can also
Cancel by pressing Command-“.” (period) [Alt+F4].

N Apply: Adds your selected effects to the image and closes the dialog box. You can
also Apply the effect by pressing Return or Enter.

A Shape Tab: Provides access to shap-
ing options. See page 50.

B Bevel Tab: Provides access to bevel
options for the buttons. See page 51.

C Color Tab: Provides access to options
for the inner, outer, and bevel areas
of the buttons. See below.

D Texture Tab: Provides access to
button texture options. See page 53.

E Preview Window with Grid displayed.
To toggle the grid on or off, press
Command-" [Ctrl+"].

F Paint Color: Determines the color to
be applied to the button parts. Use
the Paint Bucket to apply this color to
the selected part of any button indi-
vidually. Use modifier keys to apply
this color to the selected part of all
buttons simultaneously (page 68).

G Inner, Bevel, and Outer Tabs:
Provides access to separate Surface
Property controls for the Inner and
Bevel parts of the button, and the
button Outer area (button back-
ground). See page 52.

H Highlighting: Controls the light 
source. Parameters that can be
affected are Color, Direction, and
Inclination. Use the control knob on
the directional model to change
Direction and Inclination simultane-
ously. See page 70.

I Settings Controls: Select, Save, and
Delete effect settings. 

J Help Box: Displays a description of
each tool or option as the mouse
passes over it.

F

E

G

H

I

K

L

J M N

The PhotoButton Dialog box

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33.  

Tip

For a listing of keyboard shortcuts,
refer to Appendix A, page 174.

B C DA
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The Shape tab provides access to all
shaping options for the buttons. Values
changed using the Adjust tool and Pen
tool will be displayed in the appropriate
fields.

A Shape tab

B Number: Specify number of buttons in
rows (horizontal) and number of but -
tons in columns (vertical). 

C Width and Height: Specify A n c h o r
Button size, in pixels (affects all
b u t t o n s ) .

Lock/Unlock: When lock is on, con-
strains button size to values entered
in the Width and Height parameter
b o x e s .

D Shape: Choose from saved custom
shapes and 15 common, predefined
shapes.

E Save/Delete: Click Save to name and
save the current shape, and add it to
the Shapes list. Note:Saving a shape
does not save any other button para-
meters. To save all button settings,
save using the Settings options (see
page 36). Click Delete to remove the
currently selected shape from the list.

F Rotation Angle: Rotates all the but-
tons. Rotation is not applicable to all
shapes (for example, Circles). Note:
When Rotation Angle is adjusted, all
manual resizing and repositioning is
undone.

G Corner Radius:Controls curve of but-
ton corners. N o t e : When Corn e r
Radius is adjusted, all manual resiz-
ing and repositioning is undone.

F

A

C

B

D

E

H

PhotoButton Shape Tab
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The Bevel tab allows you to create
custom bevel effects for the buttons.
Options on the Bevel tab apply to all the
buttons. Use the bevel settings found on
this tab along with the bevel color and
highlighting control on the Color:Bevel
tab to achieve just the right effect.

A Bevel tab

B Shapes Thumbnail:Displays a thumb-
nail representation of the shape as
shown on the Bevel Shapes palette. 

C Save: Allows you to name and save
the current shape. When saved, the
new shape appears on the Shapes
Pop-up Menu (D). (This options saves
only the bevel Shape. To save bevel
style parameters, you must create a
Settings (page 36).

D Shapes Pop-up Menu: Access all
pre-defined and saved bevel shapes.  

E Bevel Shape Editor: Clicking the but-
ton opens or closes the Bevel Shape
editing palette. Click to add a point to
create a new edge. To change edge
spacing and height, drag the point to
a new position on the grid. 

New points are automatically created
as Smooth points. To create a sharp,
pointed edge, click the “Pointy” box
and then click on the graph to add the
point. To change a Smooth point to a
Pointy point, select the point and
check the Pointy box. To change a
Pointy point to a Smooth point, select
the point and uncheck the Pointy box.

F Delete:Deletes the selected Shape.

G Bevel Width: Controls bevel width.

H Bevel Height: Adjusts bevel lighting to
make the button look shorter, taller,
more convex or more concave.

I Bevel Softness: Softens the edges of
the bevels.

J Inner Height: Makes the inner part of
the button convex or concave. 100%
is maximum convex, 0% is flat.

For more detailed information on the
Bevel Shape editing palette, refer to
page 62.

B

A

D

E

F

PhotoButton Bevel Tab

C

G

H

I

J
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The Surface Property tabs, consisting of
the Inner and Bevel button parts, and
button Outer area, provide access to
color surface property settings for the
three parts individually. Values shown in
the tab affect the selected part of all
buttons in the matrix.

A Inner Tab: Specify color parameters
for the inner area of the button.

B Bevel Tab: Specify color parameters
for the bevel area of the buttons.

C Outer Tab: Specify color parameters
for the area outside of the buttons.

D Surface Reflectivity: Controls the
amount of light reflected or absorbed.
0% yields a matte (all light is absorb-
ed, no reflection); 99% yields a high
gloss (very reflective). See Note
under Highlight Ratio.

E Diffuse Angle: Controls the degree to
which light is diffused on the surface.
1% yields a focused, spotlight effect;
90% yields a diffused wash of light. 

F Highlight Ratio: Controls the amount
of light striking the button part (similar
to using a dimmer switch). N o t e :I f
the Highlight Ratio is set to ze r o
(indicating no light) there can be no
s u r face reflectivity.

G Preset: Sample settings showing com-
mon effects achieved by changing the
various Surface Property parameters.

H Transparent: Applies to Outer button
part only. When on, makes all the pixels
outside the button transparent. (See
Note on page 70.)

I No Highlighting: When on, no light
strikes the selected button part.
Disables the color controls. (Same
effect as setting all three color controls
to their minimum values.)

D

E

G

F

A

I

H

PhotoButton Color Tab—Surface Property Tabs

B C
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The Texture tab provides access to all
texture options for the buttons, including
regular textures and bump map (raised
or stamped) textures. Listed texture files
are saved in the PhotoButton prefer -
ences and will be available whenever
you open PhotoButton.

A Texture tab

B Texture Thumbnail:Displays a thumb-
nail preview of the selected texture. 

C Import:Allows you to locate and
import JPEG (.jpg) files to be used as
textures or bump maps. 

D Texture Fill All / Remove All: Click Fill
All to apply the selected texture (from
the Textures list) to all parts of all but-
tons at once. Click Remove all to
remove the selected texture from all
parts of all buttons at once.

E Bump Map Fill All / Remove All: Same
as Texture Fill All / Remove All (D),
except applies to Bump Maps.

F Bump Map Blur: Softens transitions in
the bump map.

G Bump Map Height: Adjusts bump map
lighting to make the bumps look
shorter, taller, more convex or more
concave.

H Textures List: Displays all the alpha
channels and JPEG files currently
available. Select a texture from the
list, then use either the Texture or
Bump Map Bucket tool to apply the
image to the button(s) as either a
texture or bump map.

JPEG Files: You can add JPEG files
to the list by importing them using the
Import button, or by dragging and
dropping from the desktop.

Alpha Channels: Any alpha channels
in the file being used to create the
buttons will automatically appear at
the top of the list to be used as tex-
tures or bump maps. You can delete
Alpha Channels from the list, but you
cannot add them.

I Delete:Click to remove the selected
JPEGfile (.jpg) from the Textures list. 

J Bucket tools: The Bucket tools allow
you to apply a Texture or Bump Map
to individual buttons or areas of a
button (inner/bevel/outer). You use a
different Bucket tool to apply selected
textures as a Bump Map. The top
Bucket in each section adds the indi-
cated effect, the bottom bucket (with
Xs) removes the effect.

PhotoButton Texture Tab

C
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B H

I

D
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Getting Started with PhotoButton

PhotoButton allows you to automatically create a matrix of same-
shape buttons using a single “Anchor Button” as the copy source.
As you work with the Anchor Button, selecting and adjusting the
shape, contour, bevels, and texture to achieve just the right effect,
you will see the effect on all the buttons automatically. Use the
color controls to set reflectivity, diffusion, and highlighting, col-
oring all buttons the same, or optionally color each button indi-
vidually.

This section will help you understand how the different parame-
ters interact. For instructions on how to create buttons and add
textures to them, refer to the tutorial starting on page 167.

Image Area

When you open PhotoButton, a maximum Image Area is set. T h e
Image Area is the maximum area, Width + Height, that your button
matrix can occupy. You specify the image area either explicitly by
selecting an image area before opening PhotoButton, or implicitly
by opening PhotoButton on any layer, image, or window. 

The image area selected when PhotoButton is opened will be the
maximum area you can work with for that PhotoButton session.
As you determine how many buttons will be in your matrix, and
how big each button will be, the total Image Area will
automatically be partitioned into equal parts to accommodate
your choices. 

Your button size will be constrained by how many buttons you
want in the matrix. Conversely, how many buttons you choose for
the matrix will constrain how much space each individual button
will occupy. For example: If you select a 100 pixel by 100 pixel
area, and you wish to have 2 rows and 2 columns of buttons, each
button can be no larger than 50 pixels x 50 pixels.

Setting the Initial Parameters: Number, Size, and Shape

When you initially open PhotoButton, you must indicate how
many buttons you wish to work with and how those the buttons
will be arranged (rows and columns). This sets the parameters for
the Button Matrix. (Note: A matrix can be composed of a single
button, indicated as 1 across and 1 down).

You may also choose to set the Width and Height of each button.
Since all buttons in the matrix will have identical shapes, the
Width and Height specification applies to all the buttons.

Button Matrix

Image Area:Width + Height

Sample Buttons Created
in PhotoButton
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Once the matrix parameters have
been set, changing the number of
buttons will affect both the size
and spacing of the buttons, unless

your settings are size protected. If you do not want your button
size to change (until you indicate a change by entering new values
in the Width and Height boxes, or by manually resizing with the
Resize tool), you can the lock the Width and Height by clicking
on the lock icon (see page 57).

You can select a shape for the button from the Shape pop-up
menu on the Shape tab at any time, modify a predefined shape, or
create your own custom shape and add it to the list. As soon as
you select a shape you can immediately see how the different but-
ton parameters you’ve set (such as color, bevels, texture) will
affect it. Remember that your results will be impacted by whether
or not you lock the button size.

The Anchor Button
Once you have established the parameters of the matrix (button
number, arrangement, size, and basic shape), you will work with
one button and PhotoButton will automatically apply your
changes to all the other buttons. This primary button is called the
Anchor Button  because all the other buttons are “anchored” to
this button. If you reposition or resize the Anchor Button, all the
buttons are repositioned and resized.

The Anchor Button (see the figure on page 56), is always the first
button in the matrix, located in the upper-left corner of the button
matrix. When you select either the Adjust (resize) tool or the Pen
(reshape) tool, the bounding box and handles that allow you to
work with the button will always be shown on the Anchor Button.
These button moving, sizing, and shaping tools are described in
“Positioning, Sizing and Shaping” on page 58.

Button Size
Since the Image Area (see the figure on page 54) is divided equal-
ly among the buttons in the matrix, it is more accurate to think of
button “size” as the total area, Width + Height, that the button
will occupy. This would include a share of the space between a
button and its surrounding neighbors. So the space between but-
tons is not “empty” space—it is an integral part of the button. 

Note: You can create the illusion of empty space between buttons
by coloring the outer part Transparent or None (no color). Refer
to page 67 for more information on the Transparent and None
options.
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Button Parts

Each button is composed of two parts: the Inner area and the
Bevel area. The Outer area is all the space outside the buttons.
Surface parameters, such as color, reflectivity, diffuse angle and
highlight ratio, can be defined separately for each of the button
areas. 

Inner area: The Inner area of the button is the space inside the
button extending up to the Bevel area. Changes in Bevel Width or
Corner Radius will affect the size of the Inner area.

Bevel area: The Bevel area of the button completely surrounds
the Inner area. It provides the boundaries of what you might com-
monly think of as the button itself, not taking into account the
space around the buttons.

Outer area: The Outer area consists entirely of the space
between and around each button, including any space between the
button and the outermost edges of the Image area. The Outer area
will change as buttons are resized and reshaped. Color is applied
to the entire Outer area at once, not on a button by button basis,
as the with the Inner and Bevel areas.

Anchor Button

Inner

Button Parts

Button
Outer area

Button
Size:
Height
+ Width

Bevel
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Before: 3x3 Matrix

Locking the Button Size

If button size must remain constant (for example, your buttons all
must be 50 pixels by 50 pixels), you can “lock” them to that size
using Size Lock/Unlock. Without the lock on, PhotoButton
assumes that you want to fill the available space with buttons, and
sizes the buttons accordingly.

When the Size Lock is on, changing the Number, Shape,
Rotation Angle, or Corner Radius does not affect button
size. The buttons can still be resized manually using the

Resize tool, or by typing in values in the Width and Height para-
meter boxes.

When the Size Lock is off, changing the Number, Shape,
Rotation Angle, or Corner Radius will undo all manual
resizing, and the buttons will be resized to entirely fill

their section of the image area.

Note: When the lock is on, increasing the number of buttons will
decrease the space between them. If a particular number of but-
tons will not fit on the canvas without resizing the buttons, that
number will be grayed out in the Number pop-up menu. 

Example: We started with a canvas 200 pixels square, then creat-
ed a 3x3 matrix of buttons specifying that each button be 50 pix-
els wide by 50 pixels high. This is shown in the figure on the left.

We then decided to change to a 2x3 matrix. In the figure on the
bottom-left (A), we locked in the button size with the Size Lock,
then selected “2” from the Rows pop-up. In the figure on the bot-
tom-right (B), we did not lock in the button size before selecting
“2” from the Rows pop-up. Notice that when button size is lock-
ed, the Outer area (space) grows to fill the Image Area. When the
button size is not locked, the buttons grow to fill the Image Area.

After:
2x3 Matrix

A B
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Positioning, Sizing, and Shaping

The button matrix can occupy all of, or any part of, the total
Image Area. The matrix can be moved about in the Image Area,
and the buttons can be resized and reshaped. However, individual
buttons cannot extend outside of their part of the button matrix.

Positioning: All buttons in the matrix move in relationship to the
Anchor Button, regardless of the number, shape, or size of the
buttons.

Adjust tool: The Adjust (reposition and resize) tool can
be used to reposition and rotate the buttons within the
matrix, and to interactively change the Width and/or

Height of the buttons. As the Anchor Button is repositioned or
resized, all of the other buttons will follow.

Note: Adjusting Corner Radius or Rotation Angle, or choosing a
new shape from the Shape pop-up, will cause any manual resizing
(with the Adjust tool) to be undone.

Adjust (Resize and
Reposition) Tool

Repositioning a
Button Matrix
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Pen (Shaping) Tool

Pen tool: The Pen tool can be used to add and remove
points for shaping the Anchor Button, and to reshape,
stretch and distort it. Drag a corner handle to change the

length and angle of the sides. Drag a side handle to move the
entire side without changing its length or angle.

Reshape
from Side 

Reshape from
Corner

Add an anchor point Option-click [Alt+click] on an existing line ( )
or double-click an existing line ( )

Delete an anchor point Option-click [Alt+click] an existing point ( )
or double-click an existing point ( )

Reposition a line Drag the line ( )

Reposition a point Drag the point ( )

Undo last drag Command-Z [Ctrl+Z]

To... With the Pen tool active...
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Creating Custom Shapes

You can create and save as many button shapes as you like, and
later select them from the button Shape pop-up menu. To create
new shapes you start with an existing shape, then use the Pen tool
to add or remove points, and to drag points and lines to new posi-
tions as required to create the new design. 

To create a Custom Button Shape:

1. Select the Shape tab by clicking it.

2. From the Shape pop-up menu, select a shape that is
similar to the shape you want to create.

3. Select the Pen tool. Position the Pen tool over a point
( ) to drag the point to a new position; position it over
a line ( ) to move the line.

When you make any change to a shape, the Shape pop-up
changes to “User Defined.”

3. To add points to the design, position the Pen tool over a
line, then Option-click [Alt-click] ( ) to create the new
point. To delete a point, Option-click [Alt-click] ( )
over an existing point.

4. Add or delete anchor points, and drag the points and
lines to create just the shape you want. 
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Things to Know about Custom Shapes:
• Once a custom shape has been saved it behaves like any other

pre-defined shape, and can be selected from the Shapes pop-up.
• To create a custom shape you must start with an existing shape,

then add, move, or delete points as necessary to create the new
shape.

• Shapes can only be made up of one path. You cannot create
gaps or holes in the design.

• Each shape is limited to 64 lines/65 points (64 sides).

• Paths cannot be imported.
• Saving a shape saves only the shape anchor points and paths.

Other effect values are saved from the Settings dialog.

To save a Custom Button Shape:

1. Create a new button shape as described on page 60.

2. Click the “Save” button below the Shape pop-up menu. 

Only the button shape will be saved. To save other shape
attributes, such as rotation angle and corner radius, create a
button “Settings” (see page 36). 

3. The new shape will be saved and added to the Shape
pop-up menu.

To use a Custom Button Shape:

Note: You must have created and saved a custom button shape
(as described above and on page 60) to have it available for
future use.

1. Select the Shape tab by clicking it.

2. Select a pre-defined custom shape from the Shape pop-
up menu.

The selected shape replaces the current button shape in the
Preview window.
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The Shape Outline

You can toggle the shape outline on or off by selecting the
“Show/Hide Outline” option from the View menu (View >
Show/Hide Outline), or by pressing Command-H [Alt+H].

The Shape Grid

You can display a grid over the image in the Preview window to
help you create and align your button shapes. You can choose a
grid size between 5x5 and 50x50, and you can elect to have
points and lines snap to the grid as you move them.

To enable or disable the Grid: 

1. Select “Show Grid” or “Hide Grid” from the View
menu, or press Command-" [Ctrl+"].

To change Grid Size: 

1. Select “Grid Size” from the view menu, then select the
desired size from the Grid Size sub-menu.

Creating Custom Button Bevels

The Bevel Shape Controls on the Bevel tab (see page 65) give
you access to all the pre-defined button bevel shapes, and allow
you to create, modify, and save shapes. You can select a bevel
shape from the list and use it as-is, or modify it using the bevel
editor on the Bevel Shape floating palette. You can show and hide
the Bevel Shape palette by clicking the “Show/Hide Bevel
Shape” button.

Bevel Shape Editor
The Bevel Shape floating palette provides the means for creating
and editing bevel shapes. You create bevels by adding points to
the graph. You shape the bevels by dragging the points to differ-
ent positions on the grid. Points are added by clicking on the
graph where you want to add a point. To delete a point, select it
and click “Delete.”

Each point controls one edge of a bevel. Moving a point along
the Y axis controls the height of an individual bevel. Moving a
point along the X axis controls the spacing between edges. When
you move one point the others remain locked in place. The curve
that joins the points will show peaks and valleys corresponding to
the peaks and valleys of the bevels. Points affect the image from
left to right, outermost bevel edge to innermost bevel edge.

Smooth Edge

Pointy Edge
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Seven pre-defined bevel shapes are
included on a pop-up menu on the but-
ton Bevel tab. You can use these bevel
shapes as-is, or modify them to suit your
needs, and you can save your custom
bevel shapes for future use. Saving a
bevel shape saves only the shape. To
save the values of the other four bevel
effects (Width, Height, Softness, and
Inner Height), you must create a button
“Settings” (page 36).

Three of the pre-defined bevel shapes
are presented here to help you visualize
the limitless possibilities.

B Half Pipe: Consists of five points. The
first four points are Smooth, while the
last (representing the innermost edge)
is Pointy. This produces an overall
smooth bevel, with a sharply defined
inner edge. The edge rises from out-
side to center, then back down to the
inner edge, creating a pipe-like look.

A Double:Consists of seven points.
Similar to the Half Pipe, but with two
rounded bevels. The outermost edge
of each bevel is Pointy, as is the cen-
ter point which separates the two
bevels. The two inner points of each
bevel are Smooth points, creating a
rounded appearance. The overall
effect is a double bevel with sharply
defined edges with smooth transitions
between them. 

C Triangle:Consists of three points. All
three are Pointy points, creating a
sharp (chisel-like) transition between
the outer, middle, and inner edges.

Sample Bevel Shapes

B - Double

A - Half Pipe

C - Triangle
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Note: You can affect the width and height of all the bevels at once
by using the Width and Height sliders Other sliders allow you to
change Bevel Softness and Inner Height. These attributes are not
saved when you save the Bevel Shape. To save these other attrib-
utes you must create a button “Settings” (see page 36). 

Points can be used to create either a smooth (curving transition)
edge, or a pointy (sharp transition) edge. Smooth edges are pro-
duced by default; sharp edges are produced when you click the
Pointy box to enable it (an “x” indicates that the new point will
create a sharp edge). You can change Smooth points to Pointy
points and vice versa by selecting the point and enabling or dis-
abling the Pointy option.

To create or edit a Custom Bevel Shape:

1. Select the Bevel tab by clicking it.

2. Select a bevel shape from the pop-up menu.

The selected shape parameters will be applied to the image
in the Preview window, and the graph representing the cur-
rently selected shape will be displayed in the Bevel Shape
thumbnail.
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The button Bevel Shape Controls allow
you to select, create, modify, and delete
bevel shapes. 

Bevel Shape Controls

A Bevel Shapes Pop-up Menu: Provides
access to all pre-defined and saved
shapes. When a shape has been
selected, any change to the displayed
shape (editing it) will cause the “User
Defined” name to be displayed. 

B Bevel Shapes Thumbnail:Displays a
thumbnail representation of the shape
as shown on the BevelShape palette. 

C Save: Allows you to name and save
the current shape. When saved, the
new shape appears on the Shapes
Pop-up Menu (A). (This options saves
only the bevel Shape. To save bevel
style parameters, you must create a
“Settings” (page 36).

D Delete:Deletes the selected Shape.

E Bevel Shape Editor: Clicking the but -
ton opens or closes the Bevel Shape
editor palette. To use the editor, click
to add a point to create a new edge.
To change edge spacing and height
drag the point to a new position on the
grid. Select the point and click Smooth
for a smooth bevel transition; click
Pointy for a sharp transition.

Bevel Shape Editor

F Bevel Shape points and curves:
Displays a visual representation of the
mathematical position, transition, and
spacing of each bevel using a grid.
Points correspond to bevel edges from
left to right, outer to inner.

G Pointy edge selector:When enabled
(X in the box), new points will have a
Pointy, or sharp, edge. When not
selected, new points will have a
Smooth edge. To change an edge
from Smooth to Pointy, select it’s cor-
responding point and check this box.
To change an edge from Pointy to
Smooth, select it corresponding point
and uncheck this box.

H Delete: Deletes the selected point.

A

CB D

E

Bevel Shape Controls

Bevel Shape Controls

Shape Applied to Button

Bevel Shape Editor

outermost edge innermost edge

max bevel height

min bevel height

F

G H
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3. Open the Bevel Shape palette by clicking the
“Show/Hide Bevel Shape” button.

4. Create bevels by clicking on the graph to create points.
Each point represents a bevel edge on the image.

Smooth points create smooth edge transitions. Pointy
points created sharp, or “pointy” edge transitions. To an
remove an edge from the image, select the corresponding
point on the graph and click “Delete.”

5. Drag the points and/or connecting lines to different
positions on the graph until you create the bevel design
you are looking for.

You can follow your effect changes as you make them by
watching the Preview window.

6. Add Style options such as highlighting and softness, or
increase the bevel height and width for the whole image
until you achieve the design you are looking for.

You can use the new shape and/or save it for future use.

To save a Custom Bevel Shape:

1. Click the “Save” button under the “Show/Hide Bevel
Shape” button.

2. Enter a name for the Shape, then click “OK.”

Your custom Shape will be added to the bottom of the
Bevel Shape pop-up menu.

Note: To save other bevel attributes, such as Bevel Height,
Bevel Width, Bevel Softness, and Inner Height, you will
need to create a Settings (see page 36).

Click to place a
new point.Click
on an existing
point to select it.
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Coloring Buttons 

Note: Options that affect color are discussed in “Creating Color
Effects using Surface Property Controls” on page 72.

Color can be applied separately or simultaneously to the two but-
ton parts (Inner and Bevel) and the button Outer area.

Paint Color pop-up: Provides access to the PhotoButton Color
Palette, the current Photoshop Foreground and Background colors,
and the Color Picker. Color values are shown on the right side of
the palette, reflecting both the current Color Mode (RGB, CMYK,
etc) and the color values of the highlighted color. 

Note: In RGB mode, the Color pop-up displays all and only
“web-safe” colors. This does not mean that the final result color
will be web-safe, since button colors may be blended and/or faded
to the background.

None: Remove or fill previously used color with No Color.
Similar to resetting the color, but the None color swatch must be
selected and applied as the Paint Color. Areas of the image col-
ored “None” will show their original content.

Transparent: Transparent color. Value will always be 0%
(opaque) except for the transparent color. This option becomes
available when you are working on a layer with transparency. It
can be used to “knock out” the background around the buttons.

Note: Photoshop’s background layer does not include transpar-
ency. To add transparency to the Background layer: Before open-
ing PhotoButton, double-click “Background” on the Photoshop
Layer Palette (F7), then hit Return or Enter.

Note: When working on a normal (not Transparent) layer, for
example the background layer, this feature allows the background
image to “show through” a semi-opaque button, allowing you to
create stunning button effects with textures, gradients, etc.
Clicking Reset returns the buttons to their default condition,
causing it to look like the buttons have disappeared. For
instructions on how to make the button visible, refer to
“Troubleshooting,” page 176.
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To Color Button Parts Individually:

1. Select a color from the Paint Color pop-up, or use the
Eyedropper to extract a color from the Preview.

2. Select the Paint Bucket tool, then click the button part
you wish to color.

With the Fill Bucket ( ) tool selected you can color any
part of any button by clicking on it.

To remove a color, select the Remove Bucket ( ) tool
(the bucket with an “x” on it), then click the button part.

To Color a Button Part for all Buttons Simultaneously:

1. Click and hold the Paint Color Pop-up.

2. Press and hold the modifier key for the button part you
wish to color.

Modifier keys: 

Inner: Shift

Bevel: Option [Alt]

Outer: Command [Ctrl]

3. When you see the color you want to apply to the button
part, release the modifier key and/or the pop-up.

— or —

1. Select the Eyedropper tool, then drag it over the
Preview.

2. Follow steps 2 and 3 above.

— or —

1. Select the desired color using either the Paint Color
pop-up or the Eyedropper.

2. Select the Paint Bucket tool.

3. Hold down the Option [Ctrl] and click the Paint Bucket
tool on the button part you wish to color.

The selected color will be applied to the selected button
part of all the buttons.

Tip

Using the modifier keys and the
Paint Color pop-up, you can
select and fill all parts of all but-
tons without ever leaving the color
pop-up. Simply keep the pop-up
open and a modifier key down
and watch the Preview. When you
see the color (or effect) you want,
release the modifier key. Keep the
pop-up open and press the modifi-
er for the remaining button parts.
You can change colors this way
until you achieve just the right
effect.

This tip works with the Eye-drop-
per tool as well—with a modifier
key pressed, drag the Eyedropper
over the Preview and watch the
button color change.
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Creating Color Effects Using Surface Property Controls

Once you have selected and applied a Paint Color to the selected
button part, you can adjust or apply effects to the color using the
Surface Property Controls in the Inner, Bevel, and Outer Color
tabs. Surface Property Controls include: Surface Reflectivity,
Diffuse Angle, and Highlight Ratio (page 52).

Surface Reflectivity: Controls the amount of light reflected or
absorbed. 0% reflectivity yields a matte look, where all light is
absorbed resulting in no reflection. 99% reflectivity yields a high
gloss look, with maximum reflectivity.

Diffuse Angle: Controls the degree to which light is diffused over
the surface. 1% diffusion yields a focused, spotlight effect, while
90% diffusion yields a diffused, washed-out effect.

Highlight Ratio: Controls the amount of light striking the select-
ed button part. 0% highlight yields no light. 100% yields maxi-
mum light.

No Highlighting: Disables the three Color Controls: Surface
Reflectivity, Diffusion, and Highlight Ratio. The effect is as if all
controls were set to minimum.

Highlighting Color and Effects

The Highlighting Color Controls determine what Color will be
used to highlight the button, and the Direction and Inclination of
the light source for highlighting. Highlighting affects all the but-
ton parts unless you choose No Highlighting in the tab for any or
all of the three button parts.

Highlighting Color pop-up: Used to select the color of the light
being cast over the button parts. Similar to the button parts Color
pop-up, but selects highlighting color. Note: None and
Transparency cannot be used for the Highlight Color.

Direction: Controls the direction of the light source on a two-
dimensional plane. Can be likened to shining a light on the image
from north, south, east, or west, or any point in between.

Inclination: Controls the arc of the light source over the three
dimensional plane. Can be likened to shining a light on the image
from above, to the side, or any point in between. 90° Inclination
indicates that the light source is directly over the image. 

Interactive Controls: Use the directional model control knob to
change Direction and Inclination simultaneously. When the knob
is in the center, inclination is 90° . 0° inclination means the light
source is in the same plane as the buttons.

Control Knob for
Interactive Control

Highlighting Color Controls
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Same file applied as a Bump Map

Adding Textures and Bump Maps

You can use existing JPEG (.jpg) files (such as those created in
PhotoTexture) and even alpha channels to add textures and bump
maps to your buttons.

Textures: Textures are two-dimensional images that you can use
to create a background for the button inner, bevel, and/or outer
areas. Highlighting does not affect textures.

Bump Maps: Bump maps can be created from the same two-
dimensional images (JPEGs and alpha channels) that you can use
to add texture to the button. But bump maps use only the lumi-
nosity values of the image, creating raised bumps or depressed
areas based on bump map blur and height, and button highlight-
ing. Bump maps can be applied to the inner, bevel, and/or outer
button areas. 

You can apply a texture or bump map to selected sections of a
button by clicking it with the appropriate Texture Bucket ( ) or
Bump Map Bucket ( ). To apply a Texture or Bump Map to all
parts of all buttons at once, click the appropriate “Fill All” button
on the Texture tab. 

To remove a texture or bump map from individual button parts,
click the area with the appropriate Remove Bucket ( , )

(“x” displayed on the bucket, “T” or “B” in the upper left of the
icon). You can remove all button textures or bump maps by click-
ing the appropriate “Remove All” button.

Texture file applied as a Texture
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Grooves and bevels give the selected parts of an image a raised or
lowered appearance by applying highlights to the inside and out-
side edges. With PhotoGroove, you have infinite control over the
number, shape, and spacing of grooved edges using an interactive
shaping grid. You can create complex compound grooves simply
by adding or deleting points on the curve, then change the width
and spacing by dragging the curve to any point on the graph, and
you can save your shapes for later use. PhotoGroove also pro-
vides you with a thumbnail preview of the shaping graph for the
currently selected shape.

All groove options, including shaping, bevel width, edge feather-
ing, softness, highlights, and light direction respond in real-time,
and you can optionally view composite layers to see just how
your effects will look with other picture elements.

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33.  

Tip

For a listing of keyboard shortcuts,
see Appendix A, page 174.

PhotoGroove

L Highlight Eyedropper: Extracts a highlight color from the preview.

M Cancel: Closes the dialog box without making changes to the image. You can
also Cancel by pressing Command-“.” (period) [Alt+F4].

N Apply: Adds your selected effects to the image and closes the dialog box. You
can also Apply the effect by pressing Return or Enter.

A Preview Window

B Shape Controls: Control shape and
spacing of individual grooves and
bevels using an interactive shaping
palette (see page 76).

C Width: Adjusts width for all edges at
once.

D Height: Adjusts depth for all edges at
once.

D Softness: Adjusts bevel softness, or
the transition between light and dark.

F Material: Apply preset surface property
parameters like Chrome, Heavy Metal,
Metal, Plastic, Rubber, and Matte.

G Highlights Pop-up Color Palette: Set
the inner and outer bevel highlight
color. Color picked with the eyedrop-
per is displayed here.

H Light Direction Field and Indicator:
Adjusts the direction and inclination 
of the light source. Indicates direction
and inclination in °.

I Highlight Inner/Outer:Determines
whether selected highlight color will
affect Inner (the bevel and anything
inside it), Outer (the entire area out-
side the selection), both or neither.

J Settings controls: Save, Select, and
Delete effect Settings (see page 36).

K Help Box: Displays a description of
each tool or option as the mouse pass-
es over it.

B

C

D

A

E

H

I

J

F
G

K L M N

The PhotoGroove Dialog Box
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The Shape Controls allow you to select,
create, modify, and delete bevel shapes. 

Shape Controls

A Shapes Pop-up Menu: Provides
access to all pre-defined and saved
shapes. When a shape has been
selected, any change to the displayed
shape (editing it) will cause the “User
Defined” name to be displayed. 

B Shapes Thumbnail:Displays a thumb-
nail representation of the shape as
shown on the BevelShape palette. 

C Save: Allows you to name and save
the current shape. When saved, the
new shape appears on the Shapes
Pop-up Menu (A). (This options saves
only the bevel Shape. To save bevel
style parameters, you must create a
“Settings” (page 36).

D Delete:Deletes the selected Shape.

E Bevel Shape Editor: Clicking the but-
ton opens or closes the Bevel Shape
editor palette. To use the editor, click
to add a point to create a new edge.
To change edge spacing and height
drag the point to a new position on the
grid. Select the point and click Smooth
for a smooth bevel transition; click
Pointy for a sharp transition.

Bevel Shape Editor

F Bevel Shape points and curves:
Displays a visual representation of the
mathematical position, transition, and
spacing of each bevel using a grid.
Points correspond to bevel edges from
left to right, outer to inner.

G Pointy edge selector:When enabled
(X in the box), new points will have a
Pointy, or sharp, edge. When not
selected, new points will have a
Smooth edge. To change an edge
from Smooth to Pointy, select it’s cor-
responding point and check this box.
To change an edge from Pointy to
Smooth, select it corresponding point
and uncheck this box.

H Delete: Deletes the selected point.

A

CB D

E

Shape Controls

Shape Controls

Shape Applied to Image

Bevel Shape Editor

outermost edge innermost edge

max bevel height

min bevel height

F

G H
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Shape Controls

The bevel Shape Controls (see (B) on page 75, and the figure on
page 76) give you access to all the pre-defined shapes, and allow
you to create, modify, and save bevel shapes. You can select a
shape from the list and use it as-is, or modify it using the bevel
editor on the Bevel Shape floating palette. You can show and hide
the Bevel Shape palette by clicking the “Show/Hide Bevel
Shape” button.

Bevel Shape Editor

The Bevel Shape floating palette provides the means for creating
and editing bevel shapes. You create bevels by adding points to
the graph. You shape the bevels by dragging the points to differ-
ent positions on the grid. Points are added by clicking on the
graph where you want to add a point. To delete a point, select it
and click “Delete.”

Each point controls one edge of a bevel. Moving a point along the
Y axis controls the height of an individual bevel. Moving a point
along the X axis controls the spacing between edges. When you
move one point the others remain locked in place. The curve that
joins the points will show peaks and valleys corresponding to the
peaks and valleys of the bevels. Points affect the image from left
to right, outermost bevel edge to innermost bevel edge.

Note: You can affect the width and height of all the bevels at once
by using the Width and Height sliders ((C) and (D) on page 75). 

Points can be used to create either a smooth (curving transition)
edge, or a pointy (sharp transition) edge. Smooth edges are pro-
duced by default; sharp edges are produced when you click the
Pointy box to enable it (an “x” indicates that the new point will
create a sharp edge). You can change Smooth points to Pointy
points and vice versa by selecting the point and enabling or dis-
abling the Pointy option.

Selecting and Saving Bevel Shapes

When a shape has been selected, any change to the displayed shape
(that is, once you start editing it) causes the “User Defined” shape
name to be displayed. The newly created shape can then be saved
with a different name, and  selected from the Shapes pop-up. 

Note: Saving a bevel shape using the Save button in the Shape
Controls area does not also save bevel style parameters like soft-
ness and highlighting. To save styles, create a Settings using the
Settings controls near the bottom of the palette (page 36.)

Smooth Edge

Pointy Edge
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Seven pre-defined shapes are included
with PhotoGroove that you can use as-
is, or modify to suit your needs. (You can
also create your own shapes from
“scratch.”) Three of the pre-defined
shapes are presented here to help you
visualize the limitless possibilities.

A Ramp:Consists of two points. Both
the outer edge and inner edge points
are smooth, creating a smooth transi -
tion on both edges. The bevel also
progresses upward from the outer to
the inner, giving a raised center, or
plateau, appearance.

B Half Pipe: Consists of five points. The
first four points are Smooth, while the
last (representing the innermost edge)
is Pointy. This produces an overall
smooth bevel, with a sharply defined
inner edge. The edge rises from out-
side to center, then back down to the
inner edge, creating a pipe-like look. 

C Triangle:Consists of three points. All
three are Pointy points, creating a
sharp (chisel-like) transition between
the outer, middle, and inner edges.

Sample Shapes

A - Ramp

B - Half Pipe

C - Triangle
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To create or edit custom bevels using PhotoGroove:

1. Select a bevel shape from the pop-up menu in the top
left corner of the PhotoGroove window, or do nothing
to work with the Last Used settings that are automati-
cally applied to the image.

The selected shape parameters will be applied to the image
in the Preview window, and the graph representing the cur-
rently selected shape will be displayed in the Bevel Shape
thumbnail.

2. Open the Bevel Shape palette by clicking the
“Show/Hide Bevel Shape” button.

3. Create bevels by clicking on the graph to create points.
Each point represents a bevel edge on the image.

Smooth points create smooth edge transitions. Pointy
points created sharp, or “pointy” edge transitions. To an
remove an edge from the image, select the corresponding
point on the graph and click “Delete.”

3. Drag the points and/or connecting lines to different
positions on the graph until you create the bevel design
you are looking for.

You can follow your effect changes as you make them by
watching the Preview window.

4. Add Style options such as highlighting and softness, or
increase the bevel height and width for the whole image
until you achieve the design you are looking for.

5. Click “Apply” to apply the effect to your image.

To Save a Shape:

1. Click the “Save” button under the “Show/Hide Bevel
Shape” button.

2. Enter a name for the Shape, then click “OK.”

Your custom Shape will be added to the pop-up menu.

Note: To save style settings along with the shape, you will
need to create a “Settings” (see page 36).

Click to place a
new point.Click
on an existing
point to select it.
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Bevel Style Controls

You can apply style parameters to your bevels (style options are
applied to all bevels at once), such as edge softness and highlight-
ing. Two other options which are considered style characteristics
are Width and Height [(C) and (D), page 75]. These affect all the
bevels, unlike the size and spacing controls on the Bevel Shape
editor that you use to affect each bevel individually.

Width, Height, and Softness

Adjust the Softness control to soften all the beveled edges
equally. Adjust the Width and Height controls to adjust the width
and/or height of all bevels equally.

Highlighting Color and Effects

The Highlighting Controls ((G), (H), and (I), page 75) determine
what Color will be used to highlight the bevels, and the Direction
and Inclination of the light source for highlighting. Highlighting
affects all the bevels. You can elect to highlight just the inner
edges, just the outer edges, or turn off both options to have no
highlighting. 

Highlighting Color pop-up: Selects the color of the light being
cast over the over the bevels. Highlighting color extracted from
the image using the Eyedropper tool is displayed here.

Direction: Controls the direction of the light source on a two-
dimensional plane. Can be likened to shining a light on the image
from north, south, east, or west, or any point in between.

Inclination: Controls the arc of the light source over the three
dimensional plane. Can be likened to shining a light on the image
from above, to the side, or any point in between. 90° Inclination
indicates that the light source is directly over the image. 

Interactive Controls: Use the directional model control knob to
change Direction and Inclination simultaneously. When the knob
is in the center, inclination is 90° . 0° inclination means the light
source is in the same plane as the bevels.

Highlight Inner/Outer: Click to select inner, outer, both, or no
highlighting. An “x” in the box indicates that highlighting will be
applied.

Control Knob for
Interactive Control

Highlighting Color Controls
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PhotoCastShadow is the fastest, most robust shadow generator
ever developed. Instantly create professional multiple cast
shadows and drop shadows. Grab a corner, edge, or center of the
s h a d o w ’s wireframe to interactively rotate, stretch, and skew the
shadow to any perspective, and place it anywhere on the image.
Easily adjust the shadow’s perspective blur to show realistic
dimension—without purchasing and learning a 3-D application.

Add shadows, show or hide them, and see the results of all
visible shadows on the composite image interactively, as you
create or modify each one. Use Invert Shadow to create useful
cutouts and other effects. Select Shadow Only to isolate the
whole shadow—not just the shadow outline—on it’s own
l a y e r.  And as with all PhotoEffects, you can undo and redo
e ffects multiple times, and save effects settings for future use.

PhotoCastShadow

A Preview Window

B Shadows List: Lists all the shadows
created for this image. Eye icon indi-
cates that a shadow is visible. Only
shadows displaying the eye icon will
be applied to the image when the
Apply button is clicked.

C Add/Delete Shadow: Allows you to
add, rename, or delete shadows. 

D Style and Shape Tabs: Provides
interactive controls for adjusting
shadow attributes—see page 78.

E Settings Controls: Select, Save, and
Delete effect settings. See page 36.

F Help Box: Displays a description of
each tool or option as the mouse
passes over it.

G Adjustment tool: Allows you to shrink,
stretch, rotate, position, and skew the
selected shadow.

H Eyedropper: Allows you to specify a
color for the selected shadow by
selecting it from the preview.

I Cancel: Closes the dialog box
without making changes to the
image. Also Cancel by pressing
Command-“.” [Alt+F4].

J Apply: Adds your selected effects to
the image and closes the dialog box.
You can also Apply the effect by
pressing Return or Enter.

B

A

C

D

E

G

H

F I J

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33. 

The PhotoCastShadow Dialog box

Tip

For a listing of keyboard shortcuts,
refer to Appendix A, page 174.
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Style Options

A Blur: Controls amount of shadow blur,
in pixels. This blur is a constant, pro -
viding the same blur value every-
where around the image.

B Perspective Blur: Controls shadow
blur, in pixels. Blur changes depend-
ing on how far the shadow is from its
corresponding spot on the image.
Creates a more realistic 3-D shadow.

C Opacity: Controls translucency of the
shadow, as a percentage. 0% opacity
is completely transparent; 100%
opacity is completely opaque.

D Noise:Controls amount of noise
applied to the shadow. This blur is
value is constant, providing the same
blur value everywhere around the
image.

E Blend Mode: Normal, Multiply,
Screen, Darken, Lighten, Differ-
ence. Effect is applied only on the
target layer.

F Color palette popup: Sets the shad -
ow color. Color picked with the eye-
dropper is displayed here.

Shape Options

G X Offset: How far the shadow is off-
set from the image in the horizontal
plane, in pixels.

H Direction: Angle at which the shadow
slants away from the image, in
degrees.

I Reset Shadow Shape: Click to
restore the selected shadow to the
last-saved settings.

J Invert Selection: Inverts the eff e c t ,
applying the shadow inside the selec-
tion rather than outside it.

K Create Shadow only: Moves the sha-
dow in front of the selection in the
Preview window. Keeps the shadow
and deletes the image on selecting
Apply (see page 83 for more details) .

L Y Offset: How far the shadow is of f-
set from the image in the vertical
plane, in pixels.

M Length: Length of shadow, as a
percentage of image size.

N Rotation Angle: Shadow rotation, in
degrees.

A

B

C

D

E

G

H

L

M

N

I

J

K

F

Shadow Style and Shape tabs

Shape

Style
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Getting Started with PhotoCastShadow

The Shadow Frame
PhotoCastShadow provides you with an interactive wireframe
that bounds the shadow on all sides, so that you can quickly and
easily manipulate the size, shape, and placement of the shadow.
As with all of the PhotoEffects plug-ins, when you open
PhotoCastShadow, the shadow applied to the selected image will
be what was automatically saved in the Setting “Last Used.”

The shadow frame has 8 handles, or hot spots, one on each side
and one on each corner, that allow you to shrink, stretch, pull, and
skew the shadow into various shapes. Two other hot spots, one
inside the box and the other outside the box, allow you to position
the shadow—either offsetting it from the image slightly, or placing
it anywhere on the canvas—and to rotate the shadow a full 360°.

You will see the shadow frame whenever you have the

Adjustment tool selected and positioned inside the Preview win-
dow. As you pass the Adjustment tool over the 10 hot spots, the
tool will change shape to indicate the type of movement that will
be applied when you click and drag from that spot. 

The side handles (top, bottom, left, right) can drag the image
from their respective side of the shadow in any direction. The
corner handles can drag the image from their respective corner in
any direction. The inside and outside pointers will drag the entire
shadow and frame.

Sides
Inside Outside

Outside (rotate)

Corners

Corners (Distort in/out)

Dual direction distort
(side handle movement shown)

Sides (Distort left/right, up/down)

Inside (move)



Shadow Style Options  (Style Tab)  
Other shadow effects, such as Blur, Perspective Blur, and
Opacity, can be adjusted with the interactive sliders or entered as
absolute values.

Blurs, Blends, Noise and Color Controls  (Style Tab)
The Blur, Opacity, Noise, Blend, and Color Controls behave
exactly as they would if applied directly in Photoshop, except that
the PhotoCastShadow blend modes only blend the effect pixel
with the target layer pixels (not affecting any underlying layers).

With Perspective Blur, you have the additional advantage of hav-
ing a blur that decreases the closer it is to its corresponding spot
on the image. This makes the shadow look more realistic, allowing
you to create truly professional 3-D effects—in a fraction of the
time, and without the overhead of complex 3-D graphics software.

The Color pop-up allows you to interactively see how your
shadow will look as you move the pointer back and forth over
the colors in the palette. Dragging the Eyedropper over any
colored area in the Preview window allows you to interactively
see the effect of changing your shadow color using a color from
the Preview window.
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Each shadow appears on the Shadows
List, even if you only one shadow has
been created. Double-click a name on
the list to change it.

A Show/Hide Shadow Indicator: Eye
icon indicates that the shadow is visi-
ble in the Preview window, and will
be applied to the image when the
effect is applied.

B Selected Shadow: The currently
selected shadow is highlighted on the
list. Effect options (position, style,
shape, color) are applied to the
selected shadow. In the Preview win-
dow, click a shadow to select it.

C Shadow List: Lists all the shadows
available for the current editing
session.Shadows on the list are
saved in the shadow Settings, when
the Settings is saved.

D Add Shadow:Click to add and name
the new shadow.

E Delete Shadow: Click to delete the
selected shadow. 

C

Creating Multiple Shadows

A B

D E

Tip

To “start over” when your selected
shadow has been skewed beyond
usefulness, click Reset Selected
Shadow.

To maintain Color and Blur set-
tings while Resetting all other
effect parameters, press Option
[ALT] when you click Reset.
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Shadow Position and Shape Values  (Shape Tab)
The two shadow position controls and most of the shadow shap-
ing controls can be entered in absolute values using the parameter
entry boxes. These include: X and Y Offset, Direction, Length,
and Rotation.

Using these absolute values, a shadow exactly the same size,
shape, and location as the image would have X and Y Offsets of
zero pixels, a Length of 100%, a Direction of 0%, and a Rotation
of 0°, and would be completely hidden by the image (unless a
Blur has been added, in which case the shadow would “peek”
around the edge of the selection like a glow.)

The one shaping control that does not have an equivalent absolute
value is Corner distortion. To distort from a corner you must use
the Pointer tool to drag from the corner.

Position Controls
The two position controls in PhotoCastShadow, Move and Rotate,
control the position of the shadow in the X/Y plane of the canvas,
and its rotation. The Position Controls, unlike the Shape Controls,
operate on the full shadow, allowing you to move it anywhere on
the canvas, or rotate around its centerpoint a full 360 degrees.

To Position the Shadow:

1. Select the Adjustment tool ( ).

2. Place the tool inside the shadow frame: the pointer
should look like the Adjustment tool ( ).

3. Click and drag the shadow to the desired position, then
release.

— or —

1. Enter the desired position using the X and Y coordinate
boxes.

To Rotate the Shadow:

1. Select the Adjustment tool ( ).

2. Place the tool outside of the shadow frame: the pointer
should look like a circular arrow ( ).

3. Click and drag the shadow to the desired position, then
release.

— or —

1. Enter the desired rotation using the Rotation Angle
attribute box.

Tip

To constrain Adjustment tool to
Side movement during a resize
operation, press Command
[CTRL] while dragging. 

To constrain the Adjustment tool to
Center movement, press Option
[Alt] dragging. 
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Shape Controls
The 8 handles, or hot spots, along the border of the shadow frame
constitute the Shape Controls. The Shape Controls operate togeth-
er, giving you full freedom to reshape the shadow in nearly any
way imaginable. Parameters affected are the X Offset, Y Offset,
Direction, and Length.

To Distort the Shadow Shape:

1. Select the Adjustment tool ( ) .

2. Place the tool on any handle around the perimeter of
the shadow frame: the pointer should look like an
arrow with a directional pointer ( ).

3. Click and drag the shadow to the desired position.

— or —

1. Enter the desired shape parameters in the shape para-
meter boxes on the Shape tab.

Note: The only size parameter you cannot change by enter-
ing a value in a parameter box is Corner distortion. To dis-
tort from a corner, you must use the Adjustment tool to
drag from a corner.
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Create Shadow Only  (Shape Tab)
Allows you to separate all visible shadows from the image perma-
nently, and provides you with a full shadow image, not just the
outline. When you select this option the shadow(s) will move in
front of the image in the Preview window, and the image itself
will be discarded when the effects are applied.

Important: If you wish to keep a copy of the original image layer
after selecting and applying Create Shadow Only, you must cre-
ate a copy of the layer before opening PhotoCastShadow.

Invert Selection  (Shape Tab)
Allows you to invert the shadow color and move the shadow from
outside the image to inside it, creating a variety of interesting
effects, including cutouts.

Shadow Preset Settings
PhotoCastShadow includes several pre-configured default shad-
ows that you can select from the Settings menu. You may want to
use these shadows “as is,” or as a starting point for more creative
and complex shadow effects. 

Default shadow settings include: Last Used, Drop Shadow, Cast
Shadow, and Cutout. Last Used is updated each time your effects
are applied to the image, and will be automatically reapplied each
time you open PhotoCastShadow. To change this setting, either
click Reset to eliminate all shadow effects (start from scratch),
select an effect setting from the pop-up menu, enter values in the
attribute boxes, or just begin manipulating the shadow frame.

Only the shadow(s) visible in the Preview window (eye icon
being displayed) are saved when you create shadow Settings.

For more detailed information on creating, selecting, saving, and
using Settings, refer to page 36.
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With PhotoBevel, you have point and click control over four
different bevel types that can be applied to an image or floating
selection (such as text): Flat, Round, Slope, and Double. You can
apply a different bevel to the inside and/or outside edge of the
selection area, control bevel edge tolerance, and apply different
colors to the highlight (affecting the inside edges) and the shadow
(which affects the outside edges). 

All bevel options, including edge feathering, softness, highlights,
shadow intensity, and light direction respond in real-time, and you
can optionally view composite layers to see just how your effects
will look with other picture elements.

J Help Box: Displays a description of
each tool or option as the mouse
passes over it.

K Highlight Eyedropper: Extracts a
highlight color from the preview.

L Shadow Eyedropper: Extracts a
shadow color from the preview.

M Cancel: Closes the dialog box without
making changes to the image. You
can also Cancel by pressing
Command+“.” (Macintosh) or ALT+F4
(Windows).

N Apply: Adds your selected effects to
the image and closes the dialog box.
You can also Apply the effect by
pressing Return or Enter.

A Preview Window

B Bevel Type: Controls Inner and Outer
Bevel options. Outer is only active if
you’ve selected less than the entire
image. 

Bevel Shape: Controls bevel shape
(Flat, Round, Slope, or Double).

C Edge Tolerance: Refers to feathered
and implicit selections. Allows you to
control which pixels PhotoBevel con-
siders the edge. Maximum: All feath-
ered pixels are used when defining the
bevel area; Minimum: No feathered
pixels used; Medium: Half of feathered
pixels used.

D Width: Determines bevel width.
Softness: Similar to a blur; it softens
the transition points between light and
dark.

E Balance: Adjusts balance between the
Highlight and the Shadow of the bevel.

F Highlight and Shadow Intensity:
Control the strength of bevel highlights
and shadows.

G Light Direction Field and Indicator:
Adjusts the direction of the light
source and indicates direction in °.

H Highlight and Shadows Pop-up Color
Palettes: Sets the bevel highlight and
shadow colors. Colors picked with the
eyedroppers are displayed here.

I Settings controls: Save, Select, and
Delete effect Settings.

B
C

A

D

E

H

I

F

G

PhotoBevel

K

J L M

N

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33.  

The PhotoBevel Dialog Box

Tip

For a listing of keyboard short-
cuts, see Appendix A, page 174.
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PhotoEmboss works like no other embossing tool. Its unique con-
trols and emboss styles give you the ability to create cutouts,
embosses, reliefs, recesses, and many other special effects.

PhotoEmboss includes options for selecting the emboss type,
along with the amount, of embossing. You control the contrast,
softness, highlight and shadow of the embossing. In addition, you
can position a directional light source and customize the color of
the emboss highlight and shadow.

PhotoEmboss

J Help Box: Displays a description of
each tool or option as the mouse
passes over it.

K Highlight Eyedropper: Extracts a
highlight color from the preview.

L Shadow Eyedropper: Extracts a
shadow color from the preview.

M Cancel: Closes the dialog box without
making changes to the image. You
can also Cancel by pressing
Command+“.” (Macintosh) or ALT+F4
(Windows).

N Apply: Adds your selected effects to
the image and closes the dialog box.
You can also Apply the effect by
pressing Return or Enter.

A Preview Window

B Emboss Type: Cutout, Raise, Edges,
Blur.

Cutout typically pushes in the selection
area; Raisetypically pushes out the
selection area.

Edges applies the highlight and shad-
ow emboss colors around the inside
and outside of the selection edge. This
effect more dramatically defines the
selection edge.

B l u r creates an off focus, fuzzy emboss.

C Amount: Indicates Width of the emboss.

D Softness: Similar to a blur—softens the
transition points between light and dark.

Contrast: Controls the amount of dif -
ference between lightness and dark-
ness of the emboss.

E Highlight and Shadow Intensity:
Controls the strength of emboss high -
lights and shadow edges.

F Invert: Changes emboss effect 180°.

G Light Direction Field and Indicator:
Adjusts the direction of the light source
and Indicates direction in degrees.

H Highlight and Shadow Pop-up Color
Palettes: Determine the bevel highlight
and shadow colors. Colors picked with
the eyedroppers are displayed here.

I Settings controls: Save, Select, and
Delete effect Settings.

B

C

H

A

D

E

I

K

J L M

N

F
G

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33.  

The PhotoEmboss Dialog box

Tip

For a listing of keyboard shortcuts,
refer to Appendix A, page 174.
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As an artist, imagine creating an image of a neon sign or a candle.
You would typically add a glow effect around the outer edges of
the neon sign and around the candle’s flame. PhotoGlow makes
this process easy: apply a high radiance for a soft, subtle glow or
a low radiance for an intense, hard, bright glow.

Apply a solid glow to the selected image or just to its edges.
Determine how far the glow should extend, and control its radi-
ance (glow diffusion). In addition, you can add a solid stroke
around any selection. Change glow opacity (how much the glow
will show through) to highlight an image containing light text on a
light background: choose a glow color darker than the background,
then increase the opacity of the letters’glow to make them more
visible against the light background.

J Settings controls: Save, Select, and
Delete effect Settings.

K Help Box: Displays a description of
each tool or option as the mouse
passes over it.

L Eyedropper: Extracts a glow color
from the preview.

M Cancel: Closes the dialog box without
making changes to the image. You
can also Cancel by pressing
Command+“.” (Macintosh) or ALT+F4
(Windows).

N Apply: Adds your selected effects to
the image and closes the dialog box.
You can also Apply the effect by
pressing Return or Enter.

A Preview Window

B Glow Type: Edge, Solid

Edge applies the glow effect to the
area defined by the selection edges.

Solidignores enclosed selection areas
within the selection. Fills in the hollow
areas like the center of a selected “O.”

C Stroke Shape: Square, Round

D Stroke Width: Controls the number of
pixels from the image that the glow
extends. A higher number indicates a
fatter glow.

E Radiance: Indicates how abruptly the
outer edge of the glow diffuses. A high
number indicates higher diffusion.

F Opacity: Indicates the percentage of
the glow that is allowed to be seen in
the image.

G Blend Mode: Normal, Multiply, Screen,
Darken, Lighten, Difference. These
produce the same effect as when
applied directly in Photoshop, except
the effect is applied only on the target
layer (see page 57 for more details) .

H CreateGlow Only: Moves the glow in
front of the selection in the Preview
window. Keeps the glow and deletes
the image on selecting Apply (see
pages 49 and 57 for more details) .

I Color Palette Pop-up: Sets the glow
color. Color picked with the eyedrop-
per is displayed here.

B
C

I

A

D

E

J

F

G

H

LK M N

Note: Many controls, options, and
commands are common to all the
PhotoEffects plug-ins. For detailed
information on those elements,
refer to “The PhotoEffects Plug-
ins” starting on page 33.  

PhotoGlow

The PhotoGlow Dialog box

Tip

For a listing of keyboard shortcuts,
refer to Appendix A, page 174.
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PhotoBars brings the one-click convenience of toolbar buttons to
Photoshop, giving you instant access to hundreds of Photoshop
commands, tools, and menus. If a menu item or keyboard com-
mand is available inside of Photoshop, from either the Photoshop
application or a plug-in, it can be made available for instant
access on a PhotoBars toolbar.

With PhotoBars, you no longer need to constantly access buried
menus—simply drag buttons containing the commands you use
most often onto a toolbar, and have those commands available in
one click. And if you’re working on a Macintosh, simply enable
SmartBar: SmartBar watches as you select commands, then auto-
matically creates a toolbar for them.

PhotoBars includes several popular preconfigured toolbars to
show you just how convenient toolbars can be. The commands on
these toolbars are ones that most Photoshop users will find useful.
But since work patterns and preferences differ, PhotoBars gives
you the power to customize your toolbars: you can add, remove,
and rearrange buttons according to your preference. You can hide
and unhide your toolbars to reflect your work in different files
and projects, and you can have your toolbars “float” freely in the
Photoshop window, or “embed” them along any edge of the win-
dow—and instantly change from floating to embedded and back
again. 

If you find yourself repeating the same commands over and over
again, those commands probably belong on a toolbar. By spend-
ing just a few minutes learning how to work with PhotoBars, you
can save hundreds of steps and drudgery on every project!

PhotoBars

PhotoBars turns this

Into this
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Getting Started with PhotoBars

When Photoshop is first opened after PhotoTools has been
installed, the PhotoBars default toolbars will be displayed. The
default toolbars contain preselected buttons, and each button rep-
resents either a Photoshop or a PhotoTools command. 

You can start with the default toolbars to rearrange, add or
remove buttons, or to float, embed or hide the toolbars, or even
delete them. And don’t worry—even when you delete a toolbar
the commands and buttons used to create them are still available.
So you can recreate a toolbar, or a create a similar one, at any
time. 

If you’re not interested in using a particular toolbar, simply click
the “close” box to hide it. You can display it again at any time by
selecting “PhotoBars” from the Extensis menu, then selecting the
toolbar you wish to display.

To Determine Button Function:

Position the mouse pointer over the button.

The button’s function will
be displayed in the “Hot
Help” pop-up.

Note: You can turn off toolbars Hot Help at any time. Select
Extensis > PhotoBars > Edit Toolbars, then click the box
“ S h ow Hot Help” (Macintosh) or “ S h ow To o l Ti p s ” ( Wi n d ow s ) .
No checkmark indicates that Hot Help is turned off.

To Hide a Toolbar:

Click the Close button.
— or —
Select Extensis > PhotoBars > Edit toolbars. Select the

toolbar you wish to hide.
— or —
Select Extensis > PhotoBars, then select the toolbar you

wish to hide (visible toolbars are indicated with a check).

Typical Floating Toolbar

Close (hide) toolbar
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Floating Toolbar

To Show (Unhide) a Toolbar:

• Click the Edit Toolbars button on the PhotoTools
Commands toolbar, then click the toolbar you wish to
show (hidden toolbars have no checkmark).

— or —

• Select Extensis > PhotoBars > Edit toolbars. Select the
toolbar you wish to show.

— or —

• Select Extensis > PhotoBars, then select the toolbar you
wish to show.

Floating Toolbars and Embedded Toolbars

Any PhotoBars toolbar can be displayed as either a “floating
palette” toolbar or an “embedded” toolbar.

A floating palette toolbar is a group of buttons that can be moved
to any location on the screen. The advantage of floating palettes
is that they can be dragged anywhere in the screen that’s conve-
nient; they can be reshaped in any combination of rows and
columns; they can be given a name for easy recognition; and they
can be hidden until needed. An embedded toolbar is a row or col-
umn of buttons attached to one side of the window. Embedded
toolbars cannot be resized—but they can be instantly changed to
floating toolbars. The advantage of embedded toolbars is that
they’re at the outside edge of the work area: out of the way, yet
close enough to be accessed quickly.

PhotoBars makes it easy to change back and forth between the
two types, so you can have some toolbars one style and some the
other—and easily switch back and forth between them. 

To Change a Toolbar from Floating to Embedded:

• Click in the title bar or empty gray area on the toolbar
(not a button), then drag the toolbar to any edge of the
screen and release.

— or —

• Double-click  in the title bar or empty gray area on the
toolbar (not a button). 

The toolbar will automatically be embedded in the location
it was last embedded. If it has never been embedded, it will
embed to the nearest edge of the window. 

Embedded
Toolbar
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To Change a Toolbar from Embedded to Floating:

• Click in either the title bar or the empty gray area on
the toolbar (not a button), then drag the toolbar away
from the edge of the screen. Release the mouse where
you’d like to place the toolbar.

— or —

• Double-click  in the title bar or empty gray area on the
toolbar (not a button). 

The toolbar will immediately turn into a floating palette and
placed where it was last positioned as a floating toolbar. If it
was never a floating toolbar, it will be placed in the upper-
left corner of the window.

To Resize (Reshape) a Floating Toolbar:

• Drag the toolbar from the grow box in the bottom right
corner (Macintosh) or from the bottom corner
(Windows). Release when the toolbar is the desired
shape.

You can pull the toolbar in any direction to resize it, making
it fully vertical, fully horizontal, or anything in between.

Customizing Toolbars

You can remove buttons, add buttons, add space between buttons
to help group them logically, and move buttons from one toolbar
to another. You may want to create some toolbars for commands
that you use often, and other toolbars for commands that you use
only with certain projects. You can also rename, duplicate, or
remove your toolbars at any time. 

To Remove a Button from a Toolbar:

1. While pressing Command (Macintosh) or ALT
(Windows), click and drag the button off the toolbar.
Release the mouse when the button is no longer on the
toolbar.

The icon will disappear.

Note: This action deletes the button icon from the toolbar,
but not from PhotoBars. The button can be retrieved from
the button library at any time (Extensis > PhotoBars >
Customize Toolbars). For detailed instructions refer to “To
Add New Buttons to a Toolbar” on page 92.

Drag to reshape
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To Add Space Between Buttons:

1. While pressing Command (Macintosh) or ALT
(Windows), click and drag the button to the left or to
the right only slightly, then release.

Note: It takes just a small amount of movement to add
space between buttons. You may have to experiment a little
to get just the right touch for spacing button icons. 

To Rearrange Buttons On or Between Toolbars:

1. While pressing Command (Macintosh) or ALT
(Windows), click and drag the button to its new loca-
tion, then release the mouse.

You can drag a button to any location on a toolbar, or drag
it to another toolbar (both toolbars must be showing). 

Note: If you drag a button around and release it when it is
not positioned over a toolbar, the button will disappear.
Remember that this is how you remove a button from a
toolbar, and it can happen accidentally. To retrieve the but-
ton, select Extensis > PhotoBars > Customize Toolbars.
Locate the button and drag it back onto your toolbar. For
help see “To Add New Buttons to a Toolbar” on page 92.

To Create a New a Toolbar:

1. Click the Edit Toolbars button on the PhotoTools
Commands toolbar.

— or —

1. From the Extensis menu select PhotoBars > Edit
Toolbars.

2. Click “New.”

Tip

You can also create a new toolbar
from the Customize Toolbars dia-
log box—simply drag a button
from the Buttons window to the
Photoshop window.
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3. Enter a name for your toolbar.

4. Click “Done.”

A blank toolbar will be created and placed in the upper-left
portion of the Photoshop window. Drag your new toolbar
to a convenient location.

5. Add buttons to your new toolbar.

Either drag buttons from existing toolbars (the toolbar must
be visible for you to do this), or add buttons from the Cus-
tomize Toolbars dialog box (as described in the next section.)

To Add New Buttons to a Toolbar:

1. Click the Customize Toolbars button on the PhotoTools
Commands toolbar.

— or —

1. From the Extensis menu select PhotoBars > Customize
Toolbars.

The Customize Toolbars dialog box will appear, showing
all the Categories of available buttons. Each Category rep-
resents a menu in Photoshop. 

2. From the “Categories” window, locate the category of
commands that represents the command you are inter-
ested in.

All the buttons associated with commands in the selected
category will be displayed in the “Buttons” box on the
right hand side of the window.

Tip

Macintosh Users: You can auto-
mate the toolbar creation process
with SmartBar. SmartBar will
“watch” you work and automati -
cally record your commands as
you invoke them, then instantly
create a toolbar of those com-
mands. Refer to “Creating
Toolbars with SmartBar” for more
information.
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3 . From the “ B u t t o n s ” w i n d ow, select the button rep re s e n t-
ing the command that you want to add to your toolbar.

To determine which button represents which command,
pass the mouse over each button. A description of the but-
ton will appear in the “Description” Help box in the center
of the screen (Macintosh) or as a pop-up ToolTip
(Windows).

4 . D rag the button to your toolbar and re l e a s e.

5 . R ep e at steps 1 through 4 for all the commands you wa n t
to add to your toolbar.

If a button doesn’t “land” on the toolbar where you want it,
simply drag it into the correct position. You may want to
add all your buttons first, then experiment with positioning.

Tip

Macintosh Users: You can use
PhotoBar buttons to access files,
folders, and other applications. 

For example, you might want to
create a button that will show you
a pop-up list of all images in a par-

ticular folder on
your hard drive. 

To open the
image in Photo-
shop, simply
select it from
the list. 
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Creating New Buttons (Macintosh)

While there are hundreds of predefined buttons available in
PhotoBars (for Photoshop and PhotoTools commands), other
commands that you use frequently may not have a predefined
icon. These might include commands associated with add-on
f i lters, additional plug-ins, special keyboard functions, etc.
However, if the command is accessible in Photoshop, either by
menu or by key command, you can create a button for it and
access it from a PhotoBars toolbar.

To Create a Button for a New Command (Macintosh):

1. Click the Customize Toolbars
button on the PhotoTools
Commands toolbar.

— or —

1. From the Extensis menu, select Photo-
Bars > Customize Toolbars.

2. Click “New Button.”

3. Click “Select Icon.”

4. Select an icon for your button.

Scroll through the icons in the icon library and click an
icon to select it.

Note: You can add your own buttons to the icon library.
Refer to “Adding Your Own Button Icons” on page 100.

5. Click “Define.”

This closes the Define Icons dialog, and displays the
selected icon in the Edit Custom Button dialog.

Verify that your selected icon appears in the Edit Custom
Button dialog box. 

Icon selected

Tip

You won’t have to create new but-
tons often—every menu and sub-
menu item in Photoshop, including
Plug-ins and Filters, has a button
already created for it in
PhotoBars. You’ll only need to cre-
ate new buttons to add a button
for third-party Plug-ins, Filters,
etc., or to add a file or folder to
your toolbar(s).

For more information on adding
buttons to a toolbar, see “To Add
New Buttons to a Toolbar,” on
page 92.

Windows Users

Refer to page 101, “Creating New
Buttons (Windows).”
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6. Select “Keystroke,” “Menu,” or “Finder Item.”

If the command you wish to create a button for is invoked
with a keystroke, select “Keystroke.”

If the command appears on a Photoshop menu, select
“Menu.”

If you’re creating a button to access a file, folder, or appli-
cation, click “Finder Item.”

7. Depending on which option you chose, refer to the
appropriate section below.

To Create a Button for a Keyboard Command (Macintosh):

1. If you have not already done so, open the Customize
Toolbars dialog and select an icon as indicated in “To
Create a Button for a New Command” on page 94.

2. Select the “Keystroke” option. 

3. Click “Select…”

4. Type the keystrokes that invoke your command.

5. Click “OK.”

Verify that your selected keystrokes appear next to the
“Select...” button in the Edit Custom Button dialog box. 

6. Click “OK.”

Your new button will be displayed in the category “Custom
Buttons” in the Categories window of the Customize
Toolbars dialog box.
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7. Drag your new button onto a toolbar.

Note: Whether or not you drag your button onto a toolbar,
it will remain in the Custom Buttons category until you
delete it.

8. You can define more buttons, or click “Done” to return
to Photoshop.

To Create a Button for a Menu Command (Macintosh):

1. If you have not already done so, open the Customize
Toolbars dialog and select an icon as indicated in “To
Create a Button for a New Command” on page 94.

2. Select the “Menu” option. 

A pop-up menu appears to the right of the Menu radio but-
ton. This pop-up allows you to scroll through the menus
until you find the menu item command that you wish to
attach to your custom button.

3. Select the menu command you are creating a button for.

Verify that your selected menu command appears next to the
pop-up menu button in the Edit Custom Button dialog box. 

4. Click “OK.”

Your new button will be displayed in the category “Custom
Buttons” in the Categories window of the Customize To o l b a r s
dialog box.

5. Drag your new button onto a toolbar.

Note: Whether or not you drag your button onto a toolbar,
it will remain in the Custom Buttons category until you
delete it.

6. You can define more buttons, or click “Done” to return
to Photoshop.
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To Create a Button for a Finder Item (Macintosh only):

1. If you have not already done so, open the Customize
Toolbars dialog and select an icon as indicated in “To
Create a Button for a New Command” on page 94.

2. Select the “Finder Item” option. 

A dialog appears, asking if you want to attach a file or a
folder to the custom button. 

3. Select “File” or “Folder.”

If you attach a file to the button, the file will be opened
when you click the button. If you attach an application, the
application will be launched when you click the button.

If you attach a folder to the button, folder contents will be
displayed in a pop-up menu when you click the button.

4. Locate the file or folder.

5. If you are selecting a file, highlight the file then click
“Open.” If you are selecting a folder, highlight the fold-
er then click “Select.”

Verify that your selected file or folder appears next to the
“Select...” button in the Edit Custom Button dialog box. 
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6. Click “Done.”

Your new button will be displayed in the category “Custom
Buttons” in the Categories window of the Customize
Toolbars dialog box.

7. Drag your new button onto a toolbar.

8. You can define more buttons, or click “Done” to return
to Photoshop.

Using the SmartBar to Create Toolbars

(Macintosh Only)

SmartBar is a floating palette that automates the task of creating
buttons and toolbars. SmartBar records your menu selections and
commands, then allows you to save those recorded commands as
a toolbar.

When the SmartBar palette is open and enabled, each time you
invoke a menu item or other command it is recorded on the
palette. Up to 15 commands can be shown in the SmartBar palette
at one time. When you’re ready, you can click a button on the
palette and convert those commands into a toolbar. From then on,
instead of selecting commands from pulldown menus, you can
click the buttons to invoke your commands.

To Open the SmartBar Palette (Begin Recording):

1. Click the Show/Hide SmartBar button on the
PhotoTools Commands toolbar.

— or —

1. From the Extensis menu choose PhotoBars, then select
Show SmartBar.

Watch Me button
(Toggles SmartBar
on and off)

Build (tool) Bar

Reset Button List

Tip

Note: Whether or not you drag
your button onto a toolbar, it will
remain in the Custom Buttons cat-
egory until you delete it. To delete
an icon from the Buttons window
in the icon library, select (click) it
and press the Delete key.
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To Turn SmartBar On or Off (Start or Stop Recording):

1. Once the SmartBar palette is open, you will see the
Watch Me button (the button with the eye on it). Click
this button to turn SmartBar on and off.

When the eye is open, SmartBar watches you
while you work and creates a button for you when
you choose a Photoshop menu command. 

When the eye is closed, SmartBar is turned off. 

Once SmartBar has created a button for your command and
added it to the palette, you can use the button immediately
by simply clicking on it in the SmartBar list. 

SmartBar lists up to the last 15 commands you have used.
After this, when a new command is added the oldest is
deleted.

To Create a Toolbar from the Commands in the SmartBar:

1. Click the “Build Bar” (hammer) button to create a new
toolbar containing all the buttons listed in the SmartBar
palette.

If you only want some of the listed buttons to be in a new
palette, hold down the Command key and click on the
names (not the icons) of the buttons you want to include in
the new toolbar before you click the “Build Bar” button.

To Copy a Button from the SmartBar to Another Toolbar:

1. Hold down the Command key and drag the button icon
from the SmartBar list to the toolbar you want to place
it in.

To Clear the SmartBar Button List:

1. Click the “Reset List” button in the SmartBar palette.

2. Click OK.
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Adding Your Own Button Icons  (Macintosh)

You can create your own icons for toolbar buttons. You can use any
of the icons in the PhotoBars button library, you can use any
Macintosh paint program, including Photoshop, to design your own
icons, or you can copy a small image to the clipboard and paste it
into the icon library.

To Add a Button Icon to the Icon Library:

1. Create a custom button icon.

Icons that you create should be 19 pixels wide by 17 pixels
tall. Use Copy and Paste (see Note with step 5, below) to
place your icon on the Clipboard. Once a custom designed
icon is on the Clipboard, it can be pasted into the
PhotoBars icon library. PhotoBars will automatically add a
border to your icon, and will alert you if the pasted icon is
not the correct size.

2. Click the Customize
Toolbars button on the
PhotoTools Commands
toolbar.

Or select Extensis > PhotoBars > Customize Toolbars.

3. Click “New Button.”

4. Click “Select Icon.”

The Define Icons dialog box appears.

5. Click “Paste.”

Your new icon will be pasted into the icon library as the
last item on the list. 

Note: If you copy your image on to the Clipboard from
Photoshop, you must switch out of Photoshop, then back in,
before the Clipboard will allow you to paste the icon into
the icon library.

6. If you wish to define a button using your new icon, click
“Define.” If you wish to keep your new icon in the
library but do not wish to define a button at this time,
click “Cancel.” If you do not want to keep your new
icon, click “Delete” and then “Cancel.”

Tip

For best results, custom designed
icons should be 19 x 17 pixels
(width x height). 
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Creating New Buttons  (Windows)

While there are hundreds of predefined buttons available in
PhotoBars, other commands that you use frequently may not have
a predefined button. These might include commands associated
with add-on filters, additional plug-ins, special keyboard func-
tions, etc. If the command is accessible in Photoshop, either by
menu or by key command, you can create a button for it and
access it from a PhotoBars toolbar.

To Create a Custom Button:

1. Click the Customize Toolbars
button on the PhotoTools
Commands toolbar.

— or —

1. In the Edit Toolbars… dialog box click “Customize.”

— or —

1. Select Customize Toolbars… from the PhotoBars sub-
menu of the Extensis menu.

The Edit Custom Button dialog box appears.

2. Click the New Button button.

The Icon Button Editor dialog box appears. Custom but-
tons can represent Keystrokes, Photoshop menu items, or
Plug-in items.

3. Click the Keystroke, Menu, or Filter button.

Tip

You won’t have to create new but-
tons often—every menu and sub-
menu item in Photoshop, including
Plug-ins and Filters, has a button
already created for it in
PhotoBars. You’ll only need to cre-
ate new buttons to add a button
for third-party Plug-ins, Filters, etc.

For more information on adding
buttons to a toolbar, see “To Add
New Buttons to a Toolbar,” on
page 92.
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4. Provide PhotoBars with additional information about
the button.

Keystroke: If you selected Keystroke, click in the field
next to “Keystroke” and type in your command. You can-
not use ALT key combinations as these are reserved in
Photoshop.

Menu: If you selected Menu, enter the menu and menu
item numbers corresponding to the desired menu item. The
menu numbers in Windows start counting at 0 for the File
Menu, 1 for the Edit Menu, etc. A pull-down menu is -1.
For example: To select the Image Adjust menu item, you
would enter 2, 2, -1.

Filter: If you selected Filter, click in the Filter Name field
and type in the filter name exactly as it appears on the
menu.

A description of the button command appears in the
Description field. You can edit the button description by
changing the text in this field. 

5. Click OK.

The button is added to the Custom Buttons category. You
can add the Custom button to a toolbar, just as you would a
pre-defined button.

Adding Your Own Button Icons  (Windows)

You can create your own icons for toolbar buttons using any
Windows paint program. 

To Add a Button Icon to the Icon Library:

1. Design an icon in any Wi n d ows paint program. Th e
button must be 19 pixels wide by 17 pixels tall and be a
16-color image.

2. Copy your icon to the Clipboard.

3. Open Photoshop and the Customize Toolbars... dialog.

4. Click New.

5. Define settings for the new button.

6. Click the Button icon on the right side of the dialog
box.

The icon is added to those shown in the dialog box. An
alert box appears if the pasted icon is not the correct size.
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Extensis PhotoAnimator is a stand-alone application that helps
you create stunning and exciting animations with almost no eff o r t .
You start with raw animation elements saved either in native
Photoshop format (.psd), or as GIF images (.gif), then use
PhotoAnimator’s intuitive tools to add special effects to create the
animation, or import existing animations and use PhotoAnimator
to enhance them. And because PhotoAnimator is a stand-alone
application, you don’t need to have Photoshop open to use it.

PhotoAnimator System and Software

Requirements

To install and use PhotoAnimator, you will need the following:

M a c i n t o s h :
•   Power Macintosh® or equivalent
•   Mac OS® System 7.5 or higher 
• 8MB free hard disk space for PhotoAnimator, the

PhotoAnimator User Guide PDF, and Tutorial Sample Files

Wi n d ow s :
•   PC with Pentium processor or faster 
•   Microsoft® Windows 95® or Windows NT® 4.0
• 8MB free hard disk space for PhotoAnimator, the

PhotoAnimator User Guide PDF, and Tutorial Sample Files

PhotoAnimator Tutorial Sample Files

By default, the installer will place the PhotoAnimator Tutorial
Sample Files in the following locations:

M a c i n t o s h :
• Application—Hard disk: PhotoTools: PhotoAnimator™ 1 . 0
• Tutorial Sample Files—Hard disk: PhotoTools:

PhotoAnimator™ 1.0: Tutorials
Wi n d ow s :

• Application—C:\Program Files\Extensis\
\PhotoTools\PhotoAnimator™ 1.0

• Tutorial Sample Files—C:\Program Files\Extensis\
\PhotoTools\PhotoAnimator™ 1.0\Tutorials

PhotoAnimator
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Getting Started with PhotoAnimator

1) Open PhotoAnimator and specify a display size for the 
animation. Since PhotoAnimator is a stand-alone application,
you can open it like you would any other application.
PhotoAnimator can also be launched from within Photoshop
by choosing it from the Extensis menu in the Photoshop
menubar (Extensis > PhotoAnimator). 

Note: If you wish to import images from Photoshop into
PhotoAnimator, you must close them in Photoshop before
PhotoAnimator will be able to open them.

2 ) Import raw animation element files (.psd, .gif).
3 ) Apply special effects and play back your animations as you

design them. Loop your sequences or play them frame by
frame—you  can even use multiple windows to compare and
contrast effects—until you achieve just the effect you want.

4 ) When the design is complete, export out as a GIF A n i m a t i o n .

Unlike frame-by-frame animation programs, PhotoAnimator
allows you to use layers and to apply effects to resizeable cells.
You can animate each layer independently, and combine them
however you like. With PhotoAnimator you have the freedom to
edit your animations to your heart’s content, previewing as you
create them, rather than being limited to viewing the results after
all the frames have been created. 

Each animation layer can have multiple cells, and each cell can
have its own effect applied to it. PhotoAnimator automatically
generates the specified effect over a range of cell frames. You can
easily expand or contract the number of frames in a cell, and
PhotoAnimator will automatically recalculate the effect for the
entire cell. 

By combining PhotoAnimator’s special Image, Mask, Tr a n s i t i o n
and Filter effects like scale, rotate, spin, fade, wipe, barn door,
gradient mask, and invert, the possibilities for striking and 
professional-looking animations are virtually endless.

Instant Animation!

Apply Unlimited Special Effects

Import Raw Elements

Open the PhotoAnimator Application
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The PhotoAnimator window is the primary window, containing
three separate panes: the Layers Pane, the Preview Pane, and the
Filmstrip Pane.

Layers Pane: Displays all the layers available for the animation.
Each layer can contain from one to 300 animation frames. This
pane functions similar to the Photoshop Layers palette, allowing
you to create, name, hide, delete, and reposition layers.

Preview Pane: Displays a preview of the animation. This pre-
view is always available and can be viewed from any dialog box
as you work with animation effects.

Filmstrip Pane: Displays the cells and frames that make up the
animation. Layers in this pane correspond to the layers in the
Layers pane. This pane also provides access to tools and options
for working with the cells, frames, and images.

A PhotoAnimator Title Bar: Displays the
file name of the animation.

B Preview Pane: Displays a preview of
the animation which is always avail -
able and can be viewed from any dia-
log box as you work with animation
effects. This pane also provides
access to tools and options for work-
ing with the preview. See page 106
for more information.

C Image Preview: Displays the anima-
tion and all visible layers.

D Layers Pane: Lists animation layers.
Functions like the Photoshop Layers
palette, allowing you to create, name,
hide, delete, and reposition layers.
See page 106 for more information.

E Grow Bar: Click and drag up or down
from the center to enlarge or reduce
the Filmstrip pane, allowing you to
show or hide layers.

F Filmstrip Pane: Displays the cells and
frames that make up the animation.
Layers in this pane correspond to the
layers in the Layers pane. This pane
also provides access to tools and
options for working with the cells,
frames, and images. See page 107
for more information.

G Flicker Help Box: Displays a descrip-
tion of each tool or button function as
the mouse passes over it.

C

E

F

D

G

PhotoAnimator window

A

B

Tip

For a quick introduction to the
tools, windows, and basic opera-
tions in PhotoAnimator, we  sug-
gest you complete the first  Pho-
toAnimator tutorial “Getting Start-
ed—Basic Animations” starting on
page 120 of this User Guide.

For an introduction to some of the
stunning special effects available
in PhotoAnimator, turn to Tu t o r i a l s
2 through 5 starting on page 130.  
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A Layer Name: Displays the layer by
name. Highlighted name indicates the
currently active layer in the Filmstrip
w i n d o w. Drag the name up or down
the list to reposition the layers.

B Show/Hide Layer: Determines whether
a layer is visible in the animation
image in the Preview pane. Eye icon
indicates showing, no Eye icon indi-
cates hidden. Only layers with an Eye
icon present will be included in the
animation when it is exported.

C New Layer: Click to create a new
(empty) layer.

D Delete Layer: Click to delete the
selected layer.

E Layer Options: Change layer name;
make visible or invisible.

B

PhotoAnimator window—Layers Pane

A

C D E

A Preview: Displays the full animation
sequence when the Player is on.
Displays the contents of the currently
selected frame when the Player is off.
Display is affected by the settings of
the layer Show/Hide buttons.

B Start/Stop: Press to start and stop the
animation. You can also press the
Spacebar to start and stop the
animation.

C Animation Player: Drag the slider to
interactively move through the full ani -
mation (affected by Layer settings).

D One-step buttons: Click back and
forth through the animation one frame
at a time.

E Loop: Places the Player in continu -
ous-play mode when depressed.

F Zoom: Click “+” to Zoom In (enlarge
the Preview), click “-” to Zoom Out
(reduce it). 

G Display Composite: Displays the com-
posite preview of all visible layers of
the current frame.

H Display Frame: Displays contents of
the currently selected frame only.

I Display Transition: Displays currently
selected frame transition.

G
H
I

PhotoAnimator window—Preview Pane

A

B C D E F
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A New Cell: Click to create a new
(empty) cell in the selected layer.

B Import Image: Click to create a new
cell in the selected layer and import
an image directly into it. Automatically
displays the appropriate Import
Options dialog.

C Clipboard Icon: Cut an animation cell
by dragging it to the clipboard icon.
Paste the cell by dragging the clip-
board icon to the desired location. To
copy the cell, Option+drag (Mac-
intosh) or Alt+drag (Windows).

You can also cut or copy to the clip-
board using the standard cut, copy,
and paste commands. Pasting the cell
places it at the end of any existing
cells in the layer.

D Open Effect Settings: Click to open
the Effect Settings dialog for the cur-
rently selected cell. You can also dou-
ble-click the cell to access the
Settings dialog once an effect has
been applied.

E Trash Icon: Delete (remove) the
selected cell.

F Frame: 300 maximum frames per
layer. Black border indicates currently
selected frame. 

G Animation Cell: Consists of one or
more frames. Filmstrip outer border
indicates currently selected layer.
Red inner border indicates currently
selected cell.

H Empty Cell: Shows a one-frame wide
empty cell.

I Cell End Marker: Drag to increase or
decrease number of frames in a cell.

J Frame place-holder: Empty position;
contains no frame or cell.

K Redraw progress bar: When com-
plete, indicate entire animation is
loaded into memory.

L Flicker Help Box: Displays a
description of each tool or function as
the mouse passes over it.

M Leave/Enter: Enter or exit the Nested
Sub-Animation work area.

N Animation Layers: These correspond
to the layers listed in the Layers Pane
(see page 8).

N

PhotoAnimator window—Filmstrip Pane

K L

G I JH

M

F
A

B

C

D

E
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Frame: A single image; the smallest unit in PhotoAnimator.
Frames contain raw images. Maximum 300 frames per Layer.
Multiple frames make up a cell.

Cell: Consists of one or more frames. All the frames in a cell con-
tain the same image. Animation effects are applied to cells. The
effect may change the image gradually between the first frame of
the cell and the last frame of the cell, to create the pieces of the
total animation, such as transitions from visible to invisible, hori-
zontal or vertical movement over time, spins, etc.

Layer: Consists of one or more cells. Layers are combined to
create the full animation. A background layer, for example, might
consist of a single cell with multiple frames with no effects
applied to the image. A background layer would typically be the
bottom layer. An animation  layer, such as a filmstrip showing a
stunt plane in action, would typically be the top-most layer. The
animation layer might contain a number of different cells with a
different effect applied to each cell. When the cells are played in
succession they would simulate the movement of the plane: scal-
ing to show to perspective (movement far to near), rotation to
simulate spinning, etc. An example of this effect is shown in
Tutorial 1, which starts on page 120.

Effects: Effects allow you to create the illusion of movement.
Effects are applied to cells. Because they simulate movement,
effects are typically  applied to cells containing more than one
frame,  and may affect the individual frames within the cell differ-
ently. Effects are accessed from the Effect menu in the menu bar.

Animation Player: The animation Player, located on the Preview
Pane, controls the image in the Preview window. The Player
allows you to play back the animation in a continuous loop or
frame by frame. Another Player, available from the dialog box of
each of the Effect Settings, allows you to step through the anima-
tion sequence of a single cell. By hiding and showing layers and
then stepping one by one through the frames of a single cell, you
can see how your Effect Settings on that cell will affect the over-
all animation. 

Tip

Once an effect has been applied
to a frame, simply double-click
the frame to open the appropriate
e ffect settings dialog box. Or
select any frame in a cell and
press C o m m a n d - T [Ctrl+T].
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Animation Functions and Settings

Frames: Two Animation settings—Frame Size and Frame
Rate—allow you to specify how large the display window for
your animation will be, and to how quickly or slowly the frames
will play. The Frame Size dialog can also be opened by pressing
Command-F [Ctrl+F]. Access the Frame Rate dialog with
Command-G [Ctrl+G].

Layers: From the Animation menu you can create, delete, and
rename layers, and specify whether the selected layer is visible
or invisible. A filmstrip border indicates the currently selected
layer. Layer options can also be invoked using the buttons on the
left side of the Layers Pane (see page 106).

Cells: From the Animation menu you can create and delete cells,
and specify cell size. A red outline indicates the active cell. Cell
options can also be invoked using buttons and sliders on the
Filmstrip Pane (see page 107).

A Frame Size Settings

B Width and Height: Enter custom
frame size, in pixels.

C Common Sizes Buttons: Select from
eight commonly used sizes. Clicking a
size button enters the selected size
into the Width and Height fields.

D Cancel: Close the settings dialog
without making any changes .

E OK: Close the settings dialog and
apply the changes.

F Frame Rate Settings

G Total Frames: Displays the total num -
ber of frames in the animation. 

H Frame Rate (Frames/Second): Enter
the desired frequency in frames per
second.

I Duration (in Seconds): Displays the
duration of the animation based on
the number of frames and the speci-
fied Frame Rate.

C

G
H

I

B

Frame Size and Frame Rate Settings

A

F

D E

D E

Tip

To create a new Layer, press
C o m m a n d - L [Ctrl+L].

To create a new Cell, press
C o m m a n d - K [Ctrl+K].
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Effect Settings

PhotoAnimator provides five categories of effects (Basic, Image,
Mask, Transform, and Filter) that allow you to scale, rotate, spin,
apply gradient masks, invert, and more. By combining these
effects on different images over various size cells, the possibilities
for unique and eye-catching animations are unlimited. 

All of the Effect Settings dialogs allow you to temporarily apply
the effect and preview the result on your animation without ever
leaving the settings dialog. This gives you tremendous freedom to
try out different effect settings and test your results without end-
lessly going back and forth between the settings dialog and the
Preview Pane. 

To create an Effect:

1. Select a frame and open the effect you are interested in
by accessing it from the Effect menu. 

Effect options are described on pages 110 through 116.

2. When you have the effect you want, click “OK” to
apply the effect and close the dialog.

To Prev i ew the Effect without closing the Effect Settings dialog :

1. Move your windows around until you can see both the
Preview pane of the PhotoAnimator window and the
Settings dialog. 

2. In the Settings dialog, click “Apply” to temporarily
apply the effect. 

3. Move the slider on the player in the Settings dialog box
the see the effect on the selected cell in the Preview Pane.

4. If you don’t like the effect, click “Revert,” or change
the settings, or click “Cancel” to close the dialog with-
out making any changes to the cell.

Repeat Last Settings
Once you have set an effect for a frame, that same effect can easi-
ly be applied to other frames. To repeat an effect, either drag the
cell border to the right, which instantly replicates the frame
(thereby replicating the effect), or select or create a new frame,
then select the first item on the Effect menu. The default setting
for newly created cells is “Image Repeat Settings.”

Tip

You can access the last-used
e ffect by pressing C o m m a n d - T
[Ctrl+T].
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The ability to preview your cell effects
on the animation without closing the
dialog (controls G through K) is common
to all the Effects. Other controls shown
here may not be found in all Effect
dialogs.

A Import: Click to import an image into
the selected cell.

B Export: Click to export the selected
cell.

C Orientation Preview: Displays the
current orientation of cell contents.
Changes made to the Orientation
controls affect this Preview. Note:This
is not an animation preview window.

D Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

E Scale Settings:Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size.

F Location: Displays a proxy of the loca-
tion (relative position) of the content in
the first frame of the cell. Drag the
proxy to specify a new starting loca-
tion, or enter coordinate values. See
page 14.

Move To Location: Click to allow frame
contents to be repositioned as the cell
progresses from first frame to last.
Drag to specify the frame ending
location, or enter coordinate values.
See page 14.

G Player: Move the slider to see the
current Effect Settings on the selected
cell. Click the right and left arrows to
move forward and backward through
the cell one frame at a time.

H Revert: Revert settings to the last-
saved state (undo Apply).

I Apply: Click to Apply the settings in
order to preview the effect. 

J Cancel: Click to close the dialog box
without making any changes to the
frame.

K OK: Click to Apply the effect and
close the dialog box.

L Animation Preview: This is the
Animation Preview pane of the
PhotoAnimator window. Look here to
view the animation as you operate the
Player in an Effect Settings dialog.

Common Effect Settings

G

F

E

H I J K

B C DA

L
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The Location Settings allow you to use a
proxy to indicate the relative position of
frame contents in the first frame of the
cell, and if “Move To” is enabled, the last
frame of the cell. PhotoAnimator automat-
ically adjusts frame content movement
between the other frames in the cell.

A Location Settings: Indicates frame
content starting and ending location in
the cell.

B Location: Displays a proxy of the rela-
tive position of frame contents in the
first frame of the cell. If no “Move To ”
location is specified, Location proxy
indicates position of frame content in
all frames of the cell. Drag proxy to
adjust frame content starting location. 

C “Move To” Enable: Click to access
Move To location controls.

D Move To: Displays a proxy of the rela -
tive position of the content in the last
frame of the cell. Drag proxy to indi-
cate frame content ending location .

E Frame Grid: Representation of frame
area as a square grid.

F Proxy: Red box sets the position point
of frame content relative to the frame.
White box represents actual frame
content location in (or even outside
of) the frame. (See K through O for
additional information.)

G X and Y Offsets: Indicates frame con-
tent offset from from proxy (red box),
in pixels. (See also O).

H Preview Controls: Allows you to pre-
view effects without leaving the dia -
log. (See page 8.)

I Cancel: Click to close the dialog box
without making changes.

J OK: Click to Apply the effect and
close the dialog box.

K Proxy: Indicates upper-left corner of
image is positioned in upper-left cor -
ner of frame.

L Proxy: Indicates lower-right corner of
image is positioned out of the frame
in the upper-left corner.

M Proxy: Indicates upper-left corner of
image is positioned in center of frame.

N Proxy: Indicates center of image is
centered in frame.

O Proxy Offset: Indicates center of
i m a g e is centered in frame, then off s e t
30 pixels right and 30 pixels down.

Location Settings and Frame Content Proxies
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Basic Effects

Basic effect options include None (applies no effect), Solid Color,
Repeat Last, Repeat Next, and Nested Sub-animation.

Note: For examples of Effects, refer to Tutorials 1 through 5
starting on page 120.

The Solid Color effect allows you to
color in your frames with a solid color.
When selected, the Solid Color effect
replaces any image already in the frame
with the selected color.

A Color Mode Pop-up: Select RGB,
CMY, HSV, Grayscale, or Web.

B Color Preview: Displays a preview of
the selected color.

C Picker: Access the system color picker.

D Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 13.)

E Color Settings: Move the sliders until
the desired color appears in the Color
Preview, or enter values directly.

F Cancel: Click to close the dialog box
without making any changes to the
frame.

G OK:Click to Apply the effect and
close the dialog box.

Nested Sub-Animations

H Frame Action Pop-up: Select from
Left Align, Right Align, Center Align,
Left Repeat, Right Repeat, Center
Repeat, Scale, Loop Modulate.

I Frame Size: Opens the Frame Size
dialog (see page 11) to allow you to
select or set frame size.

J Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

Basic Effects—Color and Nested Sub-Animation 
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Image Effects

Image Effects (Scale, Rotate, Spin) allow you to progressively
change the size and/or orientation of objects between the first and
last frame in the cell.

Note: For examples of Effects, refer to Tutorials 1 through 5
starting on page 120.

Image Effects (Scale, Spin, Rotate)
allow you to change the size and orien-
tation of objects progressively between
the first and last frame in the cell.

A Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

B Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

C Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

D Scale Settings: Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size.

E Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

F Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 8.)

G Cancel: Click to close the dialog box
without making any changes to the
frame. 

H OK:Click to Apply the effect and
close the dialog box.

I Spin Settings: Specify how many rev-
olutions the image will spin by enter-
ing a value in “End.” Spin the image
horizontally, vertically, or both. Image
will appear to begin spinning in “mid-
stream” by entering a value in “Start.”

J Rotate Settings:Specify “From” Angle
and “To” Angle (in degrees), and indi-
cate Clockwise or Counter-clockwise
rotation. 

Image Effects—Scale, Rotate, and Spin 
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Mask Effects

Mask Effects (Rotate and Scale) allow you to use the contents of
a frame as a mask, and change the size and orientation of the
mask gradually between the first and last frame in the cell.

Transition Effects

Image Effects (Fade, Wipe, Barn Door, Gradient Mask) allow
you to create gradual transitions between the first and last frame
in the cell.

Mask Effects (Rotate and Scale) allow
you to specify frame contents as a
mask, and to change the size and orien-
tation of the mask gradually between the
first and last frame in the cell.

A Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

B Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

C Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

D Default Fill Pop-up: Select Black or
White as the Mask fill color.

E Accumulation Pop-up: Select
Intersection or Union.

F Rotate: Specify “From” Angle and
“To” Angle (in degrees), and indicate
Clockwise or Counter-clockwise
rotation. 

G Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

H Preview Controls: Allows you to pre-
view effects without leaving the dia -
log. (See page 8.)

I Cancel: Click to close the dialog box
without making any changes to the
frame. 

J OK:Click to Apply the effect and
close the dialog box.

K Scale Settings:Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size. 

Mask Effects—Rotate and Scale
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Transition Effects (Fade,Wipe, Barn D o o r,
Gradient Mask) allow you to create tran-
sitions between the first and last frame
in the cell.

Fade, Barn Door, Wipe

A Accumulation Pop-up: Select
Intersection or Union.

B Transition From and To: Specify
transition as a percentage of original
(0 to 100%).

C Transition Settings: Specify orientation,
direction, and start-to-end preferences.

Gradient Mask

D Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

E Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

F Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

G Direction Pop-up: Select Black to
White or White to Black transition.

Mode Pop-up: Select None to All or A l l
to None.

Edge: Changes intensity of mask.

H Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 8.)

I Cancel: Click to close the dialog box
without making any changes to the
frame. 

J OK: Click to Apply the effect and
close the dialog box.

Transition Effects—Fade, Wipe, Barn Door, Gradient Mask
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Importing and Import Options

Within PhotoAnimator you can apply limitless special effects to
images, but first you must bring those images into the Photo-
Animator program. You do this using the Import command.  

You can import any graphic file saved in either Photoshop native
format (.psd) or in GIF format (.gif). Imported files can be multi-
frame or multi-layer files as well as single frame or single image
files. 

Photoshop File Format (.psd)

A Layer Mapping Options: Select from
Horizontal Inline (Frames), Horizontal
Grouped (Frames), Vertical Grouped
(Layers).

B Layer Import Direction: Select from
Top to Bottom or Bottom to To p .

C Import Items: Options are Layer
Images, Layer Masks, Composite
Image, and Alpha Channels.

D Cancel: Cancel the Import operation .

E Import: Import the image file using
the current selections.

GIF File Format (.gif)

F Frame Import Method: Select
Composite Inline (single layer),
Composite Grouped (single layer),
or Disassembled (multi-layer)

G Include Background Color Layer 

H Adjust for Frame Delays: Imports
additional frames to account for frame
delay of imported GIF. For example, if
you import a GIF that happens to
have a frame rate of 6 Frames per
Second, and a particular frame of the
G I F was set to delay for 1 second,
PhotoAnimator will generate 6 cells to
adjust for this delay.

A

B
F

G
H

C

Import Options dialog

D E

Photoshop

GIF

Tip

You can also Import images by
pressing C o m m a n d - I [Ctrl+I].
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Exporting and Export Options

PhotoAnimator animations can be exported as GIF A n i m a t i o n s
(.gif), as Photoshop layers (.psd), or as PhotoAnimator
templates. ( For more info rm ation on Export i n g, see Tu t o rial 5
s t a rting on page 157.)

Note: Animations can also be saved in the normal way (using the
Save and Save As. . . commands) as PhotoAnimator files (.paf).

Export Options allow you to save anima-
tions in one of three ways: Animated
GIF, Photoshop native format, and
PhotoAnimator format.

A Format: Export options dialog for the
Animated GIF format.

B Animation Preview: Allows you to
preview how the animation will look in
with the specified export options
applied.

C Web Options: Dithering, Color Set,
Maximum Colors, Interframe
Transparency Option.

D Loop Options: Loop Forever, Play
(specify number of times).

E File Statistics: File Size and
Download Time are calculated based
on the option settings when
Calculate/Preview is initiated.

F Calculate/Preview: Click here to apply
the indicated settings to the Preview.

G Cancel: Close the dialog without
applying changes.

H Export: Exports the animation in the
format indicated at the top of the dia-
log box, according to the indicated
settings.

I Player: Allows you to preview the ani-
mation as it will appear when export-
ed with the indicated settings.

J Preview Zoom: Click “+” to zoom in,
click “-” to zoom out.

K Photoshop Format: Exports the
animation in native Photoshop format.

L PhotoAnimator Format: Exports the
animation in native PhotoAnimator
format. Allows you to create an
animation template.

Export Options dialogs

C

D

E

F

G H I J

BA

K L

Tip

You can Export your animations
by pressing C o m m a n d - E
[ C t r l + E ].

Photoshop PhotoAnimator

Animated GIF
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Preferences

Preferences affect some operations of the PhotoAnimator
program. 

Application Start-Up: Use this preference to specify whether,
when launched, PhotoAnimator queries you for a frame size to
begin a new animation; presents the system’s “Open File” dialog
so you can open an existing animation; or simply opens without a
document.

Undo/Redo: Undo operations require additional memory, so you
would want to keep this number low if you have limited system
memory. (Maximum 100 levels of Undo.)

Transparency Background: Select this option to change the
color, brightness, and checker-pattern size of the transparency
background in the animation Preview window.

A Application Startup: Controls the
PhotoAnimator startup process. 

Do Nothing: Open PhotoAnimator
without a document.

New Document Dialog: When starting
PhotoAnimator, present the
PhotoAnimator “Frame Size” dialog.
(This is the default.)

Open Document Dialog: When start -
ing PhotoAnimator, present the File
System “Open” Dialog.

B Undo/Redo: Specify maximum levels
of Undo/Redo. The larger the number,
the more system memory is required.

C Transparency Checkerboard: Allows
you to specify the size and color of
the Preview window background
checkerboard.

D Cancel: Close the Preferences dialog
without making any changes .

E OK:Close the Preferences dialog and
apply the changes.

Preferences dialog

A

B

C

D E



In this tutorial you will learn how to create a simple animation,
while being introduced to the tools and operations available in
PhotoAnimator. Once you’re familiar with the program, we
suggest you check out the rest of the tutorials starting on p age 130.
These tutorials will introduce you to some of the special effects
possible with PhotoAnimator, and hopefully get you started
immediately creating fun and eye-catching animations.

Airplane Animation

We’re going to be creating an animation of an airplane flying over
a cloudy sky. There are three components to this animation: an
airplane, the airplane’s shadow, and a cloudy sky.

First we’ll make the cloudy background texture scroll seamlessly,
then to complete our animation we’ll make the airplane and its
shadow bounce slightly up and down in relation to one another as
if the airplane were encountering some turbulence.

1. Open the file “airplane_start.paf” located in the Tutorial 1
folder by double-clicking its icon.  (See page 103 for
Tutorial folder location.)

— or —

Open the PhotoAnimator application, then click “Cancel”
to close the New Animation dialog. Select “Open” from the
File menu, and locate the “airplane_start.paf” file.

At startup, PhotoAnimator (by default) assumes that you want
to create a new document and displays the New Animation dia-
log box. This time we want to open an existing file, so click
the Cancel button and open the file from the menu instead.

2. Familiarize yourself with the PhotoAnimator window.

The PhotoAnimator window is divided into three panes. The
top left pane is the called the Layers Pane and functions very
similar to the Layers palette found in Adobe Photoshop. This
is where you can create, name, hide, delete and reposition
layers. The Layers Pane is described in detail on page 106.

The top right pane is called the Preview Pane. From this pane
you have access to what the animation looks like. The
Preview is available at all times in PhotoAnimator, even from
the dialog boxes where you apply animation effects. 
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Tip

There are five tutorials included in
this PhotoAnimator User Guide. To
get the most value from the tutori-
als, we suggest you do them in the
order presented. However, it isn’t
necessary—please use them in
whatever way helps you the most.

Having said that, we do encourage
you to complete the Airplane
Animation (Tutorial 1) first, as it
provides an introduction to the
basic tools and functions in the
application. Tutorials 2 through 5
assume that you have this basic
knowledge.

The tutorial sample files referenced
in the tutorials can be found in the
“Tutorials” folder inside the Photo-
Animator™ 1.0 folder on your hard
drive. (For exact file locations, see
page 103.)

Tip

You can specify what action Photo-
Animator will take at startup from
the Edit > Preferences dialog.
Options are: Do Nothing; display
New Document dialog; display
Open Document dialog.

Tutorial 1: Getting Started—Basic Animations



From the Preview Pane you can play and stop the animation
using the animation Player. Press the green arrow to start the
animation. When the animation starts the arrow will turn red;
press the red arrow to stop the animation. The Preview Pane is
described in detail on page 106.

The bottom pane of the PhotoAnimator window is the
Filmstrip Pane. This is where you will see your animation
cells and frames. Each row in the Filmstrip Pane is called a
Layer, and the Layers here correspond to the Layers in the
Layers Pane above. The Filmstrip Pane is described in detail
on page 107.

The horizontal divider between the top two panes (Layers and
Preview) and the bottom pane (Filmstrip) allows you to adjust
the size of the Filmstrip Pane so that you can see more film-
strip rows (layers) at a time. Simply drag the divider up or
down. You can also adjust the size of most PhotoAnimator
windows and dialog boxes using the grow button on the bot-
tom-right corner of the window.

A Flicker Help Box at the bottom of the PhotoAnimator
window displays a brief description of the buttons and
functions in the window as you pass the mouse over them.
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Tip

To quickly start or stop the anima-
tion, press the Spacebar.

Use the Right and Left Arrow
keys to move forward and back-
ward one frame at a time. 

Use the Up and Down Arrow keys
to move up and down one layer at
a time.

Tip

PhotoAnimator gives you multiple
levels of Undo, so don’t be afraid
to experiment—you can undo as
many times as necessary to get
back to a known condition.

Preview Pane

Layers Pane

Filmstrip Pane



3. Add an image to the animation by Importing it.

Since there will be three elements in the animation, we creat-
ed three layers—one layer to contain the animation effects for
each of the three images. We already imported images into the
“Airplane” and “Shadow” layers; now you will bring in the
image of the clouds and place it into the “Clouds” layer.

• Click the “Clouds” layer in the Layers Pane to select it,
then select “Import” from the File menu. 

• Locate the “clouds.psd” file in the “Tutorial 1” folder.

Note: PhotoAnimator works with only Photoshop native
files and GIF images. You can use Photoshop, CorelDraw,
or any number of image manipulation programs that can
save images in either native Photoshop (.psd) or GIF (.gif)
format.  

• On the Import Options dialog, leave the settings as they
are (an image of this dialog is shown in the sidebar) and
click “Import.”

A clouds texture will be placed in the “Clouds” Layer, and
will be displayed in the first frame of the first cell of the last
layer (bottom row) in the Filmstrip Pane.

Examine the Filmstrip and Layers Pane. Notice that when
you select a layer in the Layers Pane, the corresponding
layer in the Filmstrip Pane shows a cell highlighted by a
filmstrip icon and a red rectangle. The filmstrip image
shows you the selected layer; the red rectangle outlines the
currently selected cell; and a black outline around the frame
indicates the selected frame.
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Tip

You can also import an image into
an existing layer using the
Import button on the
Filmstrip Pane Toolbar.
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Also notice (in the Filmstrip Pane) that each of our three
layers now has one cell, and each cell has one frame in it.
Each frame contains one of the imported images. 

If you examine the layers in the Filmstrip Pane you’ll notice
that they are in the same order as the layer names in the
Layers Pane. By moving the layer names up and down the
layers list you can reorder the layers and dramatically alter
our effects.

D o n ’t be too concerned if all this doesn’t make a lot of sense
right now—the connection between layers, cells, and frames
will become more clear as you work on the animation.

4. Now let’s extend the clouds texture to make a longer
sequence for our animation. 

• On the Clouds layer in the Filmstrip Pane, position your
mouse on the right edge of the cell border. When the
cursor changes to a double arrow, drag this border out
just past the position numbered “10.”

When you  release the mouse you will see that PhotoAnima-
tor has expanded the clouds texture over ten frames auto-
matically.

Notice that now the red highlight rectangle includes all ten
frames of the clouds texture. PhotoAnimator treats this
group of 10 “frames” as one “cell.”  You can change the
number of frames in a cell at any time by dragging its bor-
der to a new position.

Note: You can increase or decrease the number of frames in
a cell at any time by dragging the cell’s right-hand border.
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Any Effect Settings applied to the cell will include the newly
created frames.

Click on a few of the frames one at a time and observe what
happens in the Preview Pane. If you click on any frame
other than the first frame, the airplane and the shadow will
disappear. Clicking on frames  2 through 10 in any layer
results in the same texture appearing in the Preview Pane. 

5. Make the clouds appear to move across the sky.

The most important part of creating an animation is applying
the special effects that make single-cell graphics look, well...
animated! In PhotoAnimator there are a number of different
types of effects you can apply to your images, and we’ll touch
on most of them over the course of these tutorials. 

In our first effect, we’ll show you how to simulate movement
by having the clouds appear to move across the sky.

• Isolate the cloud layer in the Preview so it will be easier
to see the new effect on it: In the Layers Pane, click the
eye icon for both the Airplane and Shadow layers so that

the eye disappears. 

This hides the Airplane and Shadow layers, effectively iso-
lating the Clouds layer.

• Open the Effect Settings for the clouds texture image: In
the Clouds layer of the Filmstrip pane, double-click on
any frame in the clouds texture cell. 

This opens the “Image Repeat Settings” dialog box. All
Image Settings are Effects (the other Effect categories are:
Basic, Mask, Transition, and Filter). 

By default, PhotoAnimator applies the Image Repeat Setting
to all newly created cells. Image Repeat tells PhotoAnimator
to do just that—repeat, or reproduce, the currently selected
image in each frame of the cell.

Tip

To examine or modify the Effect
Settings currently applied to a cell,
double-click any frame in the cell.
Or press Command+T (Macintosh)
or Control+T (Windows).

To change the type of effect
applied to the cell, select the new
effect from the Effect menu in the
menubar.
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Look carefully at the preview window in the Image Repeat
Settings dialog box. Notice that the clouds texture is wider
than the texture shown in the Preview on the PhotoAnimator
window.

In fact, it is twice as wide. The frame size of this animation
is 100 by 100 pixels, but the clouds texture we imported
from the clouds.psd file is 100 by 200 pixels. We created the
clouds.psd file as a “seamless” texture so that after we ani-
mate the texture, it will appear as if the airplane is flying
over an endless stretch of clouds.

• Set the start position for the clouds texture: Click on the
small white proxy in the upper left corner of the
“Location” field and drag it around the grid (both the
white and red boxes will move). Position these little
boxes over the left center grid point, so that the tiny red
box is centered inside the white box. 

The red box sets the proxy, or position point of the image.
The white box represents the location of the image. See
page 112 for a more complete description of this feature.
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• Enable the “Move To” option by clicking its box (verify
that there is now a checkmark in the box). 

The proxies under Move To should now be available. 

• Drag the Move To proxies over the right center grid
point, keeping the red box centered inside the white box.

• Move the Image Repeat Settings dialog box so that you
can see both the Preview Pane on the PhotoAnimator
window and the open Image Repeat Settings dialog.

• In the Image Repeat Settings dialog, click the “Apply”
button to temporarily apply the effect to the cell. 

• Now drag the slider on the Player in the Image Repeat
Settings dialog (its above the Revert and Apply buttons)
to the left and right. Watch the Preview.

The cloud texture in the Preview will move back and forth.
The movement hasn’t yet been permanently applied to the
cloudy texture cell: Clicking the Apply button lets you
Preview the effect on the overall animation without actually
leaving the dialog box. At this point, if you were unhappy
with the results of your effect, you could click the “Revert”
button to undo the effect and start over. For now, just leave
the effect the way it was.

• When you’ve finished playing with your new effect, veri-
fy that the starting and ending locations for the cell
frames are as shown above, then click “OK.”

This closes the dialog Effect Settings dialog box and applies
the effect to the cell.

Click the “Loop Playback” button in the Preview Pane.

This puts the Player into continuous play mode.
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Click the Play button (the little green arrow) or tap the
Spacebar to play the animation. 

If you watch carefully, you will see that the cloudy texture
loops seamlessly when the animation plays from the last
frame to the first. 

Click the Stop button (the red square ) or tap the space-
bar again to stop the animation.

6. Now include the airplane and its shadow in the animation.

Unhide the Airplane layer and the Shadow layer by
cl i cking the Show/Hide box so that the eye icon is visibl e.

• Select the Airplane layer by clicking on it either in the
Layers Pane or the Filmstrip Pane.

• In the Filmstrip Pane, extend the airplane cell to 10
frames. Repeat this process for shadow cell, expanding it
to ten frames as well. 

Preview the animation by pressing the Play button on
the Animation Player. The airplane now appears to be
flying over our cloudy sky.

Not bad so far, but with PhotoAnimator we can easily make
our animation more interesting. What you are going to do
next is make the airplane appear to bounce up and down as
it flies through the air. You will do this by adjusting the
scale of the airplane and its shadow over time. When you
are done, the airplane will appear to rise and fall. The
airplane’s shadow will appear to shrink as the airplane rises,
and appear to grow as the airplane falls, mimicking how
shadows act in the real world.

7. Add some additional effects to the airplane, making it
appear to encounter turbulence.

You’ll need to create another cell of airplane frames for the
next effect, and you’ll do that by copying and pasting the first
cell in the same layer as the original. 

• Copy the five-frame airplane cell: Click in any frame of
the cell to select it, then select Edit > Copy. Or use the
standard keyboard shortcut [Command+C (Macintosh)
or Control+C (Windows)].

• Without doing anything else, Paste the cell: Select Edit >
Paste, or use the standard keyboard shortcut
[Command+V (Macintosh) or Control+V (Windows)].

Tip

You can toggle the animation
Player on and off by pressing the
Spacebar.

Tip

You can drag-copy a cell to a new
location by holding down the
Option (Macintosh) or ALT
(Windows) key while dragging. 
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Notice that the new cell was pasted to the right of the cell
that was copied. PhotoAnimator assumes when you copy a
cell that you wish to expand the animation of the copied
image, and automatically places it in the proper sequence.

• Repeat this process to create a second cell of the airplane
Shadow image on the Shadow layer.

When you are finished, the Airplane and the Shadow layers
should each contain two five-frame cells.

• Select the first cell on the Airplane filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

This will open the Image Scale Settings dialog box. 

Notice that we didn’t instruct you to double-click the cell to
open the Effect Settings dialog; that’s because (as you may
recall) the current settings for the cell are “Image Repeat
Settings,” and you want to apply a different effect to the
cell.

• In the Image Scale Settings dialog for the fi rst cell, set the
H o ri zontal and Ve rtical values for the “ Fro m ( % ) ” to  90.

• Click “OK” to apply the settings and close the dialog.

• Now select the second cell on the Airplane filmstrip layer,
and again select Image > Scale. . . from the Effects menu. 

This opens the Image Scale Settings dialog for the second
airplane cell.

• Set the Horizontal and Vertical values for the “To(%)”
to 90, then click “OK.”
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Now play the animation. 

The airplane should appear to bob up and down, while the
shadow remains constant.

8. The next, and final thing you need to do is animate the air-
plane’s shadow.

• Select the first cell on the Shadow filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

This will open the Image Scale Settings dialog for the
shadow.

• In the Image Scale Settings dialog, drag the proxy to the
center of the centerpoint of the Location grid, being sure
to center the red box inside the white box.

• Also set the Horizontal and Vertical values for the
“To(%)” to  80.

• Click “OK” to apply the settings and close the dialog.

• Select the second cell on the Shadow filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

• In the Image Scale Settings dialog, again drag the proxy
to the center of the centerpoint of the grid, being sure to
center the red box inside the white box.

• This time, set the Horizontal and Vertical values for the
“From(%)” to  80. 

Play the animation. 

Now the shadow appears to shrink away from the airplane
as the airplane rises, and expands towards the airplane when
the airplane falls. 

That completes your first animation in PhotoAnimator.
Congratulations—and happy animating!
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In this exercise, you will learn about one of PhotoAnimator’s
distinctive features—its ability to animate masks in addition to
images. This tutorial will focus on the Mask options of
PhotoAnimator Effects. 

Mask Effects—The “Click Here Button” Animation

In this tutorial you will create a half-size banner ad. The banner
will display the text “What are you waiting for?” for a several
seconds. The text will be set on a yellow shape. You will then
make the text disappear and use a mask to cut away at the yellow
shape, revealing an orange button below the shape that has the
words “Click Here” on it. Finally you will make a blue-striped
radial graphic rotate around a few times to help accentuate the
“Click Here” button.

1. Open the PhotoAnimator application. When the “New
Animation” dialog appears, click Half Banner (234 x 60).

The factory default setting is to have the New Animation dia-
log box appear automatically when PhotoAnimator is
launched. If this dialog didn’t appear, select File > New. This
will give you access to the dialog.

Note: If the New Animation dialog appears and you wish it
didn’t, you can change this preference in Edit > Preferences.

PhotoAnimator provides a range of common animation sizes
for you to choose from. If a size you need is not listed, you
create a custom size simply by entering the dimensions in the
Height and Width fields.

Tip

There are five tutorials included in
this PhotoAnimator User Guide. To
get the most value from the tutori-
als, we suggest you do them in the
order presented. However, it isn’t
necessary—please use them in
whatever way helps you the most.

Having said that, we do encourage
you to complete the Airplane
Animation (Tutorial 1) first, as it
provides an introduction to the
basic tools and functions in the
application. Tutorials 2 through 5
assume that you have this basic
knowledge.

The tutorial sample files referenced
in the tutorials can be found in the
“Tutorials” folder inside the Photo-
Animator™ 1.0 folder on your hard
drive. (For exact file locations, see
page 103.)

Tutorial 2: Working with Masks
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2. Create two new layers.

Create a new layer by clicking on the New
button in the Layers pane. Name the layer

“Spin Mask”. 

Create another layer and name it “Light
Blue”.

3. Expand all three layers out to 30 frames.

• Select the “Background” layer in the Layers Pane. In the
Filmstrip pane, click the New Cell button. This
will create a new cell in the Background layer.

Drag the cell’s right edge to the right so that the cell con-
tains thirty (30) frames.

You can repeat what you just did to create a thirty frame cell
in each of the other two layers, but you’re learning, so let’s
do it a different way this time.

• Copy the cell by pressing and holding the Option
(Macintosh) or ALT (Windows) key, then drag and drop
the cell from the Background layer (in the Filmstrip
Pane) into the “Spin Mask” layer.

This places an empty cell 30 frames wide in the Spin Mask
layer.

• Repeat for the “Light Blue” layer.

At this point you should have three layers each containing a
thirty-frame cell. 

Tip

You can also create a new Layer
by pressing Command+L (Mac-
intosh) or Control+L (Windows).

Tip

You can also create a New Cell by
pressing Command+K (Macintosh)
or Control+K (Windows).
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4. Now you’ll add some color and import a mask to create a
nice rotating animation effect.

• Click on the Background layer to select it , then select
Effect > Basic > Solid Color. . . from the menubar. Change
the RGB values to Red: 0, Green: 0, and Blue: 153, then
click OK. 

• Repeat this process on the Light Blue layer using RGB
values of Red: 0, Green: 153, and Blue: 204.

This creates two layers filled with different shades of blue.

5. Now you’ll will mix the two blue layers together and use a
Mask to create a radial design between the colors.

• Click on any frame in the Spin Mask layer to select the
cell.

• Choose Effect > Mask > Repeat. . . from the menubar.

In the Mask Repeat Settings dialog, click the Open
File button and select the “Spinmask.psd” file

from the Tutorial 2 folder.

Tip

Don’t forget that PhotoAnimator
provides mutiple levels of
Undo.Simply press Command+Z
(Macintosh) or Control+Z
(Windows) as many times as nec-
essary to “wind back” your actions.  

You can Redo an Undo operation
with Command+Y (Macintosh) or
Control+Y (Windows).
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Note: You may have noticed that the “Spinmask.psd” file is
actually much larger than the 234 x 60 size of the
animation. This is so that the edge of the mask is never seen
in the frame boundaries as it rotates. PhotoAnimator allows
you to use masks that are smaller or larger than the
animation frame size.

• Click “OK” to save the mask into the cell and close the
dialog box.

The two colors should now appear to form a radial design.
However, if you press the Play button, nothing appears to
happen. It’s time to generate some motion!

6. Adjust Cell size to prepare for the mask animation.

• Reduce the Spin Mask layer cell size to 24 frames (re c a l l
t h at it is curre n t ly 30 frames) by dragging the ri g h t
b o rder of the cell just past the number 24.

This next step you could do by dragging as you did earlier,
but let’s try something new.

• D u p l i c ate the Spin Mask cell, then reduce the new cell
to 6 fra m e s : C l i ck in any frame of the Spin Mask cell,
then Cut and immediat e ly Pa s t e. Select A n i m ation >
R e s i ze Cell from the menu b a r. Enter “ 6 ” in the Number
of Frames box .

This duplicates the Spin Mask cell and places the new cell
to the right of the copied cell, and reduces the size of the
new cell from 24 to 6 frames.
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The Spin Mask layer should contain two cells. The first cell
should be 24 frames long, and the second 6 frames long.
Each cell should contain the same mask that we imported in
step 5.  

7. Create a short spinning effect for the Mask.

• In the Fi l m s t rip Pa n e, cl i ck any frame in the second cell
of the Spin Mask layer (the cell with 6 frames) to select it.

• Select Effects > Mask > Rotate. . . from the menubar.
Enter the following values:

From: 0°    To: 50°    Clockwise (CW)

• When you have finished entering the Mask Rotate effect
settings, click “OK” to apply the settings and close the
dialog.

Preview the animation by pressing the Play button in the
Preview Pane. Now the blue-striped radial design should
stay static for a few seconds and then rotate a few times.
It you turn on the Loop button in the Preview Pane you
will notice that the rotation loops seamlessly.

Up to this point you have been working on the background
for the animation. Now you are going to add in all of the
other elements.

Tip

When you copy and paste a cell in
PhotoAnimator, the pasted con-
tents are added to the right of the
currently selected cell. 
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8. Create five new layers to hold the rest of the animation ele-
ments.

• Select the Light Blue layer in the Layers Pane.

You select this layer because you want your new layers to
be positioned above this one, and PhotoAnimator inserts
new layers above the selected layer.

• Create five new layers and name them in exactly this
order: “Border,” “Click Here,” “Diamond Mask,”
“Shield,” and “What Are You Waiting For.” (“What Are
You Waiting For” should be the last and top layer.)

When you are finished you should have eight layers listed in
the Layers Pane, and each layer should have a unique name.

9. Import and examine a multi-layer file (“why_wait.psd”).

• Click on the Border layer in the Layers Pane and choose
Import from the File menu, or press Command+I
(Macintosh) or Control+I (Windows) . 

• In the Open dialog box, select the “why_wait.psd” file
from the Tutorial 2 folder.

• When you’ve located the “why_wait.psd” image, click
“OK.”

The Import Options dialog will be displayed.

• Verify that the options in the Photoshop Import Options
dialog are at their default settings: Horizontal Inline
(frames);  Top to Bottom; and all the Import Items boxes
unchecked.

• Click “Import.”
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There are four images in the “why_wait.psd” file. Notice
that after you imported the file, four cells were added to the
Border layer. Each cell corresponds to a separate layer in the
file you just imported. 

You must now move each of these images onto their own
layer.

10. Move each of the imported images from the Border layer
to the appropriate layer.

Since the new images in the cells are very small, click the
Checkerboard icon in the Preview Pane. This will isolate
the Preview to just the contents of the selected frame,
which will allow you to easily identify each element.

• To help you see the target Filmstrip layers where you’ll
be dragging the new cells, enlarge the window as much
as you can.
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• Click and drag the first cell (it should be the “What Are
You Waiting For?” image) into the “What Are You
Waiting For layer.” This will be the top layer in the
Filmstrip Pane.

• The next image should be the yellow shield. Click and
drag this image to the “Shield” layer. The Shield layer is
second from the top.

• Locate the “Click Here” button and drag it to the “Click
Here” layer.

• The remaining cell in the Border layer should display a
green border image. Leave this cell where it is.

Note that you still have one empty layer, the layer named
“Diamond Mask.” We will be tending to this omission short-
l y.

Since you have finished moving the cells around, you can
restore the composite (multi-layer) Preview in the
PhotoAnimator window by clicking the Show Composite

button at the top of the Preview Pane.

11. Resize the Border, Shield, and Click Here layers to be 30
frames wide.

• Click any frame in the Border layer cell, then select
Animation > Resize Cell. .. . When the dialog box opens,
enter 30 in the Number of Frames box.

• Repeat this step for the Click Here and Shield layers.

12. Resize the Diamond Mask and What Are You Waiting For
layers to be 15 frames wide.

• Select the Diamond Mask layer, then create a new cell in
it by clicking on the New Cell icon in the Filmstrip Pane.
Resize this cell so it has 15 frames in it.

• Resize the cell in the What are You Waiting For layer
to 15 frames as well.

Click the Play button in the Preview Pane. The message

Tip

You can automatically create a
new cell in an empty layer and size
the cell at the same time. Simply
drag the empty cell border to the
right until you’ve created as many
frames as you need. New frames
will be created as you go along.

Tip

You can toggle the animation
Player on and off by pressing the
Spacebar.

Tip

To quickly determine which layer
an image has been placed in, click
the image. This selects the layer,
causing the layer name in the
Layer Pane list to be highlighted.
Scroll the list, if necessary, to bring
the selected layer name into view.
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“What are you waiting for?” should display for 15
frames and then disappear.

Now you will use a Mask to make a diamond-shaped hole
appear on the yellow shield, which will reveal the “Click
Here” button for several frames.

13. Import the last image and apply its special effect.

• Select the cell in the “Diamond Mask” layer.

• C o py and Paste the cell to cre ate a duplicate cell to the
right of it. Resize this duplicated cell from 15 frames to 9
f rames (the second cell will end at the Frame 24 marke r ) .

• Verify that this second cell (Frames 16 through 24) is
selected (red border around it), then select Effect >
Mask > Scale. . . from the menubar.

Click the Open File button in the Mask Scale Settings dia-
log box and select “Diamondmask.psd” from the
Tutorial 2 folder, then click Import. 

You may want to scroll the Settings preview in order to see
the diamond mask. It isn’t necessary to see it, however—if
you imported it, it’s there! 

• Enter the following effect settings:

Default Fill: White
Accumulation: Intersection
Horizontal and Vertical “From(%)”: 0 (zero)
Horizontal and Vertical “To(%)”: 100 

• Click “OK” to Apply the effect and close the dialog.

Preview the animation. 
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A diamond-shaped hole should appear in the yellow shield
between Frames 16 and 24. However, after Frame 24, the
shield goes back to fully covering the “Click Here” button.
Let’s change that.

14.  Add another cell to fine-tune the animation.

• Copy and Paste the second cell on the Diamond Mask
layer.

This creates a third cell on the Diamond Mask layer.

• Resize the newly pasted cell so that it contains 6 frames
(this third cell will end at the Frame Number 30
marker). 

• Double-click anywhere in this cell to open the Mask
Scale Settings dialog box. 

• Change the Horizontal and Vertical “From(%)” val-
ues to 100, then click “OK.”

Verify that the “Loop” button is pressed so the animation
will play continuously.

Play the animation.

The final animation should display the text “What are you
waiting for?” for a few seconds. Then the text should disap-
pear and a diamond-shaped hole should get larger and larger
until the “Click Here” Button is fully visible. The “Click
Here” button should remain visible for six frames. Finally,
the radial blue strips should rotate a few times, then the ani-
mation should start over.

That completes the “Click Here Button” animation, but before
you wrap up your work with Masks, let’s look at some layered
masking effects.
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Layered Masks—The “Radiation” Animation

This example demonstrates that you can combine masks on differ-
ent layers to create interesting animation effects. In the next tutor-
ial (Tutorial 3) you will learn how to make and use Gradient
Masks—a unique and powerful PhotoAnimator effect tool that
gives you more creative capability than any animation program of
its type. 

1. Open the “Radiation” animation.

• Select File > Open. . . from the menubar.

• Locate the  “Radiate.paf” file located in the Tutorial 2
folder on the Extensis CD.

• Click “OK” to open the animation file.

Notice that you can store PhotoAnimator files in
PhotoAnimator’s own proprietary format (.paf). This allows
you to save animations without exporting them. You can
also import “.paf” files into PhotoAnimator—we’ll talk
about import and export options in our final tutorial
“Exporting Animated GIFs” starting on page 157.

2. Play the animation and observe the animation effect. 

The holes that form a classic radiation symbol gradually open
up to reveal an orange-colored backdrop. Then a wild transi-
tion occurs between orange and yellow (this effect was
achieved with a Gradient Mask transition which will be cov-
ered in the next tutorial). Finally, the radiation holes close
back up again.
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We created the opening and closing of the radiation holes by
layering two masks. The first mask, on the “Static Mask”
layer, is stationary. The second mask, on the “Rotating Mask”
layer, employs the same mask that was used on the Static
Mask layer. However, the mask on the Rotating Mask layer
rotates. When the second mask layer rotates relative to the
first, the holes of the radiation appear to open and close.

In the next tutorial (Tutorial 3), you will learn about
Transitions and see how to use a Gradient Mask—a unique
and powerful animation tool unique to PhotoAnimator.



142

In this exercise, you will learn about another one of
PhotoAnimator’s distinctive features—its ability to produce sim-
ple to complex transition effects. This tutorial will focus on the
Transition options of PhotoAnimator Effects. 

Barn Door and Dissolve—The “Web Button”Animation

PhotoAnimator makes it easy to apply transition effects to cells.
Basic transitions such as wipes, fades, and “barn door” transitions
are directly supported using the dedicated Effects commands. 

PhotoAnimator compliments these “bread and butter” transition
effects with a feature called “Gradient Mask.” The Gradient Mask
feature uses a mask saved as a Photoshop (.psd) or GIF (.gif) file
to create any number of unique transition effects. 

There are three exercises in this tutorial:

• In the first exercise, you will learn how to create basic transi-
tion effects such as a Barn Door transition. 

• In the second exercise, you will learn how to create a Gradient
Mask transition. 

• In the third exercise, you will look at a ready-made example
file to see just how dynamic and complex Gradient Mask tran-
sitions can be.

Barn Door and Dissolve Transitions

In this tutorial you will add animation to a simple Web button.
The button will grow into view using the Barn Door transition. A
glow that temporarily highlights the button will fade in and out of
view. And finally, when the button is fully visible, the word
“Extensis” will dissolve into view over the button. You will
accomplish all of this with transition effects.

1. Preview the “button_start.paf” animation.

• Open the “button_start.paf” file located in the Tutorial 3
folder.

Play the animation to get an idea of what it looks like
before you start changing the effects. 

A blue-green glow appears around a button. After a few sec-
onds the glow disappears and the word “Extensis” appears.

Note: The glow is actually blue, but appears blue-green
when viewed around a green button and against a yellow
background. Since the visible effect is blue-green, we’ll be
referring to it that way.

Tip

Don’t forget that PhotoAnimator
provides multiple levels of Undo.
Simply press Command-Z [Ctrl+Z]
as many times as necessary to
“wind back” your actions.  

You can Redo an undo operation
with Command-Y [Ctrl+Y].

Tutorial 3: Working with Transitions and Gradient Masks
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This PhotoAnimator File (.paf) contains seven layers. All of
the layers are set up with cells, images, and effects already in
place so that you can start right in working with transitions. 

There are three of the layers in the Layers Pane that contain
the word “Transition” (Glow Transition, Button Transition,
and Dissolve Transition). Each of these layers already con-
tain the blank cells that you will use to create the transition
e ffects. 

Transition cell placement: A transition cell will affect the
content cell directly above it. Notice in this sample file that
we have placed each transition layer directly below the con-
tent layer that the transition will be applied to.

2. Begin by creating a transition between the Glow and
Background layers.

• Select the Glow Transition layer in the Layers Pane, then
click any frame in the first cell of the Glow Transition
layer in the Filmstrip pane.

Note: You don’t need to select a layer in the Layers Pane in
order to select a cell in that layer in the Filmstrip Pane, but
doing so makes it easier to locate the right Filmstrip layer.

• Select Effect > Transition > Barn Door from the
menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Vertical

Direction: Outward
Mode: None to All

• When you have completed the settings, click “OK.”
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Preview the animation.

Notice that the blue-green glow appears to grow around the
button shape in a vertical progression over the first eight
frames of the animation. 

3. Now you’ll make the glow disappear out of view using a
slight variation of the Barn Door transition.

• Click on any frame in the second cell on the Glow
Transition layer.

• Select Effect > Transition > Barn Door from the
menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Horizontal

Direction: Inward
Mode: None to All

• When you finish with the settings, click “OK.”

Preview the animation again. 

First the blue-green glow transitions into full view under
the direction of the vertical Barn Door wipe, then disap-
pears. It next appears horizontally, transitioning into full
view under the direction of the horizontal Barn Door wipe,
then disappears. 

4. Next you’ll create a transition so that the button fades into
view after being hidden at the start of the animation.

• Select the Button Transition layer in the Layers Pane.

Since there is only one cell in this layer, the cell is automati-
cally selected when you select the layer.

• Once again select Effect > Transition > Barn Door from
the menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Horizontal

Direction: Outward
Mode: None to All

• When you have completed the settings, click “OK.”

Preview the animation once again

This time the button fades into view horizontally while the
blue glow appears around the button for several frames and
then disappears. 
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5. For our last Web Button animation effect you will use a
Gradient Mask transition.

• Select the Dissolve Transition layer in the Layers Pane.

• Click on any frame in the second cell of the Dissolve
Transition Filmstrip layer (the first cell will not have an
effect applied to it and will act as a place-holder).

• Select Effect > Transition > Gradient Mask. 

Click on the Open file button in the Gradient Mask
Settings dialog box and select “dissolve.psd” from the
Tutorial 3 folder.

This places a texture in the second cell of the Dissolve
Transition layer that you will use as a gradient mask.

• Select the following Gradient Mask Settings:

Accumulation: Intersection
Direction: Black to White

Mode: None to All
Edge Levels: 0

You can set the Edge levels value to 0 by either entering the
number zero in the levels field or by dragging the Edge slid-
er to the far left. If you are wondering what Levels does,
don’t worry we’ll talk about Levels soon. 

• Click “OK.”

Preview the animation.

With our new settings, after the Button and Glow
Transitions perform their respective effects, the Button stays
fully visible and the word “Extensis” dissolves into view,
the result of using the Gradient Mask. 

As you can see, the Gradient Mask effect is more sophisti-
cated than the simple Barn Door transition. This Dissolve
effect is just one of the infinite types of transitions that the

Tip

The Player always starts an anima-
tion with the currently selected
frame. You can of course start the
animation at the first frame by
dragging the Player slider all the
way to the left. Another way is to
press the Home key.

The Home key takes you to the
first frame in the selected layer.
The End key takes you to the end
of the animation in the current
layer (even if the frame is empty).
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Gradient Mask feature is capable of making. Let’s look at
how Gradient Mask transitions work.

Gradient Mask Transitions: Gradient Mask effects use an
image as a mask to create the effect. As mentioned, this
mask can be a GIF (.gif) or a Photoshop format (.psd) file.
The Photoshop file can be an RGB, Grayscale, Indexed, or
Duotone image, but you cannot use Photoshop files that are
in LAB or CMYK color mode. Mask files do not need to be
the same size as the animation.

PhotoAnimator’s Gradient Mask Transition effect uses the
brightness values of the pixels in the mask file to create its
effect. Although you can use RGB, Duotone, or Indexed
color files as masks, for optimal results it is best to stick
with Grayscale images because PhotoAnimator will actually
convert other color formats to Grayscale anyway.

• Double-click any frame in the second cell of the Dissolve
Transition layer.

Recall from Tutorial 1 that once a cell has had an Effect
applied to it, double-clicking any frame in the cell automati-
cally opens the Effect Settings dialog box for that effect. In
this case, the Gradient Mask Settings dialog will open, since
that was the Effect last applied to this cell.

• In the Gradient Mask Settings dialog box, drag the Edge
slider to the right until the Levels field reads 130. 

The Levels control in the Gradient Mask Settings dialog
controls the transition “fuzziness.” Transitions created with
the Gradient Mask feature can look very different depending
on the Levels setting. 
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• Click “Apply.”

(Recall that the Apply button only temporarily applies the
parameters in a given settings dialog box, allowing you to
Preview different settings before committing to them.) 

• Move the Gradient Mask Settings dialog so that you can
see the Preview Pane and the Gradient Mask Settings
dialog at the same time.

• Move the Player slider in the Settings dialog (its located
above the Revert and Apply buttons) back and forth and
observe the change in the animation Preview Pane.

If you look carefully, you’ll see that the dissolve effect has
been blurred by the new Levels setting of 130. 

If you move the Edge slider back to the far left (0) and pre-
view the animation again, you will see that the Edge Effect
is very pixelated—which is probably more appropriate for
this dissolve effect than the 130 Level you just looked at. 

So you can see that with the Gradient Mask Effect you can
create a wide range of transition effects with any given mask
file, creating an unlimited number of possibilities. In the next
exercise you will examine another file to see a few more of
the many creative opportunities available with this unique
e ff e c t .

Tip

PhotoAnimator allows you to have
multiple files open at the same
time. This can be quite handy for
comparing effects. 

For example, you might set differ -
ent effect values for the same cell
in each of two otherwise identical
PhotoAnimator (.paf) files. You’d
put each animation Player in Loop
mode, and Play back both anima-
tions. Then just sit back and watch
the two playing side-by-side!
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Complex Animations with Gradient Masks—The Aperture
Animation

In this exercise you will look at a file with lots of Gradient
Transitions to get an idea of the creative possibilities.

1. Examine the Aperture.paf animation.

• Open the “aperture.paf” file located in the Tutorial 3
folder.

Verify that the Loop button in the Preview Pane is
pressed so that the animation will play continuously.

Play  the animation. 

An aperture opens up to reveal a sort of radial explosion
effect, and then the aperture closes again. 

Notice that there are numerous invisible layers (layers with
their eye icon turned off) in the Layers Pane. This file was
created to show you a variety of Gradient Mask transitions.
You will hide and reveal different layers so that you can bet-
ter view these different transition effects. 

2. Hide the Aperture layer and examine the effect.

In the Layers Pane, hide the Aperture layer by clicking
on its eye icon (the eye should disappear indicating that
the layer is hidden).



149

All of the layers are actually Gradient Masks except the
Aperture, RED and YELLOW layers. The RED and YEL-
LOW layers are filled with solid colors (Effect > Image >
Solid Color). Using solid colors as the background for a
Gradient Mask is a often a great way to set off the effect.

Notice that only four layers are currently visible: the “YEL-
LOW,” “Diagonal 1,” “Concentric,” and “RED” layers.

Preview the animation again, and notice the combined
effects of the “Diagonal 1” and “Concentric” Gradient
Mask layers on the “YELLOW” and the “RED” layers.

Hide the “Concentric” layer and then Preview the
animation again. 

Now hide the “Diagonal 1” layer and  turn the
“Concentric” layer back on. 

Preview the animation again. 

As you can see, the effects of these Gradient Mask layers
are very different. Take a moment now and turn on and off
various Gradient Mask layers and observe the results by
previewing the animation. Try different combinations. After
a while you will begin to appreciate the incredible range of
possibilities with Gradient Mask transitions. 
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4. Now let’s look at a few of the mask files used to create
some of these Gradient Masks transitions.

First, unhide the “Twist 1” layer.

• Next, double-click on any frame in the second cell of the
Twist1 Filmstrip layer to open up the Gradient Mask
Settings dialog.

The Preview window in the Gradient Mask Settings dialog
shows the file used as the mask for this layer. This mask,
like most of the mask files in this example animation file,
was created in Photoshop using Filter Factory filters (most
of these filters are available for free on the Web). 

• Zoom in on the mask by clicking on the Plus (+) sign in
the Preview window of the Gradient Mask Settings
dialog.

• Roll your mouse cursor over this Preview window.
When the cursor changes to the hand icon, click and
drag to observe the detail of the mask. 

Notice that the mask has a broad range of gray values. In
general, the more gray values there are in a mask, the more
versatile the mask is. This is because the Gradient Mask
Transition effect uses the brightness values of each pixel to
create the transition effect over time. A mask with a large
variety of gray values in it gives the Gradient Mask
Transition more options. 
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Tips for Creating Masks Suitable for the Gradient Mask
Transition Effect

While you can generate a mask in any program that will export to
GIF or PSD format, for this exercise we will assume that you are
working in Photoshop. 

• Launch Photoshop and open a new file.

You generally want to start with a file size that is the same
or approximately the same as the animation that you will
use the mask in. You will also want to select RGB mode,
since many of Photoshop’s filters and features aren’t avail-
able in Grayscale mode.

• Press the letter “D” on your keyboard to ensure that the
foreground and background colors are set to black and
white respectively.

• Select a filter or line art to use as a base for the mask,
then add your own special effects.

A great place to start is with the Filter > Noise > Add Noise
(with the Monochrome setting on) filter, or Filter > Render
> Difference Clouds filter. These filters create random tex-
tures that you can use as starting points for your masks. You
can also start with any line art or patterns that you may
have. Simply convert the line art or patterns to gray values
with the Image > Adjust > Desaturate feature.

Once you have a basic foundation, try any variety of filters.
Our advice is for you to go wild. Just about anything will
work. However, some of the more simple effects might gen-
erate more practical results. For example, the mask used to
generate the dissolving text effect in the earlier example was
created with the Add Noise and Blur More filters. 

Another way to go is to apply a basic black to white gra-
dient. Try diagonal gradients or radial gradients. If you have
a solid line art shape like an ellipse, try applying Gaussian
Blur with a high setting to create in essence a custom
gradient.

PhotoAnimator’s Transition effects offer a wide range of
possibilities for animation. The potential variety offered
with the Gradient Mask transition effect is endless.
Especially since you can combine multiple Gradient Masks,
not to mention all of the other effects found in the Effects
menu in PhotoAnimator. You are limited only by your imag-
ination. Have fun!



152

PhotoAnimator allows you to nest animations within a cell and
then apply effects to them much like you would to any other cell.
In this tutorial you will quickly create and use nested sub-anima-
tions.

Nested Sub-Animations—The Hectic Animation

1. Preview the “hectic_final.paf” animation.

• Open the “hectic_final.paf” file located in the Tutorial 4
folder.

Play the animation several times to get an idea of the
different animations that are a part of it.

Notice that this animation consists of five layers: “Run Left
(Nested),” “Hectic? Take a Break!,” “Barn Door
Transition,” “Run Right (Nested)” and “Background.” The
two layers that are labeled with (Nested) contain animated
animations, or what PhotoAnimator calls Nested Sub-
Animations.

• Click “Run Right (Nested)” layer in the Layers Pane.

This layer contains one 14-frame cell. Notice that when you
select this cell the “Enter” button below the Filmstrip Pane
becomes active.

Click the Enter button.

Tip

Don’t forget that PhotoAnimator
provides multiple levels of Undo.
Simply press Command-Z [Ctrl+Z]
as many times as necessary to
“wind back” your actions.  

You can Redo an undo operation
with Command+Y [Control+Y].

Tutorial 4: Working with Nested Sub-Animations
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When you click on the Enter button PhotoAnimator takes
you into a Nested Sub-Animation work area. The Nested
Sub-Animation Window behaves exactly like it does with
regular animations in PhotoAnimator: You can work with
layers on the Layer Pane, preview the Nested Sub-
Animation in the Preview Pane, and work with frames and
cells in the Filmstrip Pane, just as you can with a normal
animation. 

Preview the Nested animation.

This nested animation consists of a simple loop of a stylized
running stick figure. Notice that the stick figure is running
in a stationary position. As you will soon see, the advantage
of using a Sub-Animation is that you can apply movement
to it externally. In other words, you can move, rotate, resize
or otherwise apply any of PhotoAnimator’s effects to a nest-
ed animation. This means that you can easily make adjust-
ments to the movements of the sub-animation. 

More importantly, your nested sub-animations can have the
same characteristics as normal layers. This means that your
nested animations can move wherever you want them to and
you don’t have to worry about anti-aliasing to other imagery
in the animation. PhotoAnimator takes care of that for you
when you export.

Click the Leave button, then close the
“hectic_final.paf” file without saving changes.
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2. Open the “hectic_start.paf” file located in the Tutorial 4
folder.

• Select the “Run Left (Nested)” layer and create a new
cell on this layer. Resize the cell to 32 frames.

• Select Effect > Basic > Sub-Animation. . . from the
menubar.

• Select Loop from the Frame Action pop-up menu, then
click “OK.”

Click the Enter button at the bottom of the Filmstrip
Pane to open the Nested Sub-Animation work area. 

Click on the empty cell on the Filmstrip Pane, then click
the Trash icon, or press the Delete key on your key-
board.

You’re going to import a file with multiple graphics, so you
first needed to delete the existing cell.

Click the Import button.

• Locate the “run_left.psd” file in the Tutorial 4 folder,
then click “Open.”

The Photoshop Import Options dialog box will be displayed.

• In the Photoshop Import Options dialog box, set the
Layer Wrapping Options to “Horizontal Inline (frames)”
and set Layer Import Direction  to “Top to Bottom.”

• Click “Import” to import the image file.

This imports a seven-layer Photoshop (.psd) document into
PhotoAnimator. With the settings you specified in the
Import Options dialog, each  Photoshop layer was placed in
the animation file as a separate single-frame cell. We now
have a Nested Sub-Animation that contains seven cells.

Tip

To Import an image file, press
Command-I [Ctrl+I].
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Click “Leave” to return to the regular animation
work area.

• Hide all the of the layers in the animation except for the
Run Left (Nested) layer.

Now preview the animation. 

The little character runs in place on the left side of the
screen.

• To help you see the little character more easily, unhide
the Background layer.

Preview the animation again.

Now it’s time to experience the fundamental advantage of a
nested animation. You will make this little guy run across the
entire animation instead of just in place.

4. M a ke the Nested Sub-Animation move across the fra m e.

• Double-click on any frame in the cell on the Run Left
(Nested) layer in the Filmstrip Pane.

This opens the Nested Sub-Animation Settings dialog box. 

• In the Nested Sub-Animations Settings, click the “Move
To” check box (it should now display a checkmark). 

• In the “Location” field, drag  the small white rectangle
of the Image Proxy to the top-right corner of the grid.
Position it so that it is off-screen on the top-most right-
hand edge of the grid. (See screenshot at left.)

• In the “Move To” field, drag the small white rectangle of
the Image Proxy to the top-left corner of the grid.
Position it so that it is off-screen on the top-most left-
hand edge of the grid. (See screenshot at left.)

• Click “OK” to apply the settings and close the dialog.

Once again, preview the animation. 

Notice that the little character runs across the entire animation
from left to right. PhotoAnimator has taken the stationary
nested animation and moved it over the banner making it
appear as if the running character is running from one place to
the other!

Tip

To instantly hide all layers but one,
press the Option [ALT] key while
clicking on the eye icon of the layer
you wish to keep visible. Option-
clicking (Macintosh) or ALT-clicking
(Windows) again will unhide all the
layers.
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Turn on the other layers and preview the entire
animation.

You can non-destructively manipulate the nested animations
as much as you want before you export the animation. Photo-
Animator also allows you to apply effects to nested anima-
tions and nested animations can have multiple layers just like
a normal animation. 

You will discover that you can create awesome animation
effects very easily using Nested Sub-Animations—animations
that would take you hours to create with a traditional gif ani-
mation tool. 

In the final tutorial (Tutorial 5) you will learn about Photo-
Animator’s powerful Export options. 



PhotoAnimator has three export options. You can export as a GIF
animation, as a Photoshop file, and as a PhotoAnimator file or
template. You will look at all three options in this tutorial, but the
lion’s share of this tutorial will deal with exporting a PhotoAni-
mator file to GIF animation. 

Exporting to a GIF Animation—The Banner Ad Animation

When you export to Animated GIF from PhotoAnimator you are
converting the animation from millions of colors (24-bit) to any-
where from 256 to 4 colors (8, 7, 6, 5, 4, 3 and/or 2-bit). Also, all
of the layers are merged down to a single layer for each frame. 

In this first example, you will open a sample banner ad and export
it as a GIF animation. Web banner ads need to download quickly
over the Internet, so the the objective is to get this banner ad
down to the smallest file size possible without sacrificing the
visual quality of the images in the animation.

1. Specify Export Format

• Open the “EPA_ad.paf” file located in the Tutorial 5
folder on the Extensis CD.

Don’t worry about previewing the animation, you will do
that several times within the Export dialog box. 

• Select File > Export. . . from the menubar.

• From the Format pop-up, select “ Animated GIF.”
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Tutorial 5: Export i n g



2. Specify Dithering

• Examine the Dithering pop-up menu and notice that
there are three options: None, Diffusion, and Pattern. 

In general the “None” option provides the best GIF com-
pression. The Diffusion option can be a better choice for
visual quality in some cases. Pattern is an another alterna-
tive to instead of the Diffusion option. 

• For this example, select Dithering: None.

3. Specify Color

• Examine the Color Set pop-up menu. 

PhotoAnimator provides a wide range of palettes, including
the Netscape palette (also known as the “Web palette”) as
well as several Macintosh and Windows palettes. Most ani-
mators will opt for the Adaptive palette which creates an
adaptive palette from the available colors in the layered 24-
bit version of the animation. In most cases the adaptive
palette will result in an animation that looks as close to the
24-bit original version as possible. 

• Select Color Set: Adaptive

Note: As you create content that you will animate in
PhotoAnimator, we recommend choosing colors from the
Netscape palette whenever possible. This will help maintain
the visual integrity of the animation when it is viewed on
8-bit systems. Just be aware that, though the Netscape
palette is often recommended, selecting this palette on
export often results in unnecessary visual quality loss in the
animation when the animation is not predominantly com-
posed of colors from the Netscape palette, such as photo-
graphic images. 

4. Specify Maximum Colors

• Examine the Maximum Colors pop-up menu.  Note that
you have the option of choosing from 256, 128, 64, 32, 16,
8 and 4 colors. 

PhotoAnimator will generate a palette for the animation that
contains no more colors than the number you have selected.
For example, if you choose 64, PhotoAnimator will create a
palette for the animation that contains 64 colors. PhotoAni-
mator will do this while attempting to keep as many colors
from the original 24-bit color version as possible.

However, PhotoAnimator always performs certain optimiza-
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tions for you automatically. For instance, if you choose 64
colors and the image you are exporting actually contains
fewer than 64 colors, PhotoAnimator automatically removes
unused colors from the color palette to ensure that you will
end up with the smallest possible file size.

Note that the Maximum Colors pop-up menu is only avail-
able when Adaptive palette is the selected Color Set pop-up
menu. 

• For now, select Maximum Colors: 256

5. Specify Optimization

Below the Maximum Colors pop-up menu is the Interframe
Transparency Optimization check box. 

If you check this option, PhotoAnimator will optimize the
animation by building transparency into the animation’s
frame whenever possible. Web browsers display GIF anima-
tions by displaying one frame over another. If parts of one
frame contain the same imagery as in the previous frame,
you can reduce the file size of the animation by making
these redundant portions of the frame transparent. 

To demonstrate how valuable this can be, leave this option
off for now.

• For now, de-select (uncheck) Interframe Transparency
Optimization.

Note: Depending on the content of your animations, some-
times this option can actually make the file size larger.
However, PhotoAnimator can calculate the file size of your
animation based on the Export options you specify. You will
see that it is quite easy to compare file sizes as you make
different choices to end up with the smallest file size.

6. Examine Loop options 

With these options you can specify whether you want the
animation to loop indefinitely or not. 

• Select Loop: Forever.

The remaining features in the Animated GIF Export Options
dialog box allow you to preview the results of the options
you have selected before you export. 

This is a very valuable aspect of PhotoAnimator. It means
that you can experiment with various options and preview
them before you actually export to GIF.
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Before you move on, notice that there are two lines that read
“File Size” and “Download Time.” These two lines both
have the word “recalculate” next to them in parenthesis.
This will be explained in a moment.

7. Test your animation with the options you specified

• Click the Calculate/Preview button and watch carefully.

After a few seconds, the Calculate/Preview button will
become grayed out. Notice that there are now values dis-
played by the  “File Size” and “Download time”. 

• Verify that the display indicates the following values:

File Size = 24,928 bytes
Download time = 12 seconds. 

The “File Size” indicator tells you how large the file will be,
in bytes, if you were to export the animation with the cur-
rent settings. The currently displayed values tell you that if
you were to export this banner ad with dithering set to none,
using an adaptive palette with 256 colors, and no interframe
transparency optimization, the animation would have a file
size of 24,928 bytes, which is about 24.9 Kilobytes.

The “Download time” indicator is related to the Connection
Speed pop-up menu, which displays 28.8 Kbps (Kilobytes
per second) by default. Our “Download time” readout indi-
cates that it will take approximately 12 seconds to download
this animation with a file size of 24.9K. If you select a dif-
ferent download speed from the Connection Speed pop-up
menu, this Download time will change to reflect how long it
would take to download the animation at its current file size
on the selected connection speed.

The Download time and Connection Speed options in the
Animated GIF Export Options dialog box allow you to gen-
erate animations that are optimal for your target connection
rate. In other words, if you think that the majority of your
site’s visitors will be connected to the Internet with
14.4Kbps modems, you can use these features to help make
sure that your animations will work within any parameters
that you have set for the site.

Note: The Preview will play back the animation at the
Frame Rate speed you choose from the Animation > Frame
Rate. . . menu before you enter the Export Options Dialog
box. In other words, the playback speed of an animation has
nothing to do with how long an animation takes to down-
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load to the viewer’s page. It takes a certain amount of time
for an animation to download before it will begin its seam-
less playback in the viewer’s browser, and that speed is what
the Download Time calculation is showing you.

Twelve seconds is a long time to have to wait for this ban-
ner ad, especially since banner ads are usually not the only
thing on a Web page. You will need to make this animation
much smaller. Fortunately, with PhotoAnimator this is easy
to do.

8. Minimize download time

• Select Interframe Transparency Optimization by click-
ing the box (checkmark in it). 

Notice that the Calculate/Preview button becomes active
and the “File Size” and Download time” options now dis-
play ”(recalculate).” This indicates that some parameter
used in the previous calculation has been changed and the
values must be recalculated. 

• Click the Calculate/Preview button.

The File Size indicator now shows that the file size has
dropped to 21,643 bytes (21.6K) and the Download time is
now approximately 11 seconds. You have chopped over 3K
off the animation’s file size and cut the download time by 1
second. Not bad, but you’re just getting warmed up!

• Select Maximum Colors: 16, then click the
Calculate/Preview button again. 

Now File Size indicates that the animation would only be
12,264 bytes and the Download time would take a mere 6
seconds to travel over the Internet. In other words, by reduc-
ing the color palette to 16 colors, and turning Interframe
Transparency Optimization on, you can cut the file size (and
thereby the download time) of the animation in half. 

It is nice that you’ve been able to make the animation’s file
size so small, but you don’t want to present a poor quality
animation. You’ve just thrown out 240 colors— will the ani-
mation still be worth looking at? 



9. Preview the animation to verify its visual quality, then
Export the animation

Press the Loop button in the animation Player in the
Export Options dialog, then Preview the animation. 

The Preview window in the Export Options dialog will
show you how the animation will look at the calculated set-
tings. Note that the Preview is not available until a down-
load time has been  calculated.

If you zoom in and study parts of the animation you’ll see
that the animation looks very similar to the original 24-bit
version. But let’s confirm this. 

• Select Maximum Colors: 256 while the animation
Preview is still running.

Notice that you do not have to click on the Calculate/
Preview button again. PhotoAnimator remembers the set-
tings of the previous calculations you chose so that you can
switch back and forth between 256 and 16 colors while the
preview is playing to compare the differences.

Since you have verified that our settings are satisfactory (16
color adaptive palette with no dithering and Interframe
Transparency Optimization turned on), you can now to
export the animation. 

Important: This part of the tutorial is extremely complicated,
so pay very close attention. Even seasoned professionals get
lost when trying to perform this step. Now then...

• Click the Export button.

In all seriousness, that’s all there is to it. PhotoAnimator
takes care of everything for you, automatically generating
an optimized GIF animation from your 24-bit layered
PhotoAnimator document. 
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To fully appreciate this, look carefully at the image below.

This image shows what the exported animation looks like
frame-by-frame. The light and medium gray blocks repre-
sent the portions of the animation optimized with interframe
transparency. In other words, the light and medium gray
portions represent transparency.

Another important thing to notice is that the animation
exported only 14 frames. If you look at the filmstrip layers
in the “EPA_ad.paf” file you will see that some layers are as
many as 45 frames long. However, the majority of these
frames are static duplicates. That is, 32 frames are each
duplicates of one another. The duplicates are there so that
the animation will pause on the last frame long enough for
the viewer to read the text on the banner ad, before the ani-
mation loops back to the beginning and starts over again.

PhotoAnimator recognized the duplicate frames and com-
piled them all into one frame by lengthening the display
time of that frame. While the first 13 frames of the anima-
tion each display for 7/100ths of a second, the last frame of
the animation is displayed much longer: just over two sec-
onds. Including those redundant frames in the animation
would have added to the animation’s file size unnecessarily.
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Tip

You can set the rate of an anima-
tion with the Frame Rate command
located in the Animation menu, or
by pressing Command+G (Mac-
intosh) or Control+G (Windows).



Tips for Keeping GIF Animation File Sizes Down

While PhotoAnimator automates the process of optimizing an ani-
mation’s file size, it can only do so much with what it has been
given. It is very easy to create prohibitively large GIF animations
with PhotoAnimator’s powerful animation features. Consider
these guidelines for keeping your animation files manageable.

1. Keep transitions to as few frames as possible.

For instance, if you are moving a logo across a banner ad and
you have set the motion to occur across 15 frames, could you
achieve a believable effect by using only 10 or even 5 frames?
If your file size is not as low as you want it to be, try resizing
your cells to fewer frames, then compare the difference.

2. Use the Fade transition sparingly.

In order to achieve it’s effect, the Fade transition effect must
add colors to your animation which will make it more difficult
to export your animation at lower bit depths. A lot of the time,
using one of the Wipe or Barn Door transitions will create a
similar effect, but with a much smaller hit on file size. 

3. Try to confine your animation to a small palette.

Heavy use of colorful photographic or 3D images can make it
difficult to export your animation at lower bit depths without
sacrificing image quality.

4. Use the Dithering: None option whenever possible.

The GIF format employs LZW compression, which works
best with contiguous strings of same-color pixels. So the more
dithering in an image, the more difficult it will be for the GIF
format to compress the animation.
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Exporting to Photoshop Format

PhotoAnimator also allows you to export to a layered Photoshop
file. The main benefit to this export option is that it allows you to
export frames created with PhotoAnimator for editing back in
Photoshop. Since PhotoAnimator also imports layered Photoshop
files, you can export out a PhotoAnimator file out as a layered
Photoshop file and then re-import the results back into
PhotoAnimator. This makes PhotoAnimator an excellent anima-
tion companion to Adobe Photoshop. 

And what is really cool about this Photoshop support is that
PhotoAnimator understands all of Photoshop’s transparency and
layer information. (Example: If you create some text on a layer in
Photoshop, and then create a 50% opaque drop shadow of the text
on a separate layer, PhotoAnimator will bring in both layers and
retain the transparency of the drop shadow. Woo-hoo!)

The Photoshop Export Options dialog box contains only two
options, both of which control the Frame Order of the exported
file. You can choose to have the frames ordered from Top to
Bottom (frame 1 of your PhotoAnimator document will translate
to the top layer in the layered Photoshop file, and so on) or you
can elect to have the frames ordered from Bottom to Top (the last
frame of your PhotoAnimator document will translate to the top
layer in the layered Photoshop file, and so on). 

Note that, unlike exporting to the GIF format, all redundant
PhotoAnimator frames are exported as individual Photoshop lay-
ers. For example, our 45 frame example animation will export to
a 45 layer Photoshop file.
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Exporting to PhotoAnimator File or Template

PhotoAnimator’s final export option is to a PhotoAnimator file
(PAF) or template (PAT). The advantage of exporting to a
PhotoAnimator file is that you can then import the file back into
PhotoAnimator as a Nested Sub-Animation. 

Exporting to a PhotoAnimator Template allows you to construct a
layered document in PhotoAnimator that you can use over and
over again by simply swapping in different images. For example,
you might make a template for banner ads so that you can simply
swap in a different message or background and to generate any
number of ads from the template. 

166



167

This tutorial will show you how to use PhotoTexture to create a
texture file to be used on buttons created in PhotoButton. The
following tutorial (Tutorial 6) (page 170) will show you how to
apply that texture to your buttons. For detailed information about
the tools and features presented in this tutorial, see the
PhotoTexture section of this User Guide (page 11).

1. Open Photoshop and create a new RGB document. 

This is the file that you will use for your buttons. The
Photoshop file we created had the following dimensions:

200 x 300 pixels, 72 dpi, RGB, Contents: White

2. Choose “PhotoTexture” from the Extensis menu. 

PhotoTexture allows you specify what you will be using as a
basis for the texture. For this exercise we will be creating a
texture from scratch using  a “blank” workspace. 

In the New dialog box, enter:

Width: 100
Height: 100

3. Choose Contents: Blank, then Click “OK.”

PhotoTexture opens with a blank tile in the Drawing Area.

Tutorial 6: Creating a Te x t u re for Buttons
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4. Start the texture by creating a background color: Click
the “Add Color. . .” button in the Filters list.

Click on the color well and choose a Dark Blue color from
the color picker, then move the Opacity slider to 100%. 

5. Add a droplet effect to the texture by clicking the
“Drops. . .” button in the Effects list.

You can adjust the settings to match the settings we used, or
choose your own. Click “Apply”—this allows you to see the
results of your effect without closing the dialog. When you
are happy with the results, click “OK.”

6. Reapply the Drops Filter by clicking the “Repeat Effect”
button repeatedly until you are happy with the results.
You can also press (Command-E) [Ctrl+E] to apply the
last-used effect. 

For this example, we repeated the Drops effect 10 times.
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7. Add a swirl effect to the texture by clicking the “Twirls. . .”
button in the Effects list. 

You can use whatever settings you prefer; we chose the
default settings. Click “OK” to apply the settings to the
texture and close the dialog.

8. Reapply the Twirls effect by click the “Repeat Effect”
button repeatedly until you are happy with the results.
You can also press Command-E [Ctrl+E] to apply the
last-used effect.

For this example, we repeated the Twirls effect 4 times.

9. Save the texture as a JPEG file by clicking the “Save...”
button in PhotoTexture. Name the file
“blue twirls.jpg” and save it to your

desktop.

This is the texture file that you will import into PhotoButton
and apply to your buttons.

10.Click “OK” to accept the JPEG setting of 75.

11. When you return to the main PhotoTexture dialog box,
close PhotoTexture by clicking
“Cancel.”

Since you have already saved the texture as an image file, you
do not need to Apply it to your Photoshop document.

You can now apply the texture you created to your buttons in
PhotoButton. 
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This tutorial will show you how to create buttons and apply the
texture that you created in Tutorial 5 ( p age 167). For detailed
information about the tools and features presented in this tutorial,
see the PhotoButton section of this User Guide ( p age 49).

1. In Photoshop, open PhotoButton by selecting it from the
Extensis menu (Extensis > PhotoButton > PhotoButton),
then click the “Reset” button.

This resets the button parameters to their default values. 

2. Start creating your buttons with the Shape tab. Verify that
the current button shape is a Circle.

3. Choose “2” from the Vertical Number pop-up menu and
“1” from the Horizontal Number pop-up menu, then enter
a Width and Height of “140.”

This creates two Circle buttons that will be applied to the
Photoshop document we created in step 1 on page 167.

Tutorial 7: Creating Buttons and Adding Te x t u re s

Important

If you did not create a blank docu-
ment as shown in step 1 on page
167, create one now: 200 x 300 pix-
els, 72 dpi, RGB, Contents: White
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4. Click the Bevel tab to select it. Use the following settings:

Bevel Preset: Round
Bevel Width: 20
Bevel Height: 150
Bevel Softness: 0
Inner Height: 50

5. Click the Color tab to select it, then add color to the but-
tons by holding down the Option-Shift [Alt+Shift] keys
while you select a color from the Paint Color pop-up
menu. This fills all the parts of all buttons with the color
you chose.

You could instead use the Paint Bucket to color the buttons by
choosing a color from the pop-up and then clicking each part
of the button(s) you wish to color with the Paint Bucket tool.

Within the Color tab, click on the Inner tab: Choose
Rubber from the Materials pop-up menu.

Within the Color tab, click on the Bevel tab: Choose
Rubber from the Materials pop-up menu.
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6. Click the Texture tab to select it, then click the “Import...”
button. Locate the “blue twirls.jpg” file you saved on the
Desktop earlier.

The texture is now ready to be applied to the buttons.

Alternately, you can drag and drop any JPEG texture file(s)
directly into PhotoButton from the Desktop. If you drag and
drop textures into PhotoButton, be aware that you won’t see
the them until you select the Texture tab.
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7. Apply a texture to the top button by selecting the Texture
Paint Bucket tool, then clicking on the inner
surface and the outer bevel of the top button to

fill that button with the selected texture.

8. Apply a bump map to the bottom button by select the
Bump Map Paint Bucket tool, then click on the
inner surface and the outer bevel of the bottom

button to apply a bump map to their surfaces. 

You can adust the settings of the bump map. These are the
settings we used: Bump Map Blur: 1.0, Bump Map Height: 10

You now have a button with a texture applied, and another with a
bump map applied. Try applying the bump map to the button with
the texture to create a different effect.
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Cut Command-X Ctrl+X
Copy Command-C Ctrl+C
Paste Command-V Ctrl+V
Select All Command-A Ctrl+A
Undo Command-Z Ctrl+Z
Redo Command-Y Ctrl+Y
Import Command-I Ctrl+I
Export Command-E Ctrl+E

Frame Size Command-F Ctrl+F
Frame Rate Command-G Ctrl+G
New Layer Command-L Ctrl+L
New Cell Command-K Ctrl+K
Delete Cell Delete or Del Backspace or Delete
Duplicate Cell Option+Drag cell Alt+Drag cell
Extend Cell Option-Click on blank frame Alt+Click on blank frame
New Cell Shift-Click on blank frame Shift+Click on blank frame

Effect Settings (for currently applied effect) Command-T Ctrl+T

Play/Stop Animation Spacebar Spacebar
Preview Zoom In Command-“+” Ctrl+“+”
Preview Zoom Out Command-“-” Ctrl+ “-”

Hide all layers except this one Option-Click eye icon Alt+Click eye icon
Show all layers including this one Option-Click eye icon Alt+Click eye icon

Select (relative to currently selected)
First Frame in layer Home Home
Last Frame in layer End End
Frame Right à à
Frame Left ß ß
Cell Right Shift-à Shift+à
Cell Left Shift-ß Shift+ß
Layer Up á á
Layer Down â â

New Animation File Command-N Ctrl+N
Open Animation File Command-O Ctrl+O
Save Animation File Command-S Ctrl+S
Close Animation File Command-W Ctrl+F4 or Ctrl+W
Quit PhotoAnimator Command-Q Alt+F4 or Ctrl+Q

Appendix A: Keyboard Shortcuts

Function Performed Macintosh Windows

PhotoAnimator



Cut Command-X Ctrl+X
Copy Command-C Ctrl+C
Paste Command-V Ctrl+V
Select All Command-A Ctrl+A
Undo Command-Z Ctrl+Z
Redo Command-Y Ctrl+Y
Apply Effect  (and close dialog box) Return or Enter Return or Enter
Cancel  (and close dialog box) Command-. or Escape Alt+F4 or Esc
Pan and Zoom

Zoom In Command-“+” Ctrl+Keypad “+”
Zoom Out Command-“–” Ctrl+Keypad “–”

Option+Zoom tool Alt+Zoom tool
Access Hand tool from any tool Spacebar —
Access Magnifier “+”  from Hand tool Command —
Access Magnifier “-”  from Hand tool Option —
Access Magnifier “+”  from other tool Spacebar+Command —
Access Magnifier “-”  from other tool Spacebar+Option —

Fit on Preview Command-0 Ctrl+0
Actual Pixels Command-Option+0 Ctrl+Alt+0
View Composite Layer Command-L Ctrl+L
Parameter Boxes

Move forward one character à à
Move backward one character ß ß
Move forward one box Tab Tab
Move backward one box Shift-Tab Shift+Tab

PhotoCastShadow only
Toggle Show/Hide Outline Command-H —
Reset Shape Options Only Option+Reset Alt+Reset
Constrain to Side movement Adjust tool+Command-Drag Adjust tool+Ctrl+Drag
Constrain Horizontally/Vertically Adjust tool+Shift-Drag Adjust tool+Shift+Drag
Resize from Center Adjust tool+Option+Drag Adjust tool+Alt+Drag
Resize proportionally from Corner Adjust tool+Command-Drag Adjust tool+Ctrl+Drag

PhotoButton only (*affects all buttons)
Fill Inner* Command-I Ctrl+I
Fill Inner* with Pop-up Color Shift-Select color Shift+Select color
Fill Inner* with Extracted Color Shift-Eyedropper-Click Shift+Eyedropper+Click
Fill Bevel* Command-B Ctrl+B
Fill Bevel* with Pop-up Color Option+Select color Alt+Select color
Fill Bevel* with Extracted Color Option+Eyedropper-Click Alt+Eyedropper+Click
Fill Outer* Command-U Ctrl+U
Fill Outer* with Pop-up Color Command-Select Color —
Fill Outer* with Extracted Color Command-Eyedropper-Click —
Fill Part* with Paint Color Option+Paint Bucket-Click Ctrl+Paint Bucket+Click
Show/Hide Grid Command-" Ctrl+"
Show/Hide Outline Command-H Ctrl+H
Resize from Center Pen tool+Option+Drag Pen tool+Ctrl+Drag
Constrain Reshape to Horizontal/Vert Pen tool+Shift-Drag Pen tool+Shift+Drag

Function Performed Macintosh Windows

PhotoEffects  (PhotoButton, PhotoGroove, PhotoCastShadow, PhotoBevel/Emboss/Glow)
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1. Nothing changes in my image Preview when I make
changes using the effect tools.

Each PhotoEffects plug-in allows you to disable real-time
viewing. If you don’t see any changes in your image as you
apply different effect parameters, check the “Options” menu
in the menubar to be sure that “Real Time Preview” is
s e l e c t e d .

2. The background (or other layer) doesn’t appear in the
Effect’s Preview window.

If you expected to see all the layers in your picture and didn’t,
check the “View” menu in the menubar to be sure “View
Composite Layer” has been selected. Also verify that the lay-
ers you wish to view have been selected for viewing in the
Photoshop layers palette.

See also “Additional Information” on page 46.

3. I’m working with a Transparent layer (PhotoButton) and
when I click “Reset” there appears to be no button in the
Preview window.

The default fill color for PhotoButton is “Transparent.” When
working on a normal (not Transparent) layer, for example the
background layer, this feature allows the background image to
“show through” a semi-opaque button. This feature allows
you to create stunning button effects with textures, gradients,
etc. Adding this automatic Transparent fill to an already
Transparent layer results in an apparently “invisible” button.
However, the button is there!

To see the transparent button:

Use the Color controls to fill the button so you can see it. or
use the Reshape tool.

— or —

Select the Reshape tool and move it around the Preview win-
dow—the button frame will appear and show you the button.

For more information on Transparent options, refer to the
PhotoButton section of this User Guide (page 67).

Appendix B: Troubleshooting
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5. When I select a different blend mode in PhotoCastShadow
or PhotoGlow, nothing seems to happen.

The blend mode in PhotoCastShadow and PhotoGlow only
blends the effect with the pixels in the target layer. If there are
no pixels with color in the target layer, you will see no
“blending” in the Preview.
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creating new
Macintosh   94-97
Windows   101-102

finding in library   92-93
for Finder Items, Macintosh   97
for Keystrokes

Macintosh   95
Windows   101-102

for Menu Items
Macintosh   96
Windows   101-102

for Plug-ins and Filters
Macintosh   92
Windows   92

icons, creating your own
Macintosh   100
Windows   102

rearranging   91
removing   90
repositioning   91

C
Cancel command   38, 
Cast Shadow Preset   36, 83
Cast shadows, creating   77-83
Categories of toolbars, accessing   92
Color Modes    48
Color Palette

for Buttons   45, 49, 52, 67-69
for Effects   45
for Textures   10, 17, 21, 26

Color tab in PhotoButton   49, 52, 67-69
Color tools 

for PhotoButton   49, 52, 67-69
for PhotoEffects   See “Color Palette”

Composite Layers
for Effects   40

Composite preview   See “Composite Layers”
Control knob

for adjusting button highlight color   69
Corner Radius, of button   50
Create Glow Only   86

discussed   47
Create Shadow Only   83

discussed   47
Creating New Buttons

for Macintosh toolbars   94-97
for Windows toolbars   101-102

Customize toolbars   
dialog box   92

Cutout, Shadow Preset   83

3-D bevels, creating   71-76, 84
3-D buttons, creating   49-70
3-D shadow effects, creating   77-83

A
Actions Palette Awareness   48
Actions Palette Scripting   46
Adding 

button icons, Macintosh   94-97
button icons, Windows   101-102
buttons to a toolbar   92

Additional Information about effects   46
Adjustment tool

for buttons   49, 58-59
for shadows   78, 82

Anchor button   55-56
Apply command

Effects   36, 38
keyboard shortcut   175

B
Background processing   42
Bevels   See also “PhotoGroove,” “PhotoButton,” 

“PhotoBevel”
and buttons   51, 62-66
Button

adding bump map to   70
coloring   68-69
texturizing   70

creating   71-76, 84
Blend Mode

and shadows   78
unexpected results with   177

Bump Map, adding to buttons   70
Buttons  See also “buttons, toolbar”

See also “PhotoBars”
See also “PhotoButton”

Anchor   55-56
bevels   51, 62-66   
Color   49, 52, 67-69
color modifier keys   68, 175
inner part, discussed   56
matrix   54
number, specifying   54
outer area, discussed   56
parts defined   56
tutorial   167-173

buttons, toolbar   See also “PhotoBars”
adding   92
adding space between   91

Index
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D
Diffuse Angle   52, 69
Distort

button   59, 60-61
shadow   77, 81-82

Drop Shadow Preset   83
Drop shadows, creating  83 

E
Edge Tolerance, of Bevel   
Editor

Bevel Shape   72, 73-75
for Buttons   51, 62-66

Effects   See specific effect (e.g. “PhotoGlow”)
Effects, common elements   38-48
Effect Settings

deleting   37
Presets   37
saving   36
using    37

embedded toolbar   See “toolbars, embedded”
Emboss effect   85
Extensis, contacting   2, 6
Eyedropper tool   

interactive previewing with   45
using, common effects   45
using, PhotoButton   68

F
Files, adding to toolbar (Macintosh)   97
Fill All buttons

for Button Texture   53, 70
for Button Bump Map   53, 70

Fit on Preview command   40
floating palette   See “toolbars, floating”
floating toolbar   See “toolbars, floating”

G
Getting Started

PhotoAnimator   105
PhotoBars   88
PhotoButton   54
PhotoCastShadow   79
PhotoEffects   35

Glow effect   86
Glow Diffusion   86

H
Handles

for Button resizing   54-55, 57
for Shadow resizing   79, 82

Help Box   10, 38, 49, 71, 77, 84, 85, 86, 105
Highlight

of button   49, 52, 69
of bevel   71, 76

Highlight Ratio, button   52, 69  
Hot Help   88   See also “Help Box”

I
Icon Button Editor   (Mac) 94-96, (Win) 101
icons   See “buttons, toolbar icons”
Image Area of button matrix, defined   54  
Image navigator   44
Inclination, of light source   69
Inner button part   See also “Buttons” 

See also “PhotoButton”
adding bump map   70
coloring   68-69
discussed   56
texturizing   70

Inner Height, of button   64
Installation   6
Interactive wireframe

for Buttons   60-61  See also “Shape Outline”
for Shadows   77, 79

Invert 
effect discussed   83
Selection command   78, 83

K
Keyboard commands, creating buttons for

Macintosh   95-96
Windows   101-102

Keyboard shortcuts, listed
PhotoAnimator   174
PhotoEffects   175

L
Last Used Preset discussed   36, 37
Layers

viewing, in Effects   46
unexpected results with   46, 176

Light Direction
Field and Indicator, of Button   49, 69
of Highlight   See “Highlight”

Lock button size   57
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Proxies   112
Sample files, where located   103
System Requirements   103
settings

of animation   109
of effects   110-116
repeat last   110

terms defined   108
Tutorials   120-166

PhotoBars   87-102   See also “buttons, toolbar”
about   9, 33, 87
adding buttons to toolbars   92
adding space between buttons   91
creating new toolbars   91
customizing toolbars  92
Getting Started with   88
icons 

creating (Macintosh)   100
creating (Windows)   102

removing buttons from toolbars   90
showing/hiding toolbars   88-89
SmartBar (Macintosh)   98
toolbars

creating new buttons (Mac)   94-97
creating new buttons (Win)   101-102
customizing   90-93
floating   89-90
embedded   89-90

PhotoBevel   See also “PhotoGroove”
about   8, 33, 84
creating effects   84
Navigator pop-up, accessing   44
Preview window   84
tools, common   38, 43-45
tools, specific   84

PhotoButton      See also “Buttons”
about  8, 33-34, 49
anchor button, explained   55-56
Applying   36, 38
bump map, adding   70
button, parts of   56

defined   56
coloring   68-69
texture, adding to   70

Adjust tool   49, 58-59
Bevel tab   51, 62-66
Color tab   49, 52, 67-69
custom shapes, creating   60-62
Getting Started with   54-59
Grid

enabling   62
size, changing   62

image area, explained   54

M
Matrix of buttons, defined   54
Measurements, in PhotoTexture, specifying   13

Modes, color   48
Moving

Buttons   49, 58-59
Shadows   79, 81

Multiple layers   See “View Composite Layers”
Multiple undos   39

N
Navigating windows   44
Navigator pop-up  44

discussed   44
using   44

Navigator, Preview   44
Neon effect   86

Preset for Buttons, applying   37   
No Highlighting command, of Button   52, 69
None, color choice, of Button   67
Number of buttons, specifying   54

O
Outer button area   See also “Buttons” 

See also “PhotoButton”
coloring   68-69
discussed   56

P
Paint Color, of buttons   49, 52, 67-69
Paint Bucket, using, to color buttons   68
Panning

how to   44
keyboard shortcuts   175

Perspective Blur   
PhotoAnimator   103-119

about   7, 103
effects

Basic   113
creating, how to  110
Image   114
Mask   115
Transition   115, 116

Exporting   118
Filmstrip pane   107
Getting Started with   104
Importing   117
Layers pane   106
Preferences   119
Preview pane, of animation   106
Preview window, of PhotoAnimator   105
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lock button size   57
moving buttons in the image area  49, 58-59
matrix of buttons, defined   54
Navigator pop-up, accessing   44
number of, setting   54
Pen tool   49, 59
positioning   49, 58-59
Preview window   49
Shape tab   50, 60-61
shape

controls identified   49, 50, 58-59
changing   50, 58-59, 60-66
custom, things to know   61
grid   62
new, saving   61
outline, enabling/disabling   62
selecting   55

size
of grid, changing   62
locking   57
manipulating   54-55, 57
specifying   54-55, 57

size of, setting   54-55, 57
Texture tab   53, 70
tools, common   38, 43-45
tools, specific   49, 58-59
unlock button size   57

PhotoCastShadow   77-83   See also “Shadows”
about   9, 33, 77
Applying   36, 38
blur, perspective   78
controls

color   78, 80
noise  78, 80
position   78, 81
shape   78, 82

frame explained   79
Create Shadow Only   78, 83
Getting Started with   79
Invert Selection   83
moving around in the image area   79, 81
multiple shadows, creating   80
Navigator pop-up, accessing   44
noise   78, 80
Perspective Blur   78
Presets   36, 83
Preview window   77
repositioning   79, 81
resizing   79, 82
Shape tab   78
shaping   82
Style tab   78
tools, common   38, 43-45

tools, specific   77-83
wireframe   79

PhotoEffects Plug-ins     
See also specific effects (e.g. “PhotoGlow”)
about   8-9, 33
actions palette scripting, about   48
Additional Information   46-47
Background Processing   42
Color Modes   48
Color Tools   45
common elements listed   34
common elements explained   38-48
composite layers   40
Create Shadow/Glow Only   47 
defined   33
effect Settings   36-37
Fit on Preview   40
modes, color   48
Navigator pop-up   44
panning, how to   44
Preview window, typical   38
Real Time Preview   41
redo, multiple   39
reset all effects   39
undo, multiple   39
undo and RAM   48
View Composite Layers   40
zooming, how to   43   

PhotoEmboss   85
about   8, 33,
Applying   36, 38
creating effects   85
Navigator pop-up, accessing   44
Preview window   85
tools, common   38, 43-45 
tools, specific   85

PhotoGlow   86
about   8, 33, 86
Applying   36, 38
Create Glow Only   86
creating effects   86
Navigator pop-up, accessing   44
Preview window   86
tools, common   38, 43-45 
tools, specific   86

PhotoGroove   71-76
about   8, 33, 71
Applying   36, 38
Bevel Shape Editor   72, 73-75
creating effects   71-76
custom bevels, creating   75
highlighting   76
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Navigator pop-up, accessing   44
Preview window   71
Shape Controls   72, 73-75
shape, saving   75
Style Controls   76
tools, common   38, 43-45 
tools, specific   71-76

PhotoTexture   10-32
about   7, 10
base tile, about   11-12 
base tile, resizing   32
combining with another   30
Creating Textures

from an existing file   16
from scratch   14
from last applied texture   16
from Photoshop selection   15

effects   19, 20, 21-24
Effects and Filters   19-26
filters   19, 20, 25-26
Getting Started   11
pattern repetitions, changing   31
Preview   27
Saving   29
Texture File Options   13
Toolbar   17-18
tools   17, 18
Zooming   28

PhotoTools, overview   7-9
Pixels

in PhotoButton   54-55, 57
in PhotoTexture, specifying   13
toolbar button icon size   100, 102

Plug-ins
one-click access   See “buttons, toolbars” 
PhotoEffects   See “PhotoEffects Plug-ins”

Pop-up
See “Color Palette,” “Navigator”

Positioning 
Buttons   
Shadows   
toolbars   
toolbar buttons   

Presets   
Preview window   See specific effect
Progress bar

Background processing   
Preview processing   

R
Radiance   
RAM Memory and multiple undos   
Real-time Preview   
Redo   
Remove All buttons

for Button Texture   53, 70
for Button Bump Map   53, 70

Reset command  39
Reshape and Resize tools

for bevels   72-75, 84
for buttons   48, 50, 54-55, 57, 58-59
for shadows   78-82

Rotation angle
of buttons   50
of shadow   78

S
Scroll

how to   44
keyboard shortcuts   175

Settings
See “Effect Settings”
See “Style Settings, for text”

Shadow Frame explained   79
Shadows, creating   77-83
Shape controls

for Bevels   72, 73-75, 84
for Buttons   49, 50, 58-59, 60-61 
for Shadows   78, 81-82

Shapes, of Buttons   50, 58-59, 60-61
Shape Outline, of Button   62
Shape tab

PhotoButton   50
PhotoCastShadow   78

Size of Button, specifying   54-55, 57
SmartBar, creating toolbars with   98
Software Requirements   5, 103
Spacing

of Buttons, discussed   54-56, 57
of toolbar buttons, how to   91

Surface Property Controls, of button 52, 67-69
Surface Property tabs   52
Surface Reflectivity, of Button   52, 69   
System Requirements   5, 103



183

T
Technical Support, contacting   6
Textures

adding to buttons   70
creating   10-32

toolbar buttons See “buttons, toolbar”
toolbars

accessing files and folders   9
buttons, adding   92
categories of, accessing   92
changing from embedded to floating   89
changing from floating to embedded   90
customizing   92
embedded   89-90
floating   89-90
Hot Help, for toolbars   88
new, creating   91
Showing/Hiding   88-89
ToolTips, for toolbars   88

ToolTips, for toolbars   88
Transparent

backgrounds in PhotoAnimator   119
color, described   67
layers discussed   46

Tutorials
PhotoAnimator   120-166
PhotoTexture   167-169
PhotoButton   170-173

U
Undo

a command, how to   39, 175
multiple   39

Unexpected Results   see “Troubleshooting”
Unlock, button size   57

V
virtual memory, and RAM discussed   48

W
Watch Me button   98-99
What is PhotoTools?   7-9
Window Navigator   44

X, Y, Z
X Offset, of Shadow   78, 81
Y Offset, of Shadow   78, 81
Zoom

how to
PhotoEffects   43
PhotoTexture   28

keyboard shortcuts   175
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